Jump to content
Sign in to follow this  
reinheitsrobot

2600 video glitch need help

Recommended Posts

Hi - I have a light sixer that needs rehab.  See the photo.  This is an intermittent video problem.  So far this glitch only occurs on Atari Age's Test Cart (awesome btw) and Realsports Tennis.  All other games appear normal.  Ideas of whats causing this?  I can start with the capacitors and the voltage regulator, unless you think going straight to the chip swap is needed.  Any thoughts appreciated.  Thanks!

20200220_203540.jpg

Share this post


Link to post
Share on other sites

I could only describe this like playing a PAL game on an NTSC system.

 

I remember getting something similar back in the day.

 

I'd have to tweak the vertical hold on the TV.  Can't remember which game... I'm old.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...