Jump to content
MrFish

Atari 800XE - System Stability/Integrity

Recommended Posts

According to the Atari Museum, the 800XE wasn't such a great machine. To put it more bluntly, it sounds like it's the mongrel/bastard of an already cheapened 8-bit line.

 

Atari Museum quote:

"The Atari 800XE was the last of the XE line of computer systems.   Having said this it would be assumed that such a system would be the most reliable and well designed system.   However the 800XE turned out to be more of exercise of simply using up existing spare parts and dumping them onto the European market.   The 800XE is plagued with timing issues, incompatibilities and poor reliability since its chipsets are a mis-match of various revision levels and some of the semiconductor components were not within spec or were poor quality components which failed to meet their own spec's.     While the 800XE was produced in small numbers and in the European market, it may be a nice item to add to a collection, but a 130XE is a better choice to actually use in a productive manner."

 

I'm interested in hearing from 800XE owners as to their personal experiences with these machines, if they mirror what's said about them in the Atari Museum quote. Are they really this bad? If they are, how much work is necessary to get one into satisfactory condition?

 

Share this post


Link to post
Share on other sites

I have two here. All I know is that one of them was the only machine I tested which had a lot of timing issues with the UNO cart.

  • Like 2

Share this post


Link to post
Share on other sites

I had one - it had the faulty GTIA in it.

  • Like 1

Share this post


Link to post
Share on other sites

Hello guys

 

The 800XE is just a rebadged European 65XE which is actually a 130XE with all the chips missing that the 130XE needs to access more than 64kB of RAM.  I've never encountered problems that I related to it being an 800XE.  But yes, some have bad GTIA's.

 

Sincerely

 

Mathy

  • Like 3

Share this post


Link to post
Share on other sites
33 minutes ago, flashjazzcat said:

I have two here. All I know is that one of them was the only machine I tested which had a lot of timing issues with the UNO cart.

Alright, sounds like a good case in point.

 

Share this post


Link to post
Share on other sites

There were at least two motherboard versions of the 800XE:

- one came with 8x 8k RAM chips and a motherboard that had only room for these eight RAM chips; the GTIA in these machines was okay;

- the newer one came with 2x 32k RAM chips and a motherboard that has room for 4 of these chips, so you can easily upgrade to 128k RAM; the GTIA in these machines was faulty;

 

Do not know anything about timing problems with the 800XE, since I had them in the 90s and never upgraded them (and flash-carts were not available back then). All the PAL 65XE computers I had however had only the newer boards with 2x 32k RAM chips populated and room for 4 of these chips and a faulty GTIA. Some of these 65XE's from Atari Europe or Atari Benelux even had Atari Basic on an Eprom (instead of a ROM) soldered with a socket and some cables onto the motherboard...

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I concur with Mathy, it is just a 130XE (the version with 4 ram chips 64x4 MB) with two 4464 chips instead of 4, without EMMU and with a different badge. Therefore, quality wise 800XE should be the same than later generation 130XEs, XEGS and 65XEs (like my original first computer that  I already have and use).

And yes, many later generation XE computers and XE game systems came with bad GTIA (not mine...even though it came with 64x4 MB).

 

 

Edited by manterola

Share this post


Link to post
Share on other sites
Posted (edited)

I should have included the first part of the Atari Museum's 800XE page text, in my initial post:

"The Atari 800XE.   A deviation from the numbering system used within Atari from 1985-forward when the company was purchased by Tramiel Technologies Limited from Warner Communications in July of 1984.    The system is packaged in the same case design of the 1985 Atari 130XE.    The 800XE in fact is a cost reduced version of the original 130XE motherboard with only 64K of memory instead of the 130XE's 128K of memory."

 

And I have seen this in the Atari FAQ already:

"The 800XE is identical to the common PAL B version of the 65XE, utilizing the
same PAL 130XE motherboard with Enhanced Cartridge Interface (ECI)."

 

So, I am aware about the motherboard. I've also heard about the faulty GTIA's. But he's making some particular distinction about various other components used in these machines (and I would assume PAL 65XE's too), which differentiates them from Euro 130XE's (and I supposed ALL NTSC XE's).

 

Maybe Curt himself will show up and comment for us.

 

Edited by MrFish
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Here's the quote from the FAQ about the defective GTIA's:

"A substantial number of late-production Atari XE computer systems, especially
later 800XE computers made in China, shipped with moderately defective GTIA
chips."

 

Edited by MrFish

Share this post


Link to post
Share on other sites
11 hours ago, MrFish said:

And I have seen this in the Atari FAQ already:

 

"The 800XE is identical to the common PAL B version of the 65XE, utilizing the
same PAL 130XE motherboard with Enhanced Cartridge Interface (ECI)."

 

So, I am aware about the motherboard.

 

Yes, but that's only true for the later/newer motherboard version with 32k RAM chips!

 

The older motherboard version had 8x 8k RAM chips (one row of chips only!) without any free space for more RAM chips, whereas the older 130XE motherboard had of course 16x 8k RAM chips (two rows of chips) - so the older  motherboard versions of the 800XE and 130XE were different.

 

EDIT: On the internet I found pictures of an 800XE motherboard with two rows of 8k chips however. So maybe the boards with one row of 8k chips were not produced for very long ?

 

Share this post


Link to post
Share on other sites

I have used many 800XE's. They are also around since 1985 (I have seen advertisements of the 800XE on the back of Happy computer magazine from 1985).

 

Except for GTIA issues I can not confirm that the computers are unstable or in another way problematic. I have seen stability issues though but those are not limited to just the 800xe.

 

I remember I had to modify my BlackBox to work properly with my XE's and I can confirm what @flashjazzcat writes: uno cart fails on many of my PAL XE's.

 

But I also have a pretty large collection of 800XL's also suffering from all kind of weird timing behavior. 

 

In the end I am very satisfied with my 800XE's. They never seem to die. Downsides are though: too sharp video with all kind of vertical lines. Sooner or later keyboard dies (I have a large box of failing keyboards), xe case turns into yellow pretty fast, motherboard is ok as long as you leave it alone.

 

I have been using lately an 800xe with faulty GTIA. And where I always hated them I now found it not even that annoying. I can not say I did run into a lot of GTIA crap.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, CharlieChaplin said:

Yes, but that's only true for the later/newer motherboard version with 32k RAM chips!

 

The older motherboard version had 8x 8k RAM chips (one row of chips only!) without any free space for more RAM chips, whereas the older 130XE motherboard had of course 16x 8k RAM chips (two rows of chips) - so the older  motherboard versions of the 800XE and 130XE were different.

 

EDIT: On the internet I found pictures of an 800XE motherboard with two rows of 8k chips however. So maybe the boards with one row of 8k chips were not produced for very long ?

 

I wonder if there are any PAL 65XE examples with the same layout as the 800XE's you mention above?

 

Edited by MrFish

Share this post


Link to post
Share on other sites
27 minutes ago, MrFish said:

I wonder if there are any 65XE examples with the same layout as the 800XE's you mention above?

1246093607_65XE8x8K.thumb.jpg.100883e6c67da6d97fb051a179dc97f5.jpg

Not sure if this is what you're asking for.

Share this post


Link to post
Share on other sites
6 hours ago, Marius said:

I have used many 800XE's. They are also around since 1985 (I have seen advertisements of the 800XE on the back of Happy computer magazine from 1985).

Interesting, as the FAQ states a late 1987 release date for the machines. Atari Museum states 1988.

 

I would like to see some of those advertisements.

 

6 hours ago, Marius said:

Except for GTIA issues I can not confirm that the computers are unstable or in another way problematic. I have seen stability issues though but those are not limited to just the 800xe.

 

I remember I had to modify my BlackBox to work properly with my XE's and I can confirm what @flashjazzcat writes: uno cart fails on many of my PAL XE's.

 

But I also have a pretty large collection of 800XL's also suffering from all kind of weird timing behavior. 

Yes, I've heard plenty of people on here speak of stability issues with XE machines (in general) over the years. I have no reason to doubt what you're saying; I'm just trying to understand exactly what the Atari Museum is talking about in relation to the array of components used on the 800XE/(65XE) machines. If 800XE/(65XE) machines do in fact have some indiscriminate combination of leftover parts, then maybe the Atari Museum's comments about the instability of these machines (which apparently is no different than for other XE's) is falsely being attributed.

 

Yes, I've encountered more problematic XL's than I have problematic XE's. The XE's are more cheaply constructed, but the XL's are also older machines.

  

6 hours ago, Marius said:

In the end I am very satisfied with my 800XE's. They never seem to die.

This definitely seems to conflict with what is being said on the Atari Museum site about the machine.

 

Share this post


Link to post
Share on other sites
5 minutes ago, flashjazzcat said:

1246093607_65XE8x8K.thumb.jpg.100883e6c67da6d97fb051a179dc97f5.jpg

Not sure if this is what you're asking for.

I don't see any ECI there. This is PAL?

Share this post


Link to post
Share on other sites
2 minutes ago, MrFish said:

I don't see any ECI there. This is PAL?

NTSC. AFAIK, it was only this NTSC 65XE which lacked the ECI and the second RAM bank (the ECI was dropped owing to lack of third-party utilisation).

 

Share this post


Link to post
Share on other sites
2 minutes ago, flashjazzcat said:

NTSC. AFAIK...

OK, then no, it's not what I'm asking for. I was curious if there was a PAL 65XE to match the configuration of the 800XE CharlieChaplin was talking about.

 

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, flashjazzcat said:

NTSC. AFAIK, it was only this NTSC 65XE which lacked the ECI and the second RAM bank (the ECI was dropped owing to lack of third-party utilisation).

According to the Atari 8-Bit FAQ:

"  o  PAL versions for PAL B/G television (Europe) or PAL I television (UK)
     - Early units: No ECI
       Most units: PAL 130XE motherboard (including ECI, but only 64KiB RAM)"

 

But I have no confirmation for these early units without ECI, nor have I attempted looking into it yet either...

 

Edited by MrFish

Share this post


Link to post
Share on other sites
2 minutes ago, MrFish said:

I was curious if there was a PAL 65XE to match the configuration of the 800XE CharlieChaplin was talking about.

Oh right: you didn't specify PAL. I actually just had a look and have a rather beaten up 65XE board of the exact same configuration (only 8 RAM sockets, no ECI) with PAL ICs and dual crystals. Whether it came out of the factory PAL I am not 100 per cent sure.

 

It's not even clear to me whether CharlieChaplin is even asserting that this kind of board was found in 800XEs... the conversation is all over the place. :)

Share this post


Link to post
Share on other sites

Without rummaging through my notes... the only "65XE" board is the one lacking the ECI port --this board is also known as the 900XLF.  The 130XE board was used in 130XEs, 65XEs and 800XEs -- and there are at least two major 130XE board styles: 16 RAM slots, or 4.  There are many revisions to each type of those two boards.  I would also disagree with the belief that the ECI port was dropped, rather it was added...

  • Like 1

Share this post


Link to post
Share on other sites
53 minutes ago, kheller2 said:

I would also disagree with the belief that the ECI port was dropped, rather it was added...

Yes, late production NTSC 65XE's had ECI, and apparently only early production PAL 65XE's didn't have them.

 

Share this post


Link to post
Share on other sites

There were ECI NTSC 65XE branded units?  That I would like to see.  I'm not saying it didn't happen, I just find that odd.

Share this post


Link to post
Share on other sites

I will have to dig up the Happy Computer Magazines. 

 

I can remember there was a discussion about this in the past. In the upcoming weeks I am going to my storage and do some householding there. My magazines are stored there, so then I will look it up. 

Share this post


Link to post
Share on other sites
3 minutes ago, kheller2 said:

There were ECI NTSC 65XE branded units?  That I would like to see.  I'm not saying it didn't happen, I just find that odd.

Yes, @manterola mentions owning one in this thread.

 

And the Atari 8-Bit FAQ mentions it:

"  o  Domestic version for NTSC M television (North America)
     - Most units: No ECI
       Late units: NTSC 130XE motherboard (including ECI, but only 64KiB RAM)"

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...