Jump to content
Brad_from_the_80s

Atari Flashback X Custom Firmware for USB roms and boxart

Recommended Posts

On 5/23/2021 at 8:19 PM, Draxxon said:

what version AFBX (standard or Deluxe) do you have, what is the firmware version number in the about screen? do you have a hole on the bottom of your unit labeled reset?

I have the standard version, and the firmware version number is AR3060_v0.1.9....and no, I don't see a hole at the bottom of the console labeled reset.

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah, you have an old one. 

 

AFZ - Registration && Download (atgames.net)

V. 0.1.18 (released on Dec 2, 2019)

 

You have to do the official update first. They have instructions there.
You will need to open your system up, download the android tools and the drivers, connect to a PC, the whole bit.

Youll want to make sure you use a micro usb to usb cable that has a data line in it to connect it to the PC.

youll want to make sure that your computer isnt blocking the android tools drivers digital signature.
(using an older pc with an older version of windows worked for me, other say they found newer updated drivers, different than what atgames gives you, elsewhere on the internet.)

 

Edited by Draxxon

Share this post


Link to post
Share on other sites
11 hours ago, Draxxon said:

Yeah, you have an old one. 

 

AFZ - Registration && Download (atgames.net)

V. 0.1.18 (released on Dec 2, 2019)

 

You have to do the official update first. They have instructions there.

 

I just followed all the instructions, but it didn't do anything. When I powered the console on, it just booted up as normal. It didn't say that an upgrade firmware has been detected.

Share this post


Link to post
Share on other sites
Posted (edited)

did it say "found one loader device" in android tools when you hooked it up to the PC?

Im just guessing, but, either your usb cable doesnt have a data line or your PC is blocking the drivers.

What version of windows are you using?

Edited by Draxxon

Share this post


Link to post
Share on other sites
3 minutes ago, Draxxon said:

did it say "found one loader device" in android tools when you hooked it up to the PC?

Im just guessing, but, either your usb cable doesnt have a data line or your PC is blocking the drivers.

What version of windows are you using?

If you look at these support instructions that come with the downloaded image file, it mentions nothing about Android tools. These are literally plug-and-play instructions. http://legendsultimate.atgames.net/arcade/consoles/AtariFlashbackXFirmwareUpgrade.pdf

Share this post


Link to post
Share on other sites
Posted (edited)

looks like they changed the update info for the newer systems.

 

Step 6 NOTE: if you are unable to update via the steps above, your firmware may not support Y-cables. Please note the current firmware version and contact support@atgames.net for additional help.

The original instructions were here:

legendsultimate.atgames.net/afz/AtariFlashbackX-FirmwareUpgrade.pdf

Edited by Draxxon

Share this post


Link to post
Share on other sites
6 minutes ago, Draxxon said:

looks like they changed the update info for the newer systems.

 

Step 6 NOTE: if you are unable to update via the steps above, your firmware may not support Y-cables. Please note the current firmware version and contact support@atgames.net for additional help.

The original instructions were here:

legendsultimate.atgames.net/afz/AtariFlashbackX-FirmwareUpgrade.pdf

Unfortunately that link isn't working anymore..

Share this post


Link to post
Share on other sites
1 hour ago, Draxxon said:

Since I couldn't access the original pdf file with the instructions, I did some googling and ran across this. I'll give this a try. https://armchairarcade.com/perspectives/2019/10/21/atari-flashback-x-2019-upgrade-to-support-external-usb-drives/

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I did uploaded the pdf too. Its the first file of the 3.

Capture.PNG

Yes, Bill's armchair arcade link is the same thing as the pdf file. 

Edited by Draxxon

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, Draxxon said:

I uploaded the pdf too.

Capture.PNG

Yes, Bill's armchair arcade link is the same thing.

I know you did. But I told you earlier that the pdf won't load at all because it's attached to a dead link I'm assuming.

Even when I downloaded the pdf first, then tried to open it in Adobe Reader, it says the file is damaged.

Edited by DoesItMatter

Share this post


Link to post
Share on other sites
Posted (edited)

1.PNG

2.PNG

3.PNG

4.PNG

5PNG.PNG

6.PNG

7.PNG

9.PNG

i thought you meant the pdf on the site was dead. The pdf I uploaded is my own, not linked to a site. It works on my end, here are the screen shots, but, the one by Bill over at armchair arcade is the same thing.

Edited by Draxxon

Share this post


Link to post
Share on other sites
1 minute ago, Draxxon said:

1.PNG

2.PNG

3.PNG

4.PNG

5PNG.PNG

6.PNG

7.PNG

9.PNG

That is so strange. Why can't I get the pdf to open on my computer??? It won't open in the browser or the PDF Reader...

Share this post


Link to post
Share on other sites

IDK, but the wayback machine link works as well. I just tried it.

 

 

Capture.PNG

Share this post


Link to post
Share on other sites

Hi,

 

I have the Flashback X (AR 3060) and am trying to download the firmware update (I want to add more games), but I am getting an error message that says 

0.0.18 (3) img was blocked because this type of file can harm your device. 

Does anyone know if there is away around this or am I stuck with the system as is, not that there's anything wrong with that.

  Ps: I am in Australia

 

Thanks guys

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/3/2021 at 5:56 PM, pols1968 said:

Hi,

 

I have the Flashback X (AR 3060) and am trying to download the firmware update (I want to add more games), but I am getting an error message that says 

0.0.18 (3) img was blocked because this type of file can harm your device. 

Does anyone know if there is away around this or am I stuck with the system as is, not that there's anything wrong with that.

  Ps: I am in Australia

 

Thanks guys

Here is the most up-to-date firmware (V.0.1.21) for your specific model. Customized to also read files from an OTG adapter and external drive.

https://atariage.com/forums/applications/core/interface/file/attachment.php?id=837186

Edited by Draxxon

Share this post


Link to post
Share on other sites

Hi after reading this post i have bought a flashback x model with reset under console but i have had no success with the otg cable and custom firmware, I have connected the otg fine usb formatted and cfw on usb plugged in and console hangs for a bit then loads in to stock, I am on firmware version 0.1.20 if that is the problem what do i need to do thanks 

Share this post


Link to post
Share on other sites

Hi i managed to get on the cfw 0.1.21 and on the console that is what is  dose say had to do it old way ie push button in then power on with the android release tools etc but i cant get it to show the usb games from the nexus 5,5 pack ,somehow it has never shown the external usb drive can you advise thanks

 

Share this post


Link to post
Share on other sites
7 minutes ago, Draxxon said:

does the system prompt you to press left to update when you power it on?

 

If not, then the system isn't seeing the atari update image.

got the update on the old way but usb drive not an option or showing with otg cable ?

Share this post


Link to post
Share on other sites

just a bit more info when i did the update via usb it caused an error stuck in a update loop so it sees the otg but dose not show ext drive on menu

Share this post


Link to post
Share on other sites

simply put a game in your /game folder to see the Ext USB Drive menu option.

 

add an extra .gme extension to the end of the file.

 

EXAMPLE:
RiverRaid.a26.gme

 

the menu option wont show unless you have at least one game in the /game folder.

I highly recommend Nexus V.0.9.0

Edited by Draxxon

Share this post


Link to post
Share on other sites
1 hour ago, gutter said:

just a bit more info when i did the update via usb it caused an error stuck in a update loop so it sees the otg but dose not show ext drive on menu

Just a guess but maybe you used an older/slower USB 2.0 flashdrive? Maybe it had issues with the update. I recommend a USB 3.0 Device if you don't already have one.

Flashing the system the old/hard way is fine, but, DO NOT flash the Overclock Update that way. It WILL brick your system.

Edited by Draxxon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...