Jump to content
stephena

Stella 6.1 released

Recommended Posts

yeah I've noticed a difference in the picture quality from Stella 6.0 to 6.1, on my Win7 32-bit PC - the screen default size is bigger (good) but the graphics look grainy (not good), is it supposed to be this way? or do I need to change a setting @stephena?

image.png

Share this post


Link to post
Share on other sites

Looks like scanlines are turned on.  Go to Video -> TV Effects and turn the Scanlines Intensity bar all the way to the left (until it says 'Off').

  • Like 1

Share this post


Link to post
Share on other sites

Hi there!

 

I just wanted to say that I love 6.1, Kudos to Stephen and the Stella Team! :) But I do have a question - is it possible to change the snapshots that the UI shows for each game? Id love to be able to change this to box art. Im sure its an easy change, but Im not so great at figuring stuff out sometimes!

 

Thanks!

Share this post


Link to post
Share on other sites

It's not difficult, just a bit of work.  First of all, Stella only supports loading PNG files, so if you have JPEG or some other format, you need to convert to PNG.  There are image converters that will do mass conversion for an entire directory of images, so that isn't really a problem.  Second, they have to be named a certain way.  Basically, download the snapshots.zip file from Stella's webpage and look at the names.  Simply replace each one with your own box art version, and it will work fine from there.

 

So the real work is in collecting all the images, and naming them accordingly.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks very much for the info!  I seem to have a bit more time on my hands these days to tackle that project! As always, you are awesome!

Share this post


Link to post
Share on other sites
20 hours ago, stephena said:

Looks like scanlines are turned on.  Go to Video -> TV Effects and turn the Scanlines Intensity bar all the way to the left (until it says 'Off').

Thanks that worked! I wonder why it (6.1) had 35% when 6.0 was off......

Share this post


Link to post
Share on other sites
3 hours ago, Tifany said:

Hi there!

 

I just wanted to say that I love 6.1, Kudos to Stephen and the Stella Team! :) But I do have a question - is it possible to change the snapshots that the UI shows for each game? Id love to be able to change this to box art. Im sure its an easy change, but Im not so great at figuring stuff out sometimes!

 

Thanks!

snapshots???? In Stella? I've seen them on MAME, but not Stella (unless its on the AtGames Atari Flashback 9 and/or X consoles)

Share this post


Link to post
Share on other sites

Hi

 

and like others said GREAT Work on this and I am getting a Retron 77 delivery says tomorrow so I will  say thanks ahead of time for that port of Stella!!

 

And hope all are safe and hangin in there

 

Mike

Share this post


Link to post
Share on other sites
On 4/7/2020 at 7:46 PM, Arenafoot said:

snapshots???? In Stella? I've seen them on MAME, but not Stella (unless its on the AtGames Atari Flashback 9 and/or X consoles)

Look at Options -> User Interface -> Launcher.  Then play around with Rom info width and the corresponding Image path.  Finally, download the snapshots from the Stella webpage and point the path to those snapshots.

  • Like 2

Share this post


Link to post
Share on other sites

Don't know if this is a problem or not. Or if it's worth youze'all time looking into it at this juncture. After all, the game is WIP. Stella 3.9.3 detects the rom as NTSC. But 6.1.1 detects it as PAL. Manually switching to NTSC makes it look correct.

 

3.9.3

chess_20200421_palette_86_4a_16_2.thumb.png.d707bf150d6021147ed5d14a62dd1620.png

 

6.1.1

chess_20200421_palette_86_4a_16_1.thumb.png.45134fb92cb0c0a47b8e718d786de90f.png

Share this post


Link to post
Share on other sites
On 4/7/2020 at 12:26 AM, Arenafoot said:

yeah I've noticed a difference in the picture quality from Stella 6.0 to 6.1, on my Win7 32-bit PC - the screen default size is bigger (good) but the graphics look grainy (not good), is it supposed to be this way? or do I need to change a setting @stephena?

image.png

 

On 4/7/2020 at 3:51 AM, stephena said:

Looks like scanlines are turned on.  Go to Video -> TV Effects and turn the Scanlines Intensity bar all the way to the left (until it says 'Off').

In addition, the screenshot shows an aliasing pattern when scanlines are enabled. This happens because the window size is too small, and individual lines of the image are smaller in height than one pixel on your display. If you increase the scaling factor in the settings (or go fullscreen), scanlines will should look fine.

Edited by DirtyHairy
  • Like 1

Share this post


Link to post
Share on other sites

This looks like a game properties issue, brought up on FaceBook. Guy's trying to play Im Schutz der Drachen but the joystick doesn't work.


Stella IDs it as Dragon Defender, and has it configured for MindLink:

2076614559_ScreenShot2020-04-23at4_15_07PM.thumb.png.3942b0fb05d2a8ad21bea15fec1b92fb.png

 

If I switch it to Joystick I can control the dragon.  I checked DefProps.hxx and found 3 versions of Dragon Defender in there, but only this specific MD5 is configured for MindLink.

 

 

Share this post


Link to post
Share on other sites

Confirmed, and now fixed in Github.  We'll be doing a 6.1.2 release in a few days to address another issue; this fix will be included in that one too.

  • Like 2

Share this post


Link to post
Share on other sites

Stella 6.1.2 is now released, with a few small (and one not so small) fix.  Changelog as follows:

  • Fixed bug with remapped events not being reloaded in certain cases.
  • Fixed bug in debugger for 3E scheme when displaying active RAM bank.
  • Fixed bug in "Dragon Defender" ROM being misconfigured for Mindlink controller

It can be downloaded from the links in the first post.

  • Like 3
  • Thanks 3

Share this post


Link to post
Share on other sites
7 hours ago, stephena said:
  • Fixed bug with remapped events not being reloaded in certain cases.

Yes!  This is now fixed. 

 

Select and Reset, mapped to 1 and 2 respectively, remain in place after exiting and relaunching.

 

Thank you!

  • Like 1

Share this post


Link to post
Share on other sites

In saw that in a previous post in this thread that Arenafoot had a similar issue but his problem was fixed by turning scanlines off, this was not. I've noticed a display issue that looks to have started between 6.0.2 and 6.1, at least in the Windows build. I take screenshots for mock cartridge labels for the ZPH show and have been noticing for a while that the screenshots weren't pixel perfect any more. I thought it was my method of doing things for the longest time but today I looked into it a bit more.

 

It looks like Stella version 6.1+ are rendering partial pixels, even at 2x, 3x and full screen where versions 6.0.2 and previous were pixel perfect. This might be an incorrect setting on my part but out of the box defaults with TV mode 'Disabled' and Scanlines 'Off', it still persists.

 

(Both below screenshots are taken at 2x then zoomed for visibility)

image.thumb.png.cbbbb3bc918cead961cc0b74c7ba79ef.pngimage.thumb.png.5346bf0721a0a915f8d1f2cfdbe73f1d.png

 

Lining up the different builds, which I did for the first time today, you can see below that version 6.1+ creates approx 10% larger window sizes.

 

(All these versions are set to 2x Zoom)
image.thumb.png.3f647d157b47ec538143956cda775aae.png

 

This might be an issue on my end or something that's already known, but I thought I'd bring it up.

 

- James

 

 

EDIT: Additional information... here are my video settings:

 

image.thumb.png.5f42d9ebaeedad68816bbd2f43f2a90e.png
 

Edited by ZeroPage Homebrew

Share this post


Link to post
Share on other sites

What you see is the result of an improvement in emulation. With this change, Stella is now emulating correct pixel sizes. And these are not square like a digital display's pixel. Also their height is influenced by the number of scanlines created by the ROM. 

 

Previously the height of a pixel was fixed and its width was changed depending on the user's aspect ratio setting. Also there was no correct rounding of this width (if you count the width of a vertical line in your 6.0.2 screenshot you will notice the error, it will become even visually obvious at low zoom, see attachment). This lead to varying window sizes (also PAL was much larger than NTSC). But this is not how a CRT behaves. There the width of a pixel is fixed, and the height changes between NTSC and PAL.

 

So we switched from interpolated pixel width to interpolated pixel height. And we are now correctly interpolating.

Three.s (v1.02) - (Stella 6.0).png

  • Like 2

Share this post


Link to post
Share on other sites

I love fixes like this. You make it any more accurate and a REAL VCS gonna pop outa my computer's ass!

  • Like 1

Share this post


Link to post
Share on other sites

Thanks.

 

And it was quite some work, especially @DirtyHairy invested a lot of brain and labor into the scaling algorithm. Which then affected R77 performance and required some extra measures.

  • Like 3

Share this post


Link to post
Share on other sites
9 hours ago, Thomas Jentzsch said:

What you see is the result of an improvement in emulation. With this change, Stella is now emulating correct pixel sizes. And these are not square like a digital display's pixel. Also their height is influenced by the number of scanlines created by the ROM.

Thanks so much, that makes a lot of sense now. Thank you for making Stella as console accurate as possible!

Share this post


Link to post
Share on other sites
17 hours ago, Thomas Jentzsch said:

Thanks.

 

And it was quite some work, especially @DirtyHairy invested a lot of brain and labor into the scaling algorithm. Which then affected R77 performance and required some extra measures.

Does that imply CRT filters are making a comeback on the R77?  :)

Share this post


Link to post
Share on other sites
On 4/30/2020 at 7:19 PM, ZeroPage Homebrew said:

I take screenshots for mock cartridge labels for the ZPH show and have been noticing for a while that the screenshots weren't pixel perfect any more.

 

Maybe this will work for you - hit TAB to bring up Options:

944522281_ScreenShot2020-05-01at11_17_37PM.thumb.png.fa24b5f50ede31e1280a082d02f62b3d.png

 

 

Click Snapshots...:

1779588452_ScreenShot2020-05-01at11_17_41PM.thumb.png.c4b91e4d5c68d87809d45343658c9b91.png

 

 

Check Ignore Scaling (1x mode).  That results in 320x snapshots (height depends on game, NTSC will be shorter than PAL):

 

1928656728_Aardvark(Demo).png.e1dd429ffd094eddeeebc9565b00dff5.png

 

 

If you need a larger image then use a graphic program to resize it to 640x or 960x, just be sure to do so without interpolation:

 

 

1235501507_Aardvark(Demo)2.thumb.png.60c298d36427df5c3ed69867e6c9ec07.png

 

If you resize using interpolation you end up with those fuzzy pixels:

 

986171337_Aardvark(Demo)3.thumb.png.78d6cb7457c99ae1d131d51e80402a54.png

 

 

Closeup without interpolation:

 

1643718891_ScreenShot2020-05-01at11_32_15PM.png.3e413982ec3043abb6d62d2793744bae.png

 

 

Closeup with interpolation:

1270740241_ScreenShot2020-05-01at11_32_19PM.png.7ae58bebe9f31d445501b48b0c947c5d.png

  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, Rodney Hester said:

Does that imply CRT filters are making a comeback on the R77?  :)

Comeback? They never disappeared. :? 

Share this post


Link to post
Share on other sites

Hi there,

I'm having an issue where Stella freezes randomly while playing Stampede. Same thing happens on both NTSC and PAL ROMs.

I'm using Stella 6.1.2 x64 on Windows (same thing happened on 6.1.1). 

Other games play with no issues. This happens only in Stampede.

 

Any insights? 🙂

Thanks.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...