Jump to content
drac030

SpartaDOS X 4.49 (release version)

Recommended Posts

OK I think you have found the problem... How do you MOUNT a disk images in the sdrives,or fujinet sd cards... That may be the key to helping me see the light...

Do you just load a dos and then format the d2: or d3: drive?? I would think that if I can add a dos to d1: the then hit reset and the dos loads that anything I put in d2:,d3:,d4: would also show up..Maybe I am thinking this wrong...

I know that I can not put a program in d1: and reset it will not load.. I hope this will work with SDX...

 

Peter

 

Share this post


Link to post
Share on other sites

FujiNet - disk images can be mounted remotely with the WWW interface.

SDrive Max - with the screen. I have no idea what about standard SDrive without an LCD screen.

Share this post


Link to post
Share on other sites

OK so how do you "MOUNT" a file/disk etc...Thats the question now... Using SDX or dos xl or mydos or etc....

Yes I have the sdrive-max, sdriive arm, and fujinet... So how do you do it on any of the sdrives????

 

Peter

Share this post


Link to post
Share on other sites

Considering this is a ROM-based OS, is it possible to run it from the UNO Cart, and use it to mount and manage virtual disks from the FujiNet? Sorry if this all sounds silly, but I'm still new to the A8 world, and I hope to learn from the experts around here! Thanks! 

Share this post


Link to post
Share on other sites

@drac030, @trub

I have a question regarding INDUS.SYS driver. As far as I know it doesn't make use of RAM/SRAM charger (if available), would there be a chance in the future to allow track-buffering in case expansion is detected? That's something offered by Super Synchromesh of DOS XL 2.35 I2, but of course to have it in SDX would be much more important :)

Edited by Jacques

Share this post


Link to post
Share on other sites

There is a new beta version of SpartaDOS X available on the relevant website: 4.49f, dated 31 December 2021. It can be downloaded from here: http://sdx.atari8.info/index.php?show=en_download_beta

 

The list of changes relative to the previous beta, 4.49e, is available in the file whatsnew-4.49f.txt

 

Perhaps the most important change in this release is that the CAR: device is no longer limited to 8176 bytes per file. The new limit is 7*8176=57232 bytes per file. To take advantage of that, you have to use the new SDXImager, which handles both formats (the new and the old one). The new imager program can be downloaded from here: http://sdx.atari8.info/index.php?show=en_addons

 

Sorting the directories should now be much improved, as SORTDIR.COM now uses a new, much faster sorting routine. By "much" I mean 40-50 times faster than the old ICD code. The same sorting routine is used by Sparta Commander to sort directories in real-time for display.

 

The ED text editor can now run on VBXE 80-column text console as well as on the software-driven 80-column text console (provided by RC_GR8.SYS).

 

Besides, there were bugfixes and minor improvements all around.

 

65C816 support

==========

Also, this version comes with improved 65C816 support, which is now centralized in a form of unified driver, 65816.SYS (this one is for Rapidus OS, and there is another instance for AltirraOS/816, named 65816A.SYS). Owners of Rapidus and Antonia machines may want to put that driver onto the CAR: device before flashing the SDX ROM, along with the SIO816.SYS - these are available on the Toolkit disk, among few others which can be loaded from the HDD. The immediate effect of configuring the system to use these is that much more conventional RAM would be free - as the new drivers load to the RAM past the first 64k. All this is also usable on Altirra.

 

The 65816.SYS driver, among other things, contains the binary loader able to load relocatable binaries in SpartaDOS X format to the RAM past the first 64k. Such binaries can be built using the assembler ELSA http://drac030.krap.pl/pl-elsa-pliki.php

 

Below I am attaching some small demo program which may help to test, if the 65816 support stuff is properly configured. It requires VBXE. The source code is included.

 

Have fun.

 

stars3dr.arc

Edited by drac030
typos
  • Like 11
  • Thanks 2

Share this post


Link to post
Share on other sites

Something is broken with the new DOSKEY on the cart.  Unfortunately, when pressing TAB the system locks up, and needs a cold restart to recover.  This is on a clean boot, with no config file loaded, and no aliases.ini loaded.  When reverting back to 4.49e, everything is OK.  I believe with my previous setup, the aliases were working fine.

 

My system that I am testing this on, is a PAL 1088XLD which uses the U1MB upgrade.

Share this post


Link to post
Share on other sites
11 hours ago, Stephen said:

Something is broken with the new DOSKEY on the cart.  Unfortunately, when pressing TAB the system locks up, and needs a cold restart to recover.  This is on a clean boot, with no config file loaded, and no aliases.ini loaded.  When reverting back to 4.49e, everything is OK.  I believe with my previous setup, the aliases were working fine.

 

My system that I am testing this on, is a PAL 1088XLD which uses the U1MB upgrade.

Can confirm. I have got the same issue on my 800XL U1M.

  • Like 1

Share this post


Link to post
Share on other sites

Excellent catch, thank you very much. It is a bug in the library (so replacing DOSKEY does not help). We will most probably upload a fixed revision today.

 

As about the SDX Imager, it has been heavily rewritten, so if something does not work, please report - either here or to @trub.

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, drac030 said:

Excellent catch, thank you very much. It is a bug in the library (so replacing DOSKEY does not help). We will most probably upload a fixed revision today.

 

As about the SDX Imager, it has been heavily rewritten, so if something does not work, please report - either here or to @trub.

I am getting a file corruption when editing CONFIG.SYS.  I'm using SDXImage.exe via wine/linux.

 

CONFIG.SYS exactly as I have added the change at the "DEVICE SIO" line

803746177_CONFIG.SYSbeingedited.thumb.jpg.6bb46f188f0ea069135095d9d5265fc5.jpg

 

Reviewing CONFIG.SYS after editing has been completed

1422982314_CONFIG.SYSafterediting.thumb.jpg.8102ccb27629c40fb96b57693cfb33cd.jpg

 

2 Bytes appear to be added to the beginning of the text while 1 or more bytes are removed from the end.

 

-SteveS

Share this post


Link to post
Share on other sites
10 minutes ago, a8isa1 said:

I am getting a file corruption when editing CONFIG.SYS.  I'm using SDXImage.exe via wine/linux.

Please check if the problem occurs with the latest version 3.1.1 (I put it on the site a few hours ago).

Share this post


Link to post
Share on other sites
2 hours ago, trub said:

Please check if the problem occurs with the latest version 3.1.1 (I put it on the site a few hours ago).

Problem fixed.  Thanks!

 

Sorry for the false alarm.  I didn't think to look for an update of SDXImage since a day or two ago.

 

-SteveS

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

 

I've been trying to find out what all parallel disk devices SpartaDOSX is compatible with and what their device registers are.  On page 167 of the SpartaDOSX User Guide I found the following:

 

This driver must be included in the 'CONFIG.SYS' file since it contains all the code to
handle high speed SIO operations with e. g. US Doubler, Indus GT, and all other high
speed drives, if recognized. It also handles the standard speed SIO with all other drives
and the standard parallel I/O (PIO) with devices such as the KMK/JŻ IDE 2.0 Plus, MIO,
MSC, etc. DEVICE SPARTA must precede DEVICE SIO in CONFIG.SYS

 

While MIO specifications are available in the Altirra Hardware Reverence, MSC, KMK/JZ IDE 2.0 Plus, and etc. (lol) aren't.  Does anyone know who may have these specs or who to contact?

 

I am particularly interested in creating an SD Card interface to the parallel port and using the SD card as a drive.  It makes sense to use drivers that already exist, if possible.

 

Thanks!

 

Share this post


Link to post
Share on other sites
7 minutes ago, reifsnyderb said:

I am particularly interested in creating an SD Card interface to the parallel port and using the SD card as a drive.  It makes sense to use drivers that already exist, if possible.

A large number of soft and ROM-based drivers already exist for the 'APT' standard. PM'd.

 

Edited by flashjazzcat

Share this post


Link to post
Share on other sites
On 9/5/2021 at 1:17 PM, Peter Rabitt said:

OK so how do you "MOUNT" a file/disk etc...Thats the question now... Using SDX or dos xl or mydos or etc....

Yes I have the sdrive-max, sdriive arm, and fujinet... So how do you do it on any of the sdrives????

 

Peter

You just use the F commands in SDX. THey are all available at atari-apps.irata.online. Mount the FujiNet Tools and copy the commands over to your disk you use with SDX. Now use  FMOUNT for instance to mount a disk into a slot. SDX will see it.

 

Screen Shot 2022-01-12 at 12.47.51 PM.png

  • Like 2

Share this post


Link to post
Share on other sites

Is anyone else having trouble with SC 1.07 (and the new SDX 4.49g) and the "Move" command?  Tagging multiple files works fine if I do a Copy, or Delete.  When I try Move, I get an error 156.  I do not yet know if turning off DOSKEY (or the aliases) will fix this.  I can do more testing after I finish work this evening.

Share this post


Link to post
Share on other sites
3 hours ago, _The Doctor__ said:

The guide along with this and perhaps a little talk with John, Konrad, and Trub... could be enlightening, some discussion about the pbi specifications to get along with other devices and such could be fruitful.

http://sdx.atari8.info/sdx_files/4.49/SDX449_Programming_Guide_EN.pdf

Thanks!  I've been in communication with flashjazzcat.  The programming guide isn't too helpful, unfortunately.  I've been looking at the Earl Rice articles, various online technical books on the Atari, Mapping the Atari, and a bunch of other places.

Share this post


Link to post
Share on other sites

I found a typo early on in the Preface of the manual: "It is also assumed that terms such as "PORTB" are do not need to be explained."

Also, headers still say 4.48.

 

Share this post


Link to post
Share on other sites
17 hours ago, Stephen said:

Is anyone else having trouble with SC 1.07 (and the new SDX 4.49g) and the "Move" command?  Tagging multiple files works fine if I do a Copy, or Delete.  When I try Move, I get an error 156.

I just checked it quickly, move works here. SCMAIN.OVL 15849 bytes, 15 Oct 2021 21:33. So more information is needed. BTW. 156 is Bad parameter, a weird error indeed. Could you try reflashing the ROM?

 

15 hours ago, reifsnyderb said:

The programming guide isn't too helpful, unfortunately.

Its intention is to provide information on how to write application programs rather than drivers. I hope that the next version will contain that section too. What you seem to need is a sector I/O driver, the chapter dealing with that is to be found in this thread, here:

 

There are few minor inaccuracies, which I fixed already, but they should not impair anyone much.

 

11 hours ago, Kyle22 said:

I found a typo early on in the Preface of the manual: "It is also assumed that terms such as "PORTB" are do not need to be explained."

Yup, fixed, thanks.

 

11 hours ago, Kyle22 said:

Also, headers still say 4.48.

That is to be fixed too, thanks.

  • Like 3

Share this post


Link to post
Share on other sites
13 hours ago, drac030 said:
On 1/12/2022 at 1:33 PM, Stephen said:

Is anyone else having trouble with SC 1.07 (and the new SDX 4.49g) and the "Move" command?  Tagging multiple files works fine if I do a Copy, or Delete.  When I try Move, I get an error 156.

I just checked it quickly, move works here. SCMAIN.OVL 15849 bytes, 15 Oct 2021 21:33. So more information is needed. BTW. 156 is Bad parameter, a weird error indeed. Could you try reflashing the ROM?

Sorry for the false report.  I tried to recreate the error tonight, and all is working as expected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...