Jump to content

Recommended Posts

I have a 99/4 with only the bottom cover removed, it doesn't work but the LED Light burns and black screen with a whistle Tune

 

have not opened it further so far, just looked at the power supply and there is very little built in :)

I have never seen such so a power supply !

it has an EU power connector but a 5 pin TV connection (Europe = 6 Pin !)

P1070269.JPG

P1070273.JPG

P1070274.JPG

P1070278.JPG

P1070276.JPG

P1070277.JPG

P1070282.JPG

  • Like 4

Share this post


Link to post
Share on other sites
Posted (edited)

For this model with sound inside, you need a special power supply.

This model has no internal power supply.

and you will be lucky if you have nothing destroyed

 

Jean louis

Edited by humeur
  • Like 1

Share this post


Link to post
Share on other sites

This is the power suplly for this ti99/4a.

 

did you check the tensions.

 

 

ALIMTI994.thumb.JPG.df3bf50dc8a189522506552b07a13373.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Ok the power supply is a same after we need to investigate more and without a minimum of knowledge it's going to be difficult.

Share this post


Link to post
Share on other sites

Nice model and really early production date from 1979! wow!

My only 99/4 is from 1981.

My 99/4 joysticks (same product code:PHP1100) are also from 1981.

 

Also interesting that it is for Europe, but produced in the USA.

Do we know, were all the 99/4s for Europe produced in the USA?

 

Did the console came with anything else? Manuals, Sheets, accessories?

 

I also remember that there are 99/4 that require a different external power supply. so please be careful.

 

Is it true that the motherboard as such with needing the same voltages as every TI-99?

 

So is it only a matter of providing the correct voltages by the right combination of external and internal power supplies?

 

Here I see the 99/4 (1037231-1) requires +5, -5, +12 and GND via individual wires.

http://www.mainbyte.com/ti99/computers/motherboard_ti994.html

 

And the 99/4A has the 4 pin cable that seems to also get the input for +5, -5, +12 and GND.

http://www.mainbyte.com/ti99/computers/motherboard_ti994a.html

 

But it looks to me that it is only a matter of getting the wires to the right target location on the mainboard.

 

You can check if the 4 pins from the power plug simply only connect into the 4 voltage connectors on the motherboard, if that is the case, then you indeed have no internal power supply and this would mean the external power supply needs to provide the 4 voltages at the 4 pins, each at the correct pin.

 

Greetings from Vienna :)

  • Like 1

Share this post


Link to post
Share on other sites

On the model with the internal speaker the power is external see the photo that I put. The 4 power supply pins of the ti are in this case use unlike the other model where only three pins are used, moreover on this power supply one pin is larger than the others it serves to avoid an error.

On all other models except this one the voltages are AC but for this is DC.

 

Jean louis

Share this post


Link to post
Share on other sites

the 99/4 lives, played around a little and noticed, when I try to insert a Module and the first Contact is made, the screen opens

 

when i plug it in completely I have the black Screen with a beep

 

I opened the 99/4 and took Pictures and also exchanged the Module Port, it doesn't change

P1070331.JPG

P1070333.JPG

P1070334.JPG

  • Like 6

Share this post


Link to post
Share on other sites

This 99/4 variant was the first version to be released in Europe. Based on production dates I've seen in the past and the two that I have like this, none were manufactured later than about the end of February 1980. Yours is the earliest date I've seen for one of them, by about five weeks.

 

As already noted, beware of using the wrong power supply, as any later power supply outputting AC will destroy the machine.

 

These were sold at the time TI only sold consoles as a set with included monitor, and all monitors used by TI at that time were NTSC, which explains the monitor connection.

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...