Jump to content
Sign in to follow this  
marioxb

Erased the stock roms on my Flashback X, help!

Recommended Posts

Posted (edited)

Hi, so I think I accidently erased all the stock roms on the Flashback X, using nothing more than Android Tool. I'm not sure exactly what happened, but I tried to update it to add USB support. I followed the steps here, https://armchairarcade.com/perspectives/2019/10/21/atari-flashback-x-2019-upgrade-to-support-external-usb-drives/ and flashed it via Android Tool. Again, I'm not sure exactly what happened, but I don't actually have a Y cable yet, I just wanted to flash it while I had the thing unscrewed. I may have possibly also flashed the deluxe firmware from  https://firmwareupdate.atgames.net/registration to see if the 10 bonus games would magically show up. They did, kinda, but had no box art and weren't playable. Then I discovered that NONE of my games were playable anymore. I went back and flashed the non deluxe firmware and tried the USB firmware again. My menus are back to normal, but none of the games run. Selecting a game will either result in black screen that only cutting the power will "fix" or it does nothing at all. I emailed AT Games and they simply linked me to this forum and https://firmwareupdate.atgames.net/registration as well as instructions for a unit that takes SD cards, which of course the X mini does not. Anyone have a backup of the ENTIRE firmware, including the roms? Because I think I erased the roms. 

Edited by marioxb

Share this post


Link to post
Share on other sites
Posted (edited)

It sounds like it didn't update all the way, and its missing some files, just update it again is all.

 

Flashing the AFB9 Gold onto a reg AFB9 works because everything is already on the reg 9. Flashing an X Deluxe onto a reg X wont give you the bonus games because they aren't on the reg X. you just get entries in the list for games that you don't have on the system. I tried it already. (I think in the afbx thread) but I just flashed it back. I flashed the afb9 custom firmware onto the x and flashed it back, even. So I'm not sure whats wrong here. Try a different usb cable. Or try an older pc running an older version of windows. Or try flashing it the old way with a y-cable now when you get one and see if you got otg support. And if all else fails, flash the custom firmware. With that you can deff get it all working, including the 10 missing bonus games.

Edited by Draxxon

Share this post


Link to post
Share on other sites

At my installation something went wrong also. After all the steps some of my games didnt start. Instead some game pictures were just empty on the dashboard. I had to update it (by pressing left if asked on startup) again. Means, I copied the update file (0.0.18 or so from the flashback site) to the sd card and started the console. In your case it means youll need an y-cord for the USB-Stick of course. After that some broken games were fine again. Perhaps it will help you to get your games back.

  • Like 1

Share this post


Link to post
Share on other sites

OK, thanks guys. I'll give it a go when I get the Y cable. There's got to be some way to restore the lost games.

Share this post


Link to post
Share on other sites
Posted (edited)

Hey, so I found some Atari Flashback X's for $20 and I purchased two more. I hooked one of em up, and it's experiencing the exact same issue as the above, and I never even connected this one to a computer! What the hell is going on here? Selecting any game gives me a frozen black screen or a reset to the menu. Any ideas?

Edited by marioxb

Share this post


Link to post
Share on other sites
1 hour ago, marioxb said:

Hey, so I found some Atari Flashback X's for $20 and I purchased two more. I hooked one of em up, and it's experiencing the exact same issue as the above, and I never even connected this one to a computer! What the hell is going on here? Selecting any game gives me a frozen black screen or a reset to the menu. Any ideas?

$20 where????

Share this post


Link to post
Share on other sites
52 minutes ago, marioxb said:

Family Dollar. They were marked $40, but scanned at $20

Argh, I tried a few of them in my area (Northern NJ) before the pandemic but they didn't carry them at all.

Share this post


Link to post
Share on other sites

Yeah, I found em in this little hole in the wall town I was staying at in Alabama.

Share this post


Link to post
Share on other sites

I checked in my area, too, but they were out of stock.

 

I was told that they were originally sold for last Christmas, and now they are trying to sell off any remaining stock.

 

So they may be hard to come by these days.

Share this post


Link to post
Share on other sites
Posted (edited)

sounds like the systems aren't updating completely. Games aren't launching and thumbnails aren't showing up because they failed to flash to the system during the update.

try doing the update from a different PC. I had some issues and found it worked when I did it from an older PC I had.

Edited by Draxxon

Share this post


Link to post
Share on other sites
34 minutes ago, Draxxon said:

sounds like the systems aren't updating completely. Games aren't launching and thumbnails aren't showing up because they failed to flash to the system during the update.

try doing the update from a different PC. I had some issues and found it worked when I did it from an older PC I had.

Thanks, I'll try. The second one was just fresh out of the factory sealed package.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...