Jump to content
CharlieChaplin

turn OS-B carts into XL/XE carts, please...

Recommended Posts

Well, I made a proof of concept on Altirra, putting TRIG3 ($D013) on GINTLK ($03FA) every frame. It worked fine.

 

I just put an small VBI routine on $100, forcing GINTLK with TRIG3.

 

If we find enough bytes on the ROM, we can add this routine and make it work. I will see it now.

 

image.thumb.png.af8e568d1ae0046d9806f19ea062d591.png

  • Like 2

Share this post


Link to post
Share on other sites
21 hours ago, FULS said:

Also, besides fixing the Astro Chase Carts, is there a Monster Maze cart that works on the OsB and XL machines.

 

Thanks

I looked into the cartridges. There is an illegal call into a keyboard routine. Maybe if we can generalize that call, we can fix it.

 

Here's a beta that should do the trick. Please let me know if you find any bug.

Monster Maze (1982)(Epyx) beta.bin

  • Like 1

Share this post


Link to post
Share on other sites

Thank you guys for all the work in converting these.

I have one more request.

Is there a Pool 400 cart that works on both the OsB and XL computers?

 

I have these two images, one works on OsB only and the other XL only.

On a Hex editor they look very similar. I'm thinking each one makes an illegal call into the OS.

Pool 400 (OsB).bin

Pool 400 (XL_XE).bin

Thanks

Share this post


Link to post
Share on other sites
17 hours ago, larryleffaovell said:

There is an already working version I linked earlier. Try this one...

Pool 400.zip 12.69 kB · 10 downloads

Hi,

I tried using Altirra in XL mode but couldn't get your Bin to work.

Would you retry with XL and see.

I might have my settings wrong.

Also I couldn't get your Monster Maze to work in XL mode.

Wilheim's (Post #52) works fine.

Thanks

Edited by FULS

Share this post


Link to post
Share on other sites

Hmm, you're right. Interesting. I'm doing all my tests with the atari800 emulator as I'm on Linux... The binary loads and shows the initial screen with both, 800 and XL/XE, but only when setting is 800 the game is working correctly and hangs on XL/XE. Tried the atari++ emulator and there XL/XE runs the binary but hangs at start and crashes with crashed at $a003 illegal opcode $02 when set as 800.

Weired. Seems that something's borked with this cartridge or dump.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...