Jump to content
Sign in to follow this  
traindriver69

How to run Bas files from Atr Images

Recommended Posts

Hi all

Sorry in advance if I am sounding thick but I have an atari 400 computer and a sdrivemax drive plugged into it now I now how to load a bas file on its own as a tape via the sddrive but I have got some atr images which boot up into dos 2.5 when I search the disk it shows it has bas files on it but how do I get the bas files to load off the disk image.

Again sorry if I sound stupid but any help would be great.

Many Thanks in advance

Share this post


Link to post
Share on other sites

Hmmm,

if you´ve installed the Basic Cartridge, you can press "B" in DOS 2.5,

to jump into Basic, than you´re able, to load the *.bas files from your atr.

 

Gtx.,

andY

Share this post


Link to post
Share on other sites

Or you take "Turbobasic XL",

 

there is also a Version for ATARI 400 available, here:

 

->  TURBO-BASIC XL

 

(Scroll down to "ATR-Images)

 

Gtx.,

andY

  • Like 1

Share this post


Link to post
Share on other sites
48 minutes ago, traindriver69 said:

So I need to buy a basic cartridge to run bas off an atr.

On the original Atari 400/800 you are correct.  The later XL/XE series had Atari BASIC onboard in ROM.

 

You should be able to find a BASIC cart really cheap.  RAM gets tight on a stock 400.  If you plan on doing much you might consider upgrading to 48K if you haven't already.  Especially if using DOS.

 

 

  • Confused 1

Share this post


Link to post
Share on other sites

Once you get the cartridge boot the disk to the ready prompt and type the name of the file in this fashion.

 

RUN"D:filename.bas

 

That will load and run the file, if you want to just load it then replace RUN with LOAD

 

If you are unsure of the filename then at the ready prompt type DOS (as long as the disk has DOS on it) and press A to directory the disk and then when you have the file name press B to return to BASIC and repeat the first command.

Share this post


Link to post
Share on other sites
15 hours ago, kogden said:

On the original Atari 400/800 you are correct.  The later XL/XE series had Atari BASIC onboard in ROM.

The stock 1200XL also doesn't have on-board BASIC.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...