Jump to content
Sign in to follow this  
memelord

Retroarch: failed to open libretro core

Recommended Posts

whenever I load up a Neo Geo rom, or ANY core I downloaded, I get an error. here is the log for the Neo Geo core. I use a Raspberry Pi Zero with Lakka as the OS.

 

 

 

 

[ERROR] Failed to open libretro core: "/tmp/cores/mame2003_plus_libretro.so"
[ERROR] Error(s): /tmp/cores/mame2003_plus_libretro.so: wrong ELF class: ELFCLASS64
[ERROR] Failed to open libretro core: "/tmp/cores/fbalpha2012_neogeo_libretro.so"
[ERROR] Error(s): /tmp/cores/fbalpha2012_neogeo_libretro.so: wrong ELF class: ELFCLASS64
[INFO] Using content: /storage/roms/THEC64/retropie/roms/neogeo/galaxyfg.zip.
[INFO] arg #0: retroarch
[INFO] arg #1: /storage/roms/THEC64/retropie/roms/neogeo/galaxyfg.zip
[INFO] arg #2: -s
[INFO] arg #3: /storage/savefiles
[INFO] arg #4: -S
[INFO] arg #5: /storage/roms/THEC64/retropie
[INFO] arg #6: -c
[INFO] arg #7: /storage/roms/THEC64/retropie/RetroArch-0120-124945.cfg
[INFO] arg #8: -L
[INFO] arg #9: /tmp/cores/fbalpha2012_neogeo_libretro.so
[INFO] arg #10: -v
[INFO] Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] Unloading game..
[INFO] Unloading core..
[INFO] Unloading core symbols..
[INFO] Threaded video stats: Frames pushed: 25428, Frames dropped: 0.
[INFO] Set config file to : /storage/roms/THEC64/retropie/RetroArch-0120-124945.cfg
[INFO] RetroArch 1.8.4 (Git 9e25601a56)
[INFO] Redirecting save file to "/storage/savefiles/galaxyfg.srm".
[INFO] Redirecting savestate to "/storage/roms/THEC64/retropie/galaxyfg.state".
[INFO] === Build =======================================
[INFO] Capabilities: 
[INFO] Built: Jan 20 2020
[INFO] Version: 1.8.4
[INFO] Git: 9e25601a56
[INFO] =================================================
[INFO] Loading dynamic libretro core from: "/tmp/cores/fbalpha2012_neogeo_libretro.so"
[ERROR] Failed to open libretro core: "/tmp/cores/fbalpha2012_neogeo_libretro.so"
Error(s): /tmp/cores/fbalpha2012_neogeo_libretro.so: wrong ELF class: ELFCLASS64
[INFO] [Environ]: SET_PIXEL_FORMAT: RGB565.
[INFO] Redirecting save file to "/storage/savefiles/galaxyfg.srm".
[INFO] Redirecting savestate to "/storage/roms/THEC64/retropie/galaxyfg.state".
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 30000.00 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [Video]: Starting threaded video driver ...
[INFO] [EGL] Falling back to eglGetDisplay
[INFO] [EGL]: EGL version: 1.4
[INFO] [EGL]: Current context: 0x1.
[INFO] [GL]: Found GL context: videocore
[INFO] [GL]: Detecting screen resolution 1360x768.
[INFO] [EGL]: eglSwapInterval(1)
[INFO] [GL]: Vendor: Broadcom, Renderer: VideoCore IV HW.
[INFO] [GL]: Version: OpenGL ES 2.0.
[INFO] Querying EGL extension: KHR_image => exists
[INFO] [GL]: Using resolution 1360x768
[INFO] [GL]: Default shader backend found: glsl.
[INFO] [Shader driver]: Using GLSL shader backend.
[WARN] [GL]: Stock GLSL shaders will be used.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] Setting up menu pipeline shaders for XMB ... 
[INFO] [GLSL]: Compiling ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling simple ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling modern snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling bokeh shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snowflake shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] Shader log: Compiled
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GL]: Using 4 textures.
[INFO] [GL]: Loaded 1 program(s).
[INFO] : Using font rendering backend: freetype.
[INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver.
[WARN] [udev]: Couldn't open any keyboard, mouse or touchpad. Are permissions set correctly for /dev/input/event*?
[INFO] [udev]: Plugged pad: MY-POWER CO.,LTD. 2In1 USB Joystick (3727:3) on port #0.
[INFO] [Autoconf]: 306 profiles found.
[INFO] [udev]: Pad #0 (/dev/input/event0) supports force feedback.
[INFO] [udev]: Pad #0 (/dev/input/event0) supports 16 force feedback effects.
[INFO] [Joypad]: Found joypad driver: "udev".
[WARN] [udev]: Full-screen pointer won't be available.
[INFO] [Video]: Found display server: null
[INFO] Found shader "/tmp/shaders/bilinear.glslp"
[INFO] Found shader "/tmp/shaders/nearest.glslp"
[INFO] Found shader "/tmp/shaders/slang-conversion-template.glsl"
[INFO] Found shader "/tmp/shaders/stock.glsl"
[INFO] ALSA: Using signed 16-bit format.
[INFO] ALSA: Period size: 384 frames
[INFO] ALSA: Buffer size: 1536 frames
[INFO] [Menu]: Found menu display driver: "gl".
[INFO] : Using font rendering backend: freetype.
[INFO] [Autoconf]: selected configuration: /tmp/joypads/udev/MY-POWER_CO__LTD__2In1_USB_Joystick.cfg
[INFO] : Using font rendering backend: freetype.
[ERROR] Failed to open libretro core: "/tmp/cores/fbalpha2012_neogeo_libretro.so"
[ERROR] Error(s): /tmp/cores/fbalpha2012_neogeo_libretro.so: wrong ELF class: ELFCLASS64
[INFO] : Using font rendering backend: freetype.
[INFO] : Using font rendering backend: freetype.
 

 

 

 

 

how can I fix this? or is it something beyond my control because god hates me.

Share this post


Link to post
Share on other sites

also, all the cores I downloaded/added do not work. the built in ones do. why? does this problem even exist? what am I doing wrong?

Share this post


Link to post
Share on other sites

so, I figured out I was downloading the wrong cores. so I switched over to the ARMHF and ARMV7. those cores just reboot the console instead of running. how does that happen?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...