Jump to content

Recommended Posts

Jon, I tried to send a PM but I received this message:

flashjazzcat cannot receive messages.

Share this post


Link to post
Share on other sites
4 minutes ago, Philsan said:

Jon, I tried to send a PM

Sorry: inbox was full. Should be OK now. ;)

 

Are there so many bugs you don't want to post them in public? :)

 

  • Haha 1

Share this post


Link to post
Share on other sites
8 minutes ago, flashjazzcat said:

Nice one: I knew it. :) Thanks for confirming. What kind of card is the problematic one? I guess we're gonna have to compile a list of to-be-avoided media.

It was a Transcend 4 GB.

Share this post


Link to post
Share on other sites

In the Side3 Loader, when your at the Pie-chart option. It lists the partitions I have. The FAT32 shows the name I gave the card, but the SDX/APT partition show untitled. How do I put a Title there?

Share this post


Link to post
Share on other sites

confused. after seeing all the traffic here about people using their side3 devices, I thought i'd give it another try - since it's not yet working on my U1MB machines (Jon, not complaining, I understand software development..) on my non-U1MB 800xl.

Boot shows

Side3 Driver v.4.0 (c)2020 fjc

2.0.1: sdhc sl64g v.8.0

 

When spartados starts, I see

Spartados x 4.49e 4-09-2020

(copyright)

 

When I try to load the td line (car:td) , I get 

Symbol I_GETTD

154 Symbol not defined

 

I feel like I'm missing something obvious.

ideas folks?


Steve

Share this post


Link to post
Share on other sites
5 minutes ago, svhovater said:

confused. after seeing all the traffic here about people using their side3 devices, I thought i'd give it another try - since it's not yet working on my U1MB machines (Jon, not complaining, I understand software development..) on my non-U1MB 800xl.

Boot shows

Side3 Driver v.4.0 (c)2020 fjc

2.0.1: sdhc sl64g v.8.0

 

When spartados starts, I see

Spartados x 4.49e 4-09-2020

(copyright)

 

When I try to load the td line (car:td) , I get 

Symbol I_GETTD

154 Symbol not defined

 

I feel like I'm missing something obvious.

ideas folks?


Steve

The SDX version included on the SIDE3 is sort of busted right now - hopefully the SDX Project folks will be able to produce a final 4.49 version targeting this hardware soon-ish and we’ll be able to flash that to our carts for stand-alone use. 

Share this post


Link to post
Share on other sites
16 minutes ago, Frankie said:

How do I put a Title there?

You don't. :D The FAT partition names are stored either in the partition boot record (in at least two different places depending on which OS formatted the partition) or the root directory (as a special 'volume name' entry), but the APT has nowhere to store a partition name. This isn't really a problem, since only one APT per physical disk is supported.

 

For general info: of the selection of 'non-working titles' I just received, 7 out of 9 worked when I tested them. This indicates that problems with vast majority of them were caused IO errors on the SD card of the user's machine, or some feature of the U1MB PBI BIOS being enabled (noting that the SIDE3-compatible U1MB firmware is pending release, hopefully tomorrow once I get the loader sorted out).

 

In fact, disabling the 'PBI Notice' in the SIDE3 compatible U1MB firmware I'm running on my test machine resulted in one of the 2/9 titles I couldn't previously get working (Midi Maze) starting without problems. One out of nine, then, remains problematic here: Goonies, which is a SW-XEGS 128K CAR type. I will investigate that more closely when I get time, but not before releasing the Sic! fix.

7 minutes ago, svhovater said:

after seeing all the traffic here about people using their side3 devices, I thought i'd give it another try - since it's not yet working on my U1MB machines (Jon, not complaining, I understand software development..) on my non-U1MB 800xl.

I'm not part of the SDX development team, Steve, so I can't really comment on why TD isn't working. I guess there's an issue with the SDX RTC driver for SIDE3, but there haven't been any recent updates on the SDX ROM. Best person to ask is someone from DLT (Drac030 or Trub).

Edited by flashjazzcat

Share this post


Link to post
Share on other sites

Hello folks,

I was trying some randoms .car files until i had this error...?

20201016_224101 (1).jpg

Share this post


Link to post
Share on other sites
14 minutes ago, Marsupilami said:

I was trying some randoms .car files until i had this error...?

Yep. That means CAR type 43 is not supported. :)

 

For info: the banking register of the 128K SDX CAR type collides with the internal control registers of the emulation engine. Fortunately, you have SDX built into the SIDE3, so this is no great loss.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 10/15/2020 at 4:37 AM, flashjazzcat said:

The pending loader update therefore turns the green LED off

Will the pending loader update be posted here in this thread (NEW thread) or just on your website.

Share this post


Link to post
Share on other sites
2 hours ago, Roydea6 said:

Will the pending loader update be posted here in this thread (NEW thread) or just on your website.

Uploaded to my website and linked here, so you won't miss anything. I'd just like to get any known errors out of the emulation table first, but we now know that switchable XEGS carts won't switch (i.e. disable). Table looks OK to me, though.

Share this post


Link to post
Share on other sites
22 hours ago, flashjazzcat said:

Sincere thanks to Pawel Mandes for reporting the initial issue and testing updates at short notice.

The pleasure is all mine ;-)

  • Like 1

Share this post


Link to post
Share on other sites

OK: here's an interim SIDE3 Loader update and a release candidate version of the SIDE3 firmware for Ultimate 1MB:

 

s3loader_0.15_171020.zip

 

U1MB_SIDE3_Firmware_RC_171020.zip

 

Updating SIDE3:

  • Copy S3LOADER.XEX to the FAT partition of your SD card (preferably one known to work without read errors), run it from the loader (ensuring BASIC is disabled in the loader settings), and follow the prompts
  • You can also run the XEX via SIO2PC/RespeQt using the 'Boot Atari executable' feature.
  • Ensure there are NO cartridge ROM or SDX ROMs in the way. So: if you have U1MB with the normal SIDE2 firmware, disable SDX and PBI HDD, etc, and boot the SIDE3 cart with the switch in the loader (up) position
  • You may run the XEX from the CLI of the SIDE3's on-board SDX, but you MUST use the 'X' command.

My advice: run the XEX from the SD card.

 

Updating Ultimate 1MB:

 

You have an ATR with UFLASH.XEX, BIOS.ROM and ULTPBI.ROM. In the usual manner (having removed any cartridges and enabled the U1MB's on-board SDX), flash BIOS.ROM to the Main BIOS slot, and ULTPBI.ROM to the PBI BIOS slot. Power cycle the machine afterwards. Before re-applying power, in fact, you may connect your SIDE3. Hop into the BIOS setup menu and enable the PBI HDD in order to make the 'L' key start the SIDE3 loader (on the cartridge) instead of the SIDE2 loader which is still on your U1MB ROM.

 

Loader fixes:

 

I haven't provided a changelog yet, since I'm feeling rather pressurised by the almost unprecedented sense of urgency which suddenly emanates from our Polish friends, but broadly speaking, the fixes/changes to the loader compared to the one provided out of the box are:

  • Sic! carts now work properly
  • The apparently rare 2K and 4K carts should now work, including right-slot 4K
  • Right slot 8K carts should now work
  • Glitch when enabling/disabling stand-alone (soft-OS) ATR support has been fixed
  • On board (SIDE3) SDX should now boot from the loader when CTRL+X is pressed when the U1MB PBI BIOS is not present
  • U1MB SDX should now boot when CTRL+X is pressed when the U1MB PBI BIOS is present
  • ATRs should now launch consistently (bug affected disk images both stand-alone and in with PBI BIOS support)
  • Green LED should no longer cause retinal damage owing to prolonged ocular exposure (although the consistent suppression of the green LED remains a work in progress)
  • CTRL+H now calls the home (root) directory in a consistent manner
  • CTRL+P now calls the parent directory in a consistent manner
  • SD card initialisation errors no longer cause the 'Device' menu to display garbage

There is probably more which will come to me later, but that covers the bulk of it.

 

Known SIDE3 loader issues:

 

This is the stuff I was fixing while Candle was accusing me of 'undermining 10 months of work by delaying things' while I was trying to make the software more robust, so sod it: they can wait until the next update:

  • Blocking dialogues prevent the screensaver from appearing. This is (almost certainly) a long standing issue in the main U1MB setup menu as well, so will be fixed there as well in the next update (this is in fact the sole reason that the U1MB BIOS and PBI BIOS I have uploaded are not 'final').
  • Blocking dialogues prevent card swaps from being handled properly. This will be addressed in the next update (which I was already working on this evening).
  • Switchable XEGS cartridges cannot be turned off owing to a bug in the FPGA code. Hopefully Candle will green-light the fixed JED so it can be deployed via the wishbone flashing tool (yes: the FPGA on the SIDE3 can be updated without any programming cables or JTAG adapters). It's hard to tell whether the Switchable XEGS fix actually fixes every issue with this cart type, however, since Jac!'s version of Goonies still doesn't start properly.
  • Better/more consistent/useful/logical handling of the infamous green LED

Of course this list doesn't include all the other bugs which haven't been discovered yet, and nor does it cover the considerable list of feature improvements planned for upcoming versions. The intention here is to provide something which basically works.

 

For those wondering why the U1MB firmware isn't provided as a single 'FIRMWARE.ROM' blob; in point of fact, only the 1K U1MB BIOS 'plugin' and the PBI BIOS ROM must be flashed to provide SIDE3 support, so it seemed pointless to provide a redundant copy of the SIDE2 loader. Unfortunately, the SIDE3 plugin required the 'Z: Handler' setting to migrate from the main BIOS code to the plugin, so the BIOS itself had to be updated too.

 

Once the full forthcoming update for U1MB/Incognito/SIDE2, etc, is released (yes, I'm working on an update for all that stuff too), thereafter, one will be able to switch between SIDE2 and SIDE3 U1MB support by simply swapping the 1K plugin and the PBI ROM, without re-flashing the main BIOS at all. :)

 

  • Like 2
  • Thanks 8

Share this post


Link to post
Share on other sites
Just now, KlasO said:

Thank you Jon, I have my Sunday planned now. :)

No doubt my Sunday is mapped out by fate now as well. :D

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, flashjazzcat said:

OK: here's an interim SIDE3 Loader update and a release candidate version of the SIDE3 firmware for Ultimate 1MB:

 

Your a star, many thanks

  • Like 1

Share this post


Link to post
Share on other sites

My 1200XL U1MB and SIDE3 have been successfully and happily updated. Wonderful news this Saturday afternoon. :) 

5175759D-E493-46C9-BD9B-8514F3242578.jpeg

0051D1AA-D9DF-415C-BA00-07E51A20AC4C.jpeg

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, DrVenkman said:

My 1200XL U1MB and SIDE3 have been successfully and happily updated. Wonderful news this Saturday afternoon. :) 

Thanks Herb!

Share this post


Link to post
Share on other sites

All flashed (excuse pun :) ) seems to be working ok, will give it a good run tomorrow.

 

That's on a 130XE U1M

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...