Jump to content
Sign in to follow this  
RetroFox

MSX 2 (Sony) RGB to Extron Upscaler

Recommended Posts

I'm running into an odd problem that I hope someone else has seen before - I have a Sony HB-F1XDmk2 MSX2 that I'm trying to connect via RGB cable to an Extron DSC301 HD (via the 15pin D-sub input). I've done a bit of searching and believe I have the pinouts correct on both the MSX* and Extron ends. I've tested and re-tested continuity through the lines. All that said, I just can't seem to get a full picture going - I'm getting two of the three RGB colors and only the text mode (I think); the MSX boot logo screen doesn't appear, game screens don't appear. The picture is nice and crisp, there's no rolling/scrolling that I've seen mentioned from other forum posts. Also, the unit's A/V outputs work normally.

 

The odd thing on the 2 out of 3 colors - I can swap the color lines and I'll get the blend of whatever 2 colors I hook up on the first two lines for the text, so it seems the R,G, and B are outputting from the MSX but for some reason the extron is not using/seeing/processing all three colors. I've used this d-sub input on the extron with my Apple IIgs and color/sync works. 

 

*For the 8pin DIN, I'm using the Type A pin out so 6,7,8 pins are RGB and 4,5 are the two sync lines. I also have pin 1 ground hooked up.

 

I'm stumped - is it that I need to use a different combo of pin 3, 4, or 5 for Horizontal/Vertical Sync or is the Extron just not compatible with the MSX output? I know on paper the extron doesn't support 15kHz, but it does and works beautifully with my Apple IIgs. Most of the posts I find on this are talking about SCART connectors/wiring but I really want to make the 8 pin din to 15 pin D-Sub work if possible.

 

Any help appreciated!

Share this post


Link to post
Share on other sites

As best as I can determine, the issue is either that the MSX2 doesn't split Hsync and Vsync, instead just having the Csync signal and/or that the voltage output is too low on one or any of the sync lines and would need at least a capacitor to boost the voltage into a range the Extron recognizes, if not also some kind of circuit to split the Csync into H/V signals.

 

I'm thinking this just not doable without more devices in between, which I'd assume would add greater delay/lag. My intent was to have as few things between the console and tv as possible.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...