Jump to content
zezba9000

ULTRASATAN doesn't work on Atart ST 520 or 1040

Recommended Posts

On 10/7/2020 at 8:59 AM, ParanoidLittleMan said:

It is most likely because you have TOS 1.00 or 1.02 in those machines. And they are not good with so many files in partitions.

There is new SD card image, what is done specially for those old TOS versions.  https://www.mediafire.com/file/hgkdnnwym334ilg/1000GamesT02.zip/file

541 MB. Unpack it and write to SD card - 2 GB card min needed. 

Btw. UltraSatan should be detected without extra reset after power on. Maybe recap of PSU is necessary ?

Before asking: TOS 1.00 is year 1985, 1.02 is 1987, 1.04 is 1989 in Desktop Info .

So I did all that and what was written above and it really already helped a lot, especially in regards to file transfer between Atari 1040STf and any other computer (also booted up an older linux OS configured the SD card for DOS and flashed it). My issue is, it is still not playing the Games even the 1mb files. I also cannot swap SD cards and have to restart the Ultrasatan when something is changed. However if I download a program like Cubase Lite, it is no issue to run it on the SD card. 

The issue with my SD card which I purchased (amigastore.eu) is the same as described initially and I cannot even mount it with an older linux distribution. It has the ICD pro installed and Kobold and at lest these programs on the main partition are running, which is nice, but as I cannot run anything else and I cannot mount it on any other devise, nor the Ultrasatan recognises the second SD card it becomes basically worthless? However these issues are for along the way as I just got into this machine and still have a lot to learn.   

Main point:
Any hints how I get it to play the games?

Share this post


Link to post
Share on other sites

If games don't work something is wrong, works unreliable.  Should do write reliability test - copy some longer files with Atari, then compare written with original file on PC - I do it with Total Commander.

PSU recapping is practically mandatory after all this years.

That 1000Games... is demo version. It does not support hot swap, 2 cards.

Things are that ST machines are very old, and there will be more and more problems. Hardest to find cause is when it works so-so.

Share this post


Link to post
Share on other sites

I get that. But as said, other programs I download work so far.

However, I will try what you said. PSU check is easy for me and indeed I have not opened up the unit, yet.

Last thing, how do I get the full version of the SW, because at least this recognizes DOS formatted cards and I can dump applications.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...