Jump to content
Andrew Davie

Cave1K crashing

Recommended Posts

Just tried Cave1K NTSC and it consistently (i.e., every time) crashes outright when there's a collision.

 

Share this post


Link to post
Share on other sites

Just tested the NTSC version on my PAL JR. Score was sent after every collision and game restarted on button pressed.

🤔

There a 3 scores from you in the High Score Club list.
https://highscore.firmaplus.de/?game_id=12 (Game Variation: "Moving Walls")

 

Did you played more than 3 attempts?

Is the PlusCart going back to the menu, or how does it crash?

Also the time diff between the first two attempts is 2 seconds, are you sure you reloaded the game between these two attempts?

 

Share this post


Link to post
Share on other sites
3 hours ago, Al_Nafuur said:

Just tested the NTSC version on my PAL JR. Score was sent after every collision and game restarted on button pressed.

🤔

There a 3 scores from you in the High Score Club list.
https://highscore.firmaplus.de/?game_id=12 (Game Variation: "Moving Walls")

 

Did you played more than 3 attempts?

Is the PlusCart going back to the menu, or how does it crash?

Also the time diff between the first two attempts is 2 seconds, are you sure you reloaded the game between these two attempts?

 

 

I tried three times.

Each time, as I crashed (there was a collision)... the atari crashed.  Screen corrupt/no frame formed.

It was a basic complete lockup/crash with complete garbage on the screen.

As to the timing -- I do not recall, sorry.

 

 

Share this post


Link to post
Share on other sites

More info on this.

Of my 3 PlusCarts, one with version 0.15.4 works perfectly every time.

The other two, with versions from DEV, both fail every time. 

When there's a collision the screen goes all glitchy -- and eventually totally crashes.  See video.

Could this be the 4K/32K ESP8266 buffer size difference?

 

 

Edited by Andrew Davie
whoops video showed my cart ID -- back soon

Share this post


Link to post
Share on other sites
2 hours ago, Andrew Davie said:

More info on this.

Of my 3 PlusCarts, one with version 0.15.4 works perfectly every time.

The other two, with versions from DEV, both fail every time. 

When there's a collision the screen goes all glitchy -- and eventually totally crashes.  See video.

Could this be the 4K/32K ESP8266 buffer size difference?

Can you update the 2 dev PlusCarts to v0.15.7

Share this post


Link to post
Share on other sites
3 hours ago, Al_Nafuur said:

Can you update the 2 dev PlusCarts to v0.15.7

Neither of them are offering me an option to upgrade.... am I supposed to do this another way?

 

Share this post


Link to post
Share on other sites
2 minutes ago, Andrew Davie said:

Neither of them are offering me an option to upgrade.... am I supposed to do this another way?

 

upps, just added them to the draft group.

Share this post


Link to post
Share on other sites

OK, I selected "upgrade firmware" and it never returned from the spinner screen (about 3 mins)

However, on reboot of cart, I see it has in fact upgraded to 0.15.7

Playing Cave1K is now working correctly.

 

Share this post


Link to post
Share on other sites
1 minute ago, Andrew Davie said:

OK, I selected "upgrade firmware" and it never returned from the spinner screen (about 3 mins)

this usually happens when the first byte of the firmware VCS ROM has changed..
0xD8 must always be the first byte of firmware_xxxx_rom arrays..

Share this post


Link to post
Share on other sites
1 minute ago, Al_Nafuur said:

this usually happens when the first byte of the firmware VCS ROM has changed..
0xD8 must always be the first byte of firmware_xxxx_rom arrays..

Noted, but I have not touched this and I'm sure you haven't either.

So, in this case it must have been some other cause.

Not a big issue - my cart upgraded OK.

 

Share this post


Link to post
Share on other sites
21 minutes ago, Andrew Davie said:

Playing Cave1K is now working correctly.

 

What was changed to fix this?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...