Jump to content
atari2600land

Nosehair help

Recommended Posts

Looks like your NoseHair loop/section is WAY over 76 cycles, so you're effectively drawing the hairs over two scanlines.

 

  • Haha 1

Share this post


Link to post
Share on other sites

OK, I think I have this working.

The heart of the game is cutting the nosehair so it doesn't grow so long it reaches the bottom of the screen. If you don't cut it, the nosehair will grow. But since you can't cut the hair yet and there is no nosehair demon to avoid, the nosehair grows. Fast (To test it. I can adjust how fast the nosehair grows.) What do you think about this game idea?

 

nosehairattempt3.bin nosehairattempt3.asm

Share this post


Link to post
Share on other sites

I added a nostril so it looks more like a nose and less like, well, you know.

I also made the scanline count steady at 262. Things needed to add:

  • the nosehair goblin
  • ability to cut nosehair
  • some sound effects would be nice
  • more stuff I can't think of right now

I don't need to worry about room just yet. I could make this a 1k ROM if I wanted to.

nosehair2.png.a0de034e402b1ea696b7e21c50d858e0.png

 

nosehair2.bin nosehair2.asm

  • Like 1

Share this post


Link to post
Share on other sites

Was thinking this needs a name other than nose hair. Maybe something like Manscape?

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites

Ran across something that makes no sense at all.

If I use audio channel 0 the code doesn't work. Yet if I use audio channel 1 it works just fine. Change the AUDC/F/V 1 in my code to 0, compile, and see what I mean? That's crazy. Why would it do that?

nosehair4.asm nosehair4.bin

Share this post


Link to post
Share on other sites
4 hours ago, atari2600land said:

Change the AUDC/F/V 1 in my code to 0, compile, and see what I mean? That's crazy. Why would it do that?

I got this error with DASM:

nosehair4.asm (768): error: Illegal forced Addressing mode on 'sta'.

Offending line says:

        sta.wx HMP0,X  ; 5 19 - store fine tuning of X

Is there a DASM option I'm missing?

 

Share this post


Link to post
Share on other sites
What's wrong with the name 'Nosehair'?
Nothing, just trying to get you thinking. Nose hair is an object. It would be like calling PONG "BALL" or something. Perfectly ok but just wanted you to be thinking

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites
You could consider some kind of Old English spelling: Nosuhær.
I like that!

Sent from my SM-N960U using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

OK, this is really weird. If I use AUDx0, the code acts a way, but if I use AUDx1, the code acts differently. WHY?!

Share this post


Link to post
Share on other sites

As it turns out problem #2 was my bad. I still haven't figured out why AUDx0 doesn't work yet AUDx1 does. Anyway, here is version 5. I'm using AUDx1 for the cutting sound effect. I added the nosehair demon.

nosehairdemon.png.e4e94a16d15961643eccf41dea3b2e3d.png

He doesn't move yet. His legs move like he's running, but he's just standing there. So the point of the whole game is to run away from the demon and make sure the nosehair doesn't get to the bottom of the screen. Periodically there will be a lovely object to get (missile 1) for bonus points, or, perhaps just points in general. What is red and square?

nosehair5.bin nosehair5.asm

Share this post


Link to post
Share on other sites
5 hours ago, atari2600land said:

OK, this is really weird. If I use AUDx0, the code acts a way, but if I use AUDx1, the code acts differently. WHY?!

This is the line that is causing your issue:

 

        sta RESP0,X    ; 4 23 - set coarse X position of Player

 

When your PosPlayer routine is run when the X register is 5, you are stomping on AUDC0.

 

PositionPlayers:
        ldx #5             ; position players 0 and 1
POloop:
        lda PlayerX,x       ; get the Player's X position
        jsr PosPlayer       ; set coarse X position and fine-tune amount 
        dex                 ; DEcrement X
        bpl POloop          ; Branch PLus so we position all Players

ldx #5 should be changed to ldx #4 here to cover all 5 positional objects and not stomp on AUDC0.

  • Like 1

Share this post


Link to post
Share on other sites

OK, this was a mess and a half. I got the nosehair demon walking around randomly, but it had some weird pixel movement shifting when it got to a certain X position on the screen. So I spent a couple of hours fixing that and got this: version 6. I also added a "game over" sound since I discovered that if the game ends while you're pressing fire, a new game starts automatically. So I put in a short pause. I have 622 bytes left if I want to make this a 2k game.

 

I did discover that the code for drawing the nosehair is barely working. I am also wondering how to score the game. I am thinking of putting in either missile1 or the ball and have it be a thing to get and more points are added the faster you get to it.

nosehair6.zip

Share this post


Link to post
Share on other sites

HELP!

 

I need a way to put Missile 1 into the game. Otherwise this can't be a game. I need to totally rewrite the nosehair growng code, but I can't do it. I sat here for a couple hours and I give up. Does anyone want to help?

Share this post


Link to post
Share on other sites

I really spent 8 hours on this?!

Finally got missile 1 into the game. It now looks like this:

nosehair7.png.b37ff48eca78ee4729968ae33db5faaf.png

I need to work on the animations since I broke them and don't understand how they work. But at least the scanline count is steady at 262 as far as I know.

nosehair7.zip

Share this post


Link to post
Share on other sites

The fact that I am constantly ripping these suckers out of my nose I feel like this game was made for me...lol

 

don't forget the dreaded "Gray" nose hair, from the planet Elderly.......

 

Okay now I want to copy 😂

Share this post


Link to post
Share on other sites

Animations fixed.

Do people in PAL land have PAL or PAL 60? In PAL 60 mode on Stella the game works fine, but in PAL mode, there is a slight disturbance right before the nosehair gets to the bottom. I have 493 bytes left for a 2k game.

nosehair8.bin

Share this post


Link to post
Share on other sites

@atari2600land Any chance you sending me some quick instructions so I can add them to the PlusCart to go with the game? I've been slowly adding instructions to all games that are new so phones have a manual sort before they play. I know this is very much under construction, do want you can for me please.

Sent from my SM-N960U using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...