Jump to content
Bill R Sullivan

FinalGROM 99 request:

Recommended Posts

11 minutes ago, arcadeshopper said:

likely the finalgrom99 doesn't work this way..    the memory capabilities are defined in the github

Thanks, Greg I'll let Alex know, as my FG99 expertise is; I can load files on it appropriately, and use the FG99 as intended, I even switch out SDHC cards after a chosen cart is loaded, as I know the cart loaded will still work, but that is the total extent of my FG99 expertise.

Share this post


Link to post
Share on other sites
2 hours ago, Bill R Sullivan said:

Yes, this suits me (my expertise) much better than MINI MEMORY.  It will take me awhile to get this loaded and checked out, so be patient.  However, your timing is excellent, as tomorrow I will be sending my MG 80K GK out for repair.  Thank you very much.

If you missed Arcadeshoppers reply, he said, it's "likely the finalgrom99 doesn't work this way..    the memory capabilities are defined in the github" website, I believe.

Share this post


Link to post
Share on other sites
4 hours ago, Bill R Sullivan said:

Wow, after 5 minutes, it's still not loaded, as the gyro thingy just keeps rotating/spinning.

I looked into this... Yes ...spinning wheel... spinning true.:music:

 

Apparently the FG99, scans the first 4.5k of the C.BIN repeatedly, waiting to see some data other than >00, before it feels content the image is done loading.
The image was empty. I placed an >aa, at >7300, to appease it. I'd never noticed this behavior before.:roll:

 

Here's the replacement...

 

         grm3055C.BIN

Edited by HOME AUTOMATION
,,

Share this post


Link to post
Share on other sites
50 minutes ago, HOME AUTOMATION said:

I looked into this... Yes ...spinning wheel... spinning true.:music:

 

Apparently the FG99, scans the first 4.5k of the C.BIN repeatedly, waiting to see some data other than >00, before it feels content the image is done loading.
The image was empty. I placed an >aa, at >7300, to appease it. I'd never noticed this behavior before.:roll:

 

Here's the replacement...

 

          grm3055C.BIN 32 kB · 2 downloads

Well, after two downloads, I have the same problem both times, but way different from earlier today.  Now I get the E/A blue screen and screech, common to TI-99/4A lock-ups, after the EDITOR/ASSEMBLER loads; which only takes a few seconds.  After reset the EDITOR/ASSEMBLER shows on the TI menu, but reslection has the same results as already described.

Edited by Bill R Sullivan
Added more details.

Share this post


Link to post
Share on other sites
6 hours ago, HOME AUTOMATION said:

Sounds like shaky 32k, or a weak cart. port connector. I just hooked up my 32k, and was able to navigate the E/A menus ...I don't have any disk device connected.

:|

I only have a TI Speech Synthesizer and NanoPEB F18 V1 attached.  I don't have another possibility for the 32K memory.  I have the two files on a freshly formatted 8GB SanDisk SDHC.  My usual is a 2GB SanDisk SDC that has all the carts available from over a year ago, and it works really well.  I've tried many of the carts on it, that I'm familiar with, but I'm not a gamer.  So what would you suggest I do?  All my other 32K memory units are TI PEB cards.  I do have one other working NanoPEB I will try.

 

My NanoPEB V2 starts out a little worse with wiggly slanted lines in each character position on the whole screen, but after reset and selecting Editor/Assembler, I get the same lockup.

 

 

Edited by Bill R Sullivan
Added more info.

Share this post


Link to post
Share on other sites

dunno...

 

...maybe you're on a different version update of FG99.:ponder:

 

You could delete the grm3055C.BIN, and use the grm3055G.BIN, stand alone. Do you have phm3055G.bin, I only changed 1 byte.;-)

Share this post


Link to post
Share on other sites
3 minutes ago, HOME AUTOMATION said:

dunno...

 

...maybe you're on a different version update of FG99.:ponder:

 

You could delete the grm3055C.BIN, and use the grm3055G.BIN, stand alone. Do you have phm3055G.bin, I only changed 1 byte.;-)

Yes, they're both on the SDHC, but only one appears as selection A., I will try deleting the grm3055C.BIN, and get back to you.

Share this post


Link to post
Share on other sites
5 minutes ago, Bill R Sullivan said:

Yes, they're both on the SDHC, but only one appears as selection A., I will try deleting the grm3055C.BIN, and get back to you.

Apparently, that was the only one showing up on my single item list, as the results are exactly the same as already reported.

Share this post


Link to post
Share on other sites
29 minutes ago, HOME AUTOMATION said:

If one runs, so should the other.

Yes, and it works as I use it frequently.  I can try it again if you prefer?  I guess I will anyway, as it's on my usual SDC.  Back in 2 minutes.  Took a little longer as I had to switch back to the NanoPEB F18 V1, due to the NanoPEB V2 causing those wiggly slant lines at every character position on each screen selection; necessitating a reset not reselect button on the FG99.  Anyway, the phm3055g.bin I've been using still works, no problems.

 

Guess what?  I just swapped the 2GB SDC back to the 8GB SDHC, and your phm3055G.BIN works.  Which means it's now the equivalent of a Super Space II, yes/no?  Using what kind of switching CRU or CALL LOAD()?

Edited by Bill R Sullivan
added new info. New test results. Fixed typo.

Share this post


Link to post
Share on other sites
2 minutes ago, HOME AUTOMATION said:

Hmm, spooky... I'd try placing the phm3055G, and grm3055G, in the same directory and see if they don't both work the same.:twisted:

 

I'm on FG99 V1.3 +latest .pld.:ponder:

OK, stand-by while I try that.  BTW I' using FG99 V1.3 also.  They both show up as A. & B. selections on my 8GB SDHC.  I don't know which is which, but I slected both one at a time and they both work as EDITOR/ASSEMBLER.  How can I determine which is grm3055G.BIN?

Share this post


Link to post
Share on other sites
8 minutes ago, HOME AUTOMATION said:

It's the one on GRAM.:D

It's my B. selection because CALL INIT in TI Basic works fine on the A. selection, but the B. selection throws a little garbage on the top part of the screen and freezes, but no sound.  Both selections on the FG99 appear identical: EDITOR/ASSEMBLER at A. & B.; there is no other information shown.

Share this post


Link to post
Share on other sites
16 minutes ago, Bill R Sullivan said:

but the B. selection throws a little garbage on the top part of the screen and freezes, but no sound.

CALL INIT, seemed to process correctly(cursor moved down 2 lines).

Share this post


Link to post
Share on other sites
6 minutes ago, HOME AUTOMATION said:

CURIOUS, I'll consider trying to hook my TIPI back up later, and test some more, if you keep having trouble...

 

Here I changed the name to German, in order to distinguish.;-)

 

       grm3055G.BIN 40 kB · 1 download

It's not a problem, as my A. selection runs my TIB+ install flawlessly, and it includes CALL INIT, CALL LOAD()s and  CALL LINK()s.

Share this post


Link to post
Share on other sites
11 minutes ago, HOME AUTOMATION said:

CURIOUS, I'll consider trying to hook my TIPI back up later, and test some more, if you keep having trouble...

 

Here I changed the name to German, in order to distinguish.;-)

 

       grm3055G.BIN 40 kB · 1 download

Does not matter as the FG99 selection A. runs my TIB+ install perfectly.

 

5 minutes ago, HOME AUTOMATION said:

CALL INIT, seemed to process correctly(cursor moved down 2 lines).

So, my FG99 plus NanoPEB V2 & F18 V1 both do not work with your grm3055C&G.BIN files, so the only recourse I have is to remove the SNUG TI-99/4P cards from my TI PEB system, and install all normal TI cards.  That will be a big chore as I have to move this TI-99/4A console to that location (back side of this location, but 4 feet closer to the West Spanish brick wall .

Share this post


Link to post
Share on other sites
12 minutes ago, HOME AUTOMATION said:

So the GRAM is working... mission accomplished?

No, not true the standard phm3055g.bin is working, as it is the A. selection.  The B. selection on the FG99 is the grm3055G.BIN, and CALL INIT causes an immediate failure, and then freezes up.  I already submitted my only alternative solution that will take hours when I have the energy and my motivation returns.  I have to pack up my MG GK for shipment today.

Edited by Bill R Sullivan
complete comments

Share this post


Link to post
Share on other sites
19 minutes ago, Bill R Sullivan said:

No, not true the standard phm3055g.bin is working, as it is the A. selection.

when you say working, do you mean that there is GRAM in 3,4,5,6,7?

 

 

Edited by HOME AUTOMATION

Share this post


Link to post
Share on other sites
49 minutes ago, HOME AUTOMATION said:

when you say working, do you mean that there is GRAM in 3,4,5,6,7.

 

 

No!  I only loaded all the TIB+ enhancements into the 24K segment of the NanoPEB 32K memory.  When I tried to save the TIB+ install file to the first RAM bank I got an error, and in my initial test that is what I did immediately, and the error caused all the problems there after!  So it does work, but I can't use the RAM banks.  I haven't tried to save anything in GRAM yet.  However, all my GRAM files are either GramKracker or Gram Packer type, so I don't think they will work or?  I think they need a one byte addition.  I guess that's what you've been doing; adding the required byte identifier.

Edited by Bill R Sullivan
Completed comments

Share this post


Link to post
Share on other sites
1 hour ago, Bill R Sullivan said:

I have is to remove the SNUG TI-99/4P cards from my TI PEB system, and install all normal TI cards.

I didn't know you were using a hyper TI system. Does the SNUG add its own GRAM? Maybe there's a conflict.

 

2 hours ago, Bill R Sullivan said:

Guess what?  I just swapped the 2GB SDC back to the 8GB SDHC, and your phm3055G.BIN works.  Which means it's now the equivalent of a Super Space II, yes/no?  Using what kind of switching CRU or CALL LOAD()?

Edited 1 hour ago by Bill R Sullivan
added new info. New test results. Fixed typo.

That's the plain old vanilla phm3055.BIN. The grm3055.BIN, is the exact same image, except I changed the forth byte from >00, to >52(R), to indicate to the FG99, to load it into GRAM vs. GROM. ...or so I think.😁

Share this post


Link to post
Share on other sites
2 hours ago, Bill R Sullivan said:

Which means it's now the equivalent of a Super Space II, yes/no?  Using what kind of switching CRU or CALL LOAD()?

No. You could switch 8k ROM banks or half ROM(4k) half RAM(4k) banks using CALL LOAD. The FG99 can supply 128 pages of 8k ROM, or 256 pages of 4kRAM/4kROM.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...