Jump to content
apc

FujiNet on PC?

Recommended Posts

Stupid question time! I compiled and got this working on a 32-bit ARM Chromebook (Samsung Chromebook 2, Exynos CPU). In theory, since I have two SIO2PC/USB adapters, I could run two instances (from individual directories) - but how do I change the default web server? localhost:8000 will always go to instance 1, is there a place where I can set, say localhost:8001 for instance 2? Or :8001/:8002?

 

Second dumb question - this being an armv7 system, Altirra won't work. Period. Atari800 works - is there a way to mate the two?

Share this post


Link to post
Share on other sites
1 hour ago, JohnBuell said:

Stupid question time! I compiled and got this working on a 32-bit ARM Chromebook (Samsung Chromebook 2, Exynos CPU). In theory, since I have two SIO2PC/USB adapters, I could run two instances (from individual directories) - but how do I change the default web server? localhost:8000 will always go to instance 1, is there a place where I can set, say localhost:8001 for instance 2? Or :8001/:8002?

 

Thom was kind enough to show me where to alter the code. From the root directory in fujinet-pc, it's /lib/http/httpService.cpp - change "8000" and recompile the file for each instance you want to run. Now I have one instance with a web service on 8881, and a second on 8882, both running over SIO2PC/USB cables.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, JohnBuell said:

Thom was kind enough to show me where to alter the code. From the root directory in fujinet-pc, it's /lib/http/httpService.cpp - change "8000" and recompile the file for each instance you want to run. Now I have one instance with a web service on 8881, and a second on 8882, both running over SIO2PC/USB cables.

 

Command line option was added -u URL , to specify URL the web server should listen on.

Updated code is available as usually on https://github.com/FujiNetWIFI/fujinet-pc

 

After new build, you can start fujinet with -u option like this:

# to serve web on all available interfaces/addresses, on port 8881
./fujinet -u http://0.0.0.0:8881

# to serve web interface only on specific interface/address, on port 8882
./fujinet -u http://192.168.192.168:8882

# to limit the web interface only for machine which is running fujinet
./fujinet -u http://127.0.0.1:8000
# or
./fujinet -u http://localhost:8000

:-)

  • Like 4

Share this post


Link to post
Share on other sites
22 hours ago, apc said:

 

Command line option was added -u URL , to specify URL the web server should listen on.

Updated code is available as usually on https://github.com/FujiNetWIFI/fujinet-pc

 

After new build, you can start fujinet with -u option like this:

🙂

Genius! Love it! I'll download it and give it a try as soon as I can!

Share this post


Link to post
Share on other sites

Missing hardware buttons on fujinet-pc ... at least I added Restart button into web interface.

 

 

If interested, pick the code from GitHub, build it and run it with:

./run-fujinet

run-fujinet is simple wrapper script to start fujinet executable and to restart it if it previously exited with specific exit code.

 

🙂 Jan

  • Like 3

Share this post


Link to post
Share on other sites

Just tested out the latest build and printer compatibility through my AtariWriter (silver label copy, which has 10xx printer drivers). FANTASTIC.

  • Like 2

Share this post


Link to post
Share on other sites

Thanks for this great program @apc!  I'm just an atari nostalgia guy having fun after the holidays, but very ignorant -- probably missing something obvious.

 

For some reason can't get the config to boot up on the 130xe -- if I understood the thread the sio2usb diode rewire mod was only necessary to connect additional SIO hardware; perhaps I'm mistaken?  I'm using a stock sio2usb (lotharek 2019-Apr-25 hardware), running fujinet-pc with 'sudo ./run-fujinet'.  The web interface comes up fine, and the sio2usb interface is detected by dmesg as /dev/ttyUSB0:

 

<code>

'lsusb'

Bus 001 Device 019: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

</code>

 

I am not able to set hosts or mounts from the web interface on the raspberry pi side, but I think this is expected behavior.

 

Tried to boot 130xe across sio2usb with HSIO Disabled, Command DSR, Proceed DTR.  At boot the 130xe produces an interrupted tone and a blue screen flashing like it's trying to load with the following debug:

 

<code>

14:54:57.973381 > CF: 31 53 00 00 84
14:54:57.973469 > FujiNet CONFIG boot
14:54:57.973504 > disk sio_process()
14:54:57.974414 > ACK!
14:54:57.974482 > disk STATUS
14:54:57.974510 > response: 0x00, 0xff, 0xe0
14:54:57.974537 > ->SIO write 4 bytes
14:54:57.974940 > COMPLETE!
14:54:57.991703 > SIO CMD processed in 22 ms
14:54:58.002253 >
14:54:58.006751 > CF: 31 52 01 00 84
14:54:58.006850 > FujiNet CONFIG boot
14:54:58.006871 > disk sio_process()
14:54:58.007738 > ACK!
14:54:58.007797 > ATR READ 1 / 720
14:54:58.007825 > FileHandlerLocal::seek
14:54:58.007855 > FileHandlerLocal::read
14:54:58.007878 > ->SIO write 128 bytes
14:54:58.008283 > COMPLETE!
14:54:58.081512 > SIO CMD processed in 79 ms

14:54:58.082862 >
14:54:58.084368 > !!! Extra bytes pending (5)
14:54:58.084417 > CF: 31 52 01 00 84
14:54:58.084441 > FujiNet CONFIG boot
14:54:58.084459 > disk sio_process()
14:54:58.085367 > ACK!
14:54:58.085426 > ATR READ 1 / 720
14:54:58.085457 > FileHandlerLocal::seek
14:54:58.085490 > FileHandlerLocal::read
14:54:58.085511 > ->SIO write 128 bytes
14:54:58.085923 > COMPLETE!
14:54:58.171512 > SIO CMD processed in 89 ms
14:54:58.186158 >
14:54:58.189990 > !!! Extra bytes pending (5)
14:54:58.190087 > CF: 31 52 02 00 85
14:54:58.190115 > FujiNet CONFIG boot
14:54:58.190134 > disk sio_process()
14:54:58.191210 > ACK!
14:54:58.191259 > ATR READ 2 / 720
14:54:58.191292 > FileHandlerLocal::read
14:54:58.191316 > ->SIO write 128 bytes
14:54:58.191706 > COMPLETE!

14:54:58.261505 > SIO CMD processed in 75 ms

</code>

 

I tried the other COMMAND and PROCEED settings but no dice.  Very sorry if I've forgotten a critical piece of info in this unforgivably long post.

 

Thanks again for the great work!

Share this post


Link to post
Share on other sites

@Pins, I believe you did all properly but I suspect the merge I did (last Tuesday) into repo introduced buggy behavior when serial port is used. Sorry for that.

Let me fix it and I will send an update here about new code ready for build.

 

  • Like 1

Share this post


Link to post
Share on other sites

Okay, couldn't wait and I'm proud to report:  YOU HAVE FIXED IT!  Great work @apc, very impressive.  Network (internet host) connection is working well with stock SIO2USB connector, running fujinet-pc on a raspberry pi3. 

 

Now if I could just remember how to use the 130XE...  🤯

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...