Jump to content
xxx

im having problems loading from disks in mess

Recommended Posts

ive tried the new version (which wont recognize disks) and an older version MESS 0.37 BETA 15 (which seems better). and neither versions load carts. i can get the cassette to work, both loading and saving. ive also tried 99menu, which doesnt help. 

Edited by xxx

Share this post


Link to post
Share on other sites
1 hour ago, xxx said:
ive tried the new version (which wont recognize disks) and an older version MESS 0.37 BETA 15 (which seems better). and neither versions load carts. i can get the cassette to work, both loading and saving. ive also tried 99menu, which doesnt help. 

Use the latest version of MAME it has all the latest features and bug fixes mame version 37 is ancient.

 

Mess and MAME were combined into one program a few years ago so if you're running mess it's probably very old as far as development is concerned.

 

Conveniently for you the active developer is in this forum and I'm sure he will chime in as well but I'll give you some hints.

 

One if you're using disk images the ti disk controller can only handle 90k and 180k sssd and dssd images that's because that controller can only handle that size disks in real life. If your disk images are larger than that then you should use a controller that supports those formats such as the Corcomp, Myarc or my favorite the Myarc HFDC.

 

There's a front end being made for MAME by one of the forum members here shift838. It's in current development that I expect him to release it any day he probably will be happy to let you try a beta copy if you ask

 

 

Posting details will get you a lot more help than "it just don't work" for instance you could have told us which disk controller you were using and what the size of the disk images are etc..

 

Greg

 

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, xxx said:

ive tried the new version (which wont recognize disks) and an older version MESS 0.37 BETA 15 (which seems better). and neither versions load carts. i can get the cassette to work, both loading and saving. ive also tried 99menu, which doesnt help. 

Stay informed about MAME progress related to the TI platform on my pages https://www.mizapf.de/en/ti99/mame. New features, bug fixes etc.: https://www.mizapf.de/en/ti99/mame/changes

 

The version you mentioned must be about 20 years old, much earlier than I started contributing, so I really cannot help you with that.

  • Like 2

Share this post


Link to post
Share on other sites
10 hours ago, arcadeshopper said:

Use the latest version of MAME it has all the latest features and bug fixes mame version 37 is ancient.

 

Mess and MAME were combined into one program a few years ago so if you're running mess it's probably very old as far as development is concerned.

 

Conveniently for you the active developer is in this forum and I'm sure he will chime in as well but I'll give you some hints.

 

One if you're using disk images the ti disk controller can only handle 90k and 180k sssd and dssd images that's because that controller can only handle that size disks in real life. If your disk images are larger than that then you should use a controller that supports those formats such as the Corcomp, Myarc or my favorite the Myarc HFDC.

 

There's a front end being made for MAME by one of the forum members here shift838. It's in current development that I expect him to release it any day he probably will be happy to let you try a beta copy if you ask

 

 

Posting details will get you a lot more help than "it just don't work" for instance you could have told us which disk controller you were using and what the size of the disk images are etc..

 

Greg

 

 

 

 

 

i'm doing a final compile of OoeyGUI v4.0 tonight.  I believe it is ready for release and will be posting in a separate thread soon.

  • Like 1

Share this post


Link to post
Share on other sites
19 hours ago, arcadeshopper said:

Use the latest version of MAME it has all the latest features and bug fixes mame version 37 is ancient.

 

Mess and MAME were combined into one program a few years ago so if you're running mess it's probably very old as far as development is concerned.

 

Conveniently for you the active developer is in this forum and I'm sure he will chime in as well but I'll give you some hints.

 

One if you're using disk images the ti disk controller can only handle 90k and 180k sssd and dssd images that's because that controller can only handle that size disks in real life. If your disk images are larger than that then you should use a controller that supports those formats such as the Corcomp, Myarc or my favorite the Myarc HFDC.

 

There's a front end being made for MAME by one of the forum members here shift838. It's in current development that I expect him to release it any day he probably will be happy to let you try a beta copy if you ask

 

 

Posting details will get you a lot more help than "it just don't work" for instance you could have told us which disk controller you were using and what the size of the disk images are etc..

 

Greg

 

 

 

 

 

im using 90k and 180k disks. the new version of mame and ooeygui does a similar thing. the carts dont work and the disk directories are not available in mame. it does boot if nothing is attached though. it looks like there is a driver or something that is needed as running mame on its own doesnt show disk directories. 

Edited by xxx

Share this post


Link to post
Share on other sites

unzip: C:\mame0212b\carts\BlastoG.Bin couldn't find ECD
Fatal error: Device TI-99 cartridge load failed: Invalid image

 

ive tried multiple carts

Share this post


Link to post
Share on other sites

MAME does not use the "bin" cartridges but either the RPK or ZIP files. Never unzip a cartridge ZIP file (apart from the all_carts.zip, which contains all ZIP cartridges). We have them all on WHTech, https://ftp.whtech.com/Cartridges/MAME

 

mame ti99_4a -cart blasto

 

(no .rpk, no .zip, no .bin in the command line)

 

Put the ZIP cartridges in your roms subdirectory.

 

Disks will only work when you attach the hardware. You must plug in the Peripheral Expansion Box into the I/O port, and a disk controller (e.g. DDCC-1) into one slot.

 

mame ti99_4a -ioport peb -ioport:peb:slot8 ddcc1 -flop1 somefloppyimage.dsk

Share this post


Link to post
Share on other sites
25 minutes ago, mizapf said:

MAME does not use the "bin" cartridges but either the RPK or ZIP files. Never unzip a cartridge ZIP file (apart from the all_carts.zip, which contains all ZIP cartridges). We have them all on WHTech, https://ftp.whtech.com/Cartridges/MAME

 

 

mame ti99_4a -cart blasto

 

 

(no .rpk, no .zip, no .bin in the command line)

 

Put the ZIP cartridges in your roms subdirectory.

 

Disks will only work when you attach the hardware. You must plug in the Peripheral Expansion Box into the I/O port, and a disk controller (e.g. DDCC-1) into one slot.

 

 

mame ti99_4a -ioport peb -ioport:peb:slot8 ddcc1 -flop1 somefloppyimage.dsk

 

mame doesnt start when i try zip files. ive attached the disk hardware but this still wont work, sorry

 

QWindowsNativeFileDialogBase::onSelectionChange (QUrl("file:///C:/mame0212b/roms/alienadd.zip")) 1
Fatal error: Device TI-99 cartridge load failed: Invalid image

 

ive tried multiple carts in this instance, also

Edited by xxx

Share this post


Link to post
Share on other sites
2 minutes ago, mizapf said:

Please post the command line that you tried.

im not using command line im using ooeygui

Edited by xxx

Share this post


Link to post
Share on other sites

OK, then Chris @Shift838 may help you better.

 

You could, for a start, try the command line first, just to make sure everything is in place.

Share this post


Link to post
Share on other sites
10 hours ago, Shift838 said:

i'm doing a final compile of OoeyGUI v4.0 tonight.  I believe it is ready for release and will be posting in a separate thread soon.

im having problems with this bit of software, any chance of a little help?

Share this post


Link to post
Share on other sites

I believe Ooeygui V 3.5 works on MAME V224 and below. Ooeygui 4.0 is for V225 and above (remember the Horizon emulation is broken in V225 and V226). The difference between V3.5 and 4.0 is that the Python code must be loaded separately into the folder holding MAME and Ooeygui in 3.5 but Python and Ooeygui are combined in 4.0. Also, Ooeygui 4.0 is designed only for MAME V225 and above according to the author. I am using Ooeygui 3.5 and MAME V224 since I use the Horizon emulation and it works fine - no problems at all.

 

I'm using the .rpk cartridge versions and .dsk for disks

Edited by atrax27407

Share this post


Link to post
Share on other sites

likely you haven't put the rompath correctly for your software directory, you have to add it to the rompath or place it in the existing rom directory.. easier to add it

 

 

Share this post


Link to post
Share on other sites
57 minutes ago, atrax27407 said:

I believe Ooeygui V 3.5 works on MAME V224 and below. Ooeygui 4.0 is for V225 and above (remember the Horizon emulation is broken in V225 and V226). The difference between V3.5 and 4.0 is that the Python code must be loaded separately into the folder holding MAME and Ooeygui in 3.5 but Python and Ooeygui are combined in 4.0. Also, Ooeygui 4.0 is designed only for MAME V225 and above according to the author. I am using Ooeygui 3.5 and MAME V224 since I use the Horizon emulation and it works fine - no problems at all.

 

I'm using the .rpk cartridge versions and .dsk for disks

i just tried the correct version of mame 0.210. still does exactly the same thing. im using ooeygui 3.0. i cant seem to find 3.5

Edited by xxx

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...