Jump to content

Recommended Posts

Hi I have been reading some tutorials on 2600 programming and I am trying to make a simple tag game. Right now I'm trying to get it so the player can move vertically by implementing skip draw. Sometimes when I start the ROM there is no sprite on the screen but other times there is one that I can control but it doesn't look like the sprite I want. 

 

Here is what my scan loop looks like:

image.png.2ab89ccc370717142a8dec18efdc2bcb.png

 

This is my sprite data:

image.png.65b84554904f31a50ea2f1780c2d4650.png

 

This is how I'm making the pointer:

image.png.fd170df6b935e67fe089e8c05f5bf29b.png

 

Any help would be appreciated.

 

Thanks!

 

 

 

 

Share this post


Link to post
Share on other sites

I guess my first thought would be that there's no way the player sprite would require 186 zero bytes followed by the sprite data!!

 

Share this post


Link to post
Share on other sites

I don't know the reason for the 186 zero bytes at the beginning of the sprite data, but there is another mistake in your SkipDraw code: you should use bcc skipDraw instead of bcs skipDraw.

Edited by zeurt

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...