Jump to content
gandalf1369

FujiNet Update Flasher Problem

Recommended Posts

Thanks @mozzwald.  I have no problem pressing the "A" button when trying to update.  As long as the FujiNet continues to work well when attached to my Atari 800 I'm good to go.  Thanks again for your concern!!

  • Like 1

Share this post


Link to post
Share on other sites

Figured I'd post this here, as I'm having the same problem, but on one of the newer v1.3 FujiNets:

 

I tried holding down the A button, but it doesn't make a difference. Looking at the logs, it looks like it's still trying to enter flash mode.

 

One point I didn't make, for what it's worth, when it's trying to flash, all three lights are blinking - bright.. dim.. off.. bright.. dim... etc.

 

Share this post


Link to post
Share on other sites
48 minutes ago, tsom said:

I tried holding down the A button, but it doesn't make a difference. Looking at the logs, it looks like it's still trying to enter flash mode.

Unplug USB from the FujiNet, hold A button and plug in USB cable to FujiNet. All the lights should turn on dim. Then try to flash. If you have another cable, try it too (even though this one works with your other FujiNet). 

Share this post


Link to post
Share on other sites
38 minutes ago, mozzwald said:

Unplug USB from the FujiNet, hold A button and plug in USB cable to FujiNet. All the lights should turn on dim. Then try to flash. If you have another cable, try it too (even though this one works with your other FujiNet). 

That’s what I meant, I tried that, didn’t make a difference. I did try another cable but no go. The cable I’m using flashes my original FujiNet just fine. 

Share this post


Link to post
Share on other sites
1 minute ago, tsom said:

That’s what I meant, I tried that, didn’t make a difference. I did try another cable but no go. The cable I’m using flashes my original FujiNet just fine. 

Can you try the attached flash tool which slows the baud rate down when flashing? The FujiNet is communicating with the computer since it's showing the debug output, it's just having a problem with flashing for some reason.

FujiNet-Flasher-macos_slow.zip

Share this post


Link to post
Share on other sites
8 hours ago, mozzwald said:

Can you try the attached flash tool which slows the baud rate down when flashing? The FujiNet is communicating with the computer since it's showing the debug output, it's just having a problem with flashing for some reason.

FujiNet-Flasher-macos_slow.zip 14.14 MB · 1 download

Nope.

Using '/dev/cu.usbserial-1410' as serial port.
Starting firmware upgrade...
Getting latest firmware from fujinet.online..
FujiNet Version: 0.5.89f318f9
Version Date/Time: 2020-12-29 01:50:02
Build Date/Time: Tue Dec 29 02:53:03 UTC 2020
Connecting...[06:59:56]ets Jul 29 2019 12:21:46
[06:59:56]
[06:59:56]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[06:59:56]configsip: 0, SPIWP:0xee
[06:59:56]clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
[06:59:56]mode:DIO, clock div:2
[06:59:56]load:0x3fff0030,len:4
[06:59:56]load:0x3fff0034,len:5524
[06:59:56]load:0x40078000,len:16488
[06:59:56]load:0x40080400,len:4840
[06:59:56]entry 0x400806a4
.....[06:59:58]Nqƥets Jul 29 2019 12:21:46
[06:59:58]
[06:59:58]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[06:59:58]configsip: 0, SPIWP:0xee
[06:59:58]clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
[06:59:58]mode:DIO, clock div:2
[06:59:58]load:0x3fff0030,len:4
[06:59:58]load:0x3fff0034,len:5524
[06:59:58]load:0x40078000,len:16488
[06:59:58]load:0x40080400,len:4840
[06:59:58]entry 0x400806a4
_Serial port closed!
____....._____....._____....._____....._____....._____....._____
Unexpected error: ESP Chip Auto-Detection failed: Failed to connect to Espressif device: Invalid head of packet (0xC2)

I'll try to dig up another cable and try...

Share this post


Link to post
Share on other sites
1 hour ago, tsom said:

Nope.

I'll try to dig up another cable and try...

Ok, thanks for trying. If another cable doesn't work or you can find another, send me a pm and we'll figure it out

Share this post


Link to post
Share on other sites
On 12/9/2020 at 9:45 AM, mozzwald said:

The board is supposed to automatically enter flash mode when you press "Flash FujiNet Firmware", but you can force it into flash mode by holding Button A (far left) when you plug in the USB cable, then run the flash tool.

This worked for me on my non-modded Atari 800XL. Thank you!

 

PROBLEM: Prior attempts (MacOS and Windows64) to use #fujinet flasher to update firmware version 0.5.8934daff failed due to: 

                "Unexpected error: ESP Chip Auto-Detection failed: Failed to connect to Espressif device: Timed out waiting for packet header"

 

SOLUTION: Forcing into flash mode by holding button-A when I plugged in the USB cable did the trick. 

 

With the older firmware my #fujinet was hanging on the "MOUNT AND BOOT" blue screen, and then dropping down into AtariOS BASIC "Ready" mode. I was unable to launch anything.

 

Now it seems to work properly as I've launched a few games from the internet. How great! 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

for others that are having issues, try a slower or faster usb port on your flashing pc, you could also try using a powered usb hub... it's helped other trying to program other projects on these boards....

Share this post


Link to post
Share on other sites

For anyone having trouble flashing their FujiNet device, please follow this procedure:

1. Plug FujiNet into computer with MicroUSB cable
2. Run FujiNet Flasher
3. Select COM port of FujiNet device
4. Click "Flash FujiNet Firmware" and immediately press and HOLD button A
6. Continue holding button A until you see "Erasing flash (this may take a while)", then release button A
7. Wait for it to finish flashing and you're done

 I was able to get a Windows 7 computer that could not flash any FujiNet I plugged into it and this process worked every time.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, mozzwald said:

Windows 7 computer

After i told the virus software to ignore the flasher software.  I leave the FujiNet powered off until the com port shows.  Select com6 turn on FujiNet and click the flash bar.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...