Jump to content
batari

Concerto firmware thread

Recommended Posts

2 hours ago, Dauber said:

 

That's exactly what I do, and one of the pins is almost dangling by a thread. :(

if you’re comfortable with the process, you could try “tacking“ the leg to the chip with a tiny drop of solder.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/24/2020 at 12:05 PM, Swami said:

 

@Swami Did you opt for the Universal NTSC/PAL BIOS with built-in Asteroids mod ("7800 Euro Operating System Upgrade") for your Best 7800 console?  The cartridge itself will not run at all on such a unit (I have both the cart and a Best Electronics mod with OS upgrade), but just the ROM image itself on a 'flash cart', I have not tried.

 

Will Concerto work on a unit with the OS Upgrade?My unit has it. 

Starts up to flashing color screens and then loads the CONCERTO menu.   I cannot seem to be able to load any games, all freeze at different %. I tried 3 different SD cards so far. Firmware 0.95 updated properly.  

 

Any thoughts? thanks!

Edited by alortegac

Share this post


Link to post
Share on other sites
39 minutes ago, alortegac said:

 

Will Concerto work on a unit with the OS Upgrade?My unit has it. 

Starts up to flashing color screens and then loads the CONCERTO menu.   I cannot seem to be able to load any games, all freeze at different %. I tried 3 different SD cards so far. Firmware 0.95 updated properly.  

 

Any thoughts? thanks!

Works absolutely fine on my NTSC 7800 with the universal  bios installed 

  • Like 1

Share this post


Link to post
Share on other sites
28 minutes ago, mimo said:

Works absolutely fine on my NTSC 7800 with the universal  bios installed 

No in my unit. I tested the concerto in a different 7800 and works fine.....so all being equal, I am guessing the OS is the problem 

Share this post


Link to post
Share on other sites
22 minutes ago, alortegac said:

 I tested the concerto in a different 7800 and works fine.....so all being equal, I am guessing the OS is the problem 

Do you really know that all else is actually equal? Same board revision? Same CPU manufacturer? Same arrangement of socketed versus soldered chips? Same SRAM manufacturer? Do both units have the same arrangement of support logic? Etc. There are a lot of 7800 variations even from outwardly identical machines.

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, alortegac said:

Will Concerto work on a unit with the OS Upgrade?My unit has it. 

Starts up to flashing color screens and then loads the CONCERTO menu.   I cannot seem to be able to load any games, all freeze at different %. I tried 3 different SD cards so far. Firmware 0.95 updated properly.  

 

Any thoughts? thanks!

Concerto 0.95 works on my upgraded BIOS (w/built-in Asteroids) Atari 7800 just fine. Most 2600/7800 games work, although many don't. I have seen no unique issues not already reported by others in this forum. Using a 32GB SanDisk Extreme PRO microSDHC Memory Card and POKEY chip.

Share this post


Link to post
Share on other sites
1 hour ago, alortegac said:

No in my unit. I tested the concerto in a different 7800 and works fine.....so all being equal, I am guessing the OS is the problem 

Unfortunately, we did find there was a large amount of variation in compatibility with different board revisions with the Concertos old build. I think that’s been reduced a lot, but seems it could still be an issue. 

 

Have you tried it with and without POKEY installed?

Share this post


Link to post
Share on other sites
51 minutes ago, Swami said:

Unfortunately, we did find there was a large amount of variation in compatibility with different board revisions with the Concertos old build. I think that’s been reduced a lot, but seems it could still be an issue. 

 

Have you tried it with and without POKEY installed?

Hi, thanks! No pokey installed. I am going to try using a 32GB SanDisk Extreme PRO microSDHC Memory Card and POKEY chip, as suggested ^

Share this post


Link to post
Share on other sites

I am upgraded to most recent firmware 0.95 (just got cart today and loaded via Harmony software and Windows).

 

In the setup menu when I scroll down with joystick it backs out of the menu as soon as I get to Discard Changes and Exit. I am unable to go past that setting. Is that normal? I saw on a 2016 video review he was having the same issue. Can't recall reading anything in posts about this.

 

Other than that, this thing is amazing! Thank you!

Share this post


Link to post
Share on other sites

So I went back this afternoon and tried a few games that didn’t work last night just to see if a cold console (versus one warmed up for awhile) would make a difference. Answer? Well, sort of. Both Tower Toppler and Realsports Baseball were able to get through the loading process but the game did this: 

 

5B8CDF73-6DAE-45C9-B4F4-68AFEE7BD2AA.thumb.jpeg.d590cd6cf7b463de844c4d5744dd52d4.jpeg

 

Sorry for the sideways image. When I tell the forum software to use less than a full-resolution image, it decides to ignore the rotation of the original. But you get the idea. Water Ski and Tank Command both freeze at 80% still, and Alien Brigade still

loads but the title screen animation just starts (the hand appears and begins to move) but repeats jerky-jerky and eventually becomes invisible. The console is unresponsive without power cycling.

Share this post


Link to post
Share on other sites
51 minutes ago, alortegac said:

Hi, thanks! No pokey installed. I am going to try using a 32GB SanDisk Extreme PRO microSDHC Memory Card and POKEY chip, as suggested ^

Are you formatting the sd card in FAT32 with 32 kB sector size?

Share this post


Link to post
Share on other sites
57 minutes ago, DrVenkman said:

So I went back this afternoon and tried a few games that didn’t work last night just to see if a cold console (versus one warmed up for awhile) would make a difference. Answer? Well, sort of. Both Tower Toppler and Realsports Baseball were able to get through the loading process but the game did this: 

 

5B8CDF73-6DAE-45C9-B4F4-68AFEE7BD2AA.thumb.jpeg.d590cd6cf7b463de844c4d5744dd52d4.jpeg

 

Sorry for the sideways image. When I tell the forum software to use less than a full-resolution image, it decides to ignore the rotation of the original. But you get the idea. Water Ski and Tank Command both freeze at 80% still, and Alien Brigade still

loads but the title screen animation just starts (the hand appears and begins to move) but repeats jerky-jerky and eventually becomes invisible. The console is unresponsive without power cycling.

That is all the problems you have that is nothing..

 

Share this post


Link to post
Share on other sites
53 minutes ago, Swami said:

Are you formatting the sd card in FAT32 with 32 kB sector size?

No idea. I used SD Memory Card Formatter to format. Lessons learned from other systems made me stop using native OS formatting and instead always use the SD Association utilities unless I require a different file system.

Share this post


Link to post
Share on other sites
2 minutes ago, MrZarniwoop said:

No idea. I used SD Memory Card Formatter to format. Lessons learned from other systems made me stop using native OS formatting and instead always use the SD Association utilities unless I require a different file system.

Okay. I've got one called FAT32_GUI_Formatter.

Share this post


Link to post
Share on other sites
16 minutes ago, alortegac said:

I am now just to be sure, why is this relevant? thanks!

It's older and more universally compatible with older software and firmware of small size - files smaller than 1GB. I think the 32kb sector size is a happy medium for rom files so you're not wasting memory, but not spreading it out over dozens of sectors. If the Quick Format of win10 doesn't work, which it usually will, I try the FAT32_GUI formatter. I found I also have the SD formatter just mentioned, so that's another option.

Share this post


Link to post
Share on other sites
11 hours ago, Dauber said:

Btw, just from one removal via the flathead screwdriver method, my POKEY is about to lose a leg. Any way to avoid this???

Which pin is it? As Concerto only uses POKEY for sound, it needs less than half of the pins to function, so it may not even matter.

 

Still, there is a new beta version of the Harmony software that is able to program a Concerto with the POKEY installed (for those Concertos that are sensitive to that.) It's not quite ready for release yet as there are some issues still being worked out, and stephena is waiting for a Concerto to arrive to help debug the issues. But, it does correct errors like those encountered above (such as "Wrong answer on prepare command" and such) so I would consider sharing it privately with those who need to update but are are concerned about removing their POKEY chips again, as it will be a few weeks at least before the next version is ready for release.

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
22 minutes ago, Swami said:

It's older and more universally compatible with older software and firmware of small size - files smaller than 1GB. I think the 32kb sector size is a happy medium for rom files so you're not wasting memory, but not spreading it out over dozens of sectors. If the Quick Format of win10 doesn't work, which it usually will, I try the FAT32_GUI formatter. I found I also have the SD formatter just mentioned, so that's another option.

Ok, thanks so much. It is clear.

I tried it but no luck on my 7800 with BIOS upgraded.

The other unit without the bios appears to be working with the same issues with few games noted by others above. 
 

POKeY sound is a bit softer but maybe it is the UAV mod. Or the TV.  
 

thanks a lot! 

15AB65C8-4B34-43C6-ABED-940FFCECDB40.jpeg

478E2964-A169-40F3-A056-00A763C42162.jpeg

Share this post


Link to post
Share on other sites

Apologies for delays, but I took a much-needed break over the weekend and am now back to working on things again. I need to get the current batch of Concertos out the door, then I will continue working on the loading code to improve the issues some have with certain CPUs.

 

I did receive a CPU from someone who had trouble with it. I thought I had at least one console with socketed chips but it turns out not all chips were socketed, so I need to desolder the CPU from one of them and put in a socket. I may have to send out test code to some with the problematic CPUs until I am able to do that and test things on my end.

  • Like 12
  • Thanks 5

Share this post


Link to post
Share on other sites

Fred, You do not need to apologize.   You have worked your can off on these things, and II am sure I speak for the rest of the community when I say thank you.

 

Edited by scotty
  • Like 12

Share this post


Link to post
Share on other sites
On 1/5/2021 at 6:23 AM, Dauber said:

Btw, just from one removal via the flathead screwdriver method, my POKEY is about to lose a leg. Any way to avoid this???

I actually snapped two legs off of mine while extracting it from the BB board. of all pins, 28 and 32.

I just cut two legs off of another IC (a 555 timer) and soldered them on. The leg was gone but the wide pad portion remained so I put tinned the pad, then tinned the new leg's pad, and picked up the leg with the hot iron and just tacked it to the broken pad. When the both melted, removed heat. Wah-lahh!

Share this post


Link to post
Share on other sites
8 minutes ago, Zonie said:

I actually snapped two legs off of mine while extracting it from the BB board. of all pins, 28 and 32

Pin 28 is Serial Data Out, so probably unneeded here. But pin 32 is R/W and likely fairly important. 

Share this post


Link to post
Share on other sites

I ran a quick test under one of my A3 units.  Unlike the AT84 unit which ran the menu flawlessly, but could not get one game to play under the Concerto, for the A3 unit, the menu crashed most of the time, but able to run games when possible to select one.

 

Under the A3 unit, after pressing down on the joystick, passing a few entries on the list or even as far as changing to the next page, ultimately the display would go corrupt with a somewhat readable screen but corruption everywhere.  Power cycle off/on the console and I would try again.  It always starts up perfectly.

 

1 out of every 5 or 6 times I was able to load a game, so I tried the same two (Aces of Aces & Dig Dug), that I devoted to the AT84, and under the A3 they loaded and ran perfectly.

 

In summary, my brief testing so far with Firmware 0.95 with no POKEY installed:

 

AT84 Serial = Flawless menu, but either during or right after loading a game, system would freeze or crash.

A3 Serial = Flawed menu the majority of the time, but when able to select a game, appears to run perfectly fine.

 

Later on, this weekend, I can open both consoles up and provide component specifics regarding chips, if needed.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/5/2021 at 5:39 PM, NISMOPC said:

I am upgraded to most recent firmware 0.95 (just got cart today and loaded via Harmony software and Windows).

 

In the setup menu when I scroll down with joystick it backs out of the menu as soon as I get to Discard Changes and Exit. I am unable to go past that setting. Is that normal? I saw on a 2016 video review he was having the same issue. Can't recall reading anything in posts about this.

 

Other than that, this thing is amazing! Thank you!

@batari - Bumping my post from Tuesday since it appears to have been overlooked. Is this a known issue? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...