Jump to content
adamantyr

New Release: Realms of Antiquity The Shattered Crown

Recommended Posts

Character data is stored in a PROGRAM file, which is saved under a different DSR program. So that's being preserved. What is not being preserved is mob data which is stored in SG0-SG3 files.

Share this post


Link to post
Share on other sites

As it says in the debug, SBR_FILEOUT is not supported. That's the low level function to write a file by sectors. I didn't think anyone except copy programs used that on purpose.

 

All writes to disk images are supported, I probably just missed that one. I don't have any software to easily test it with. Out of curiousity, why does Realms write that way? You'll get better compatibility across the various hardwares with normal READ/WRITE/LOAD/SAVE? (For that matter, why does it work with FIAD in that case?)

 

I really really don't want to implement that opcode... ;)

 

Share this post


Link to post
Share on other sites
1 hour ago, Tursi said:

As it says in the debug, SBR_FILEOUT is not supported. That's the low level function to write a file by sectors. I didn't think anyone except copy programs used that on purpose.

 

All writes to disk images are supported, I probably just missed that one. I don't have any software to easily test it with. Out of curiousity, why does Realms write that way? You'll get better compatibility across the various hardwares with normal READ/WRITE/LOAD/SAVE? (For that matter, why does it work with FIAD in that case?)

 

I really really don't want to implement that opcode... ;)

 

I’m not familiar with the name SBR_Fileout . But is that Level 2 or Direct file access? A lot of term programs use it to receive and send Xmodem etc. Would that work as a test? 

Share this post


Link to post
Share on other sites
1 hour ago, Tursi said:

As it says in the debug, SBR_FILEOUT is not supported. That's the low level function to write a file by sectors. I didn't think anyone except copy programs used that on purpose.

 

All writes to disk images are supported, I probably just missed that one. I don't have any software to easily test it with. Out of curiousity, why does Realms write that way? You'll get better compatibility across the various hardwares with normal READ/WRITE/LOAD/SAVE? (For that matter, why does it work with FIAD in that case?)

 

I really really don't want to implement that opcode... ;)

 

It's not that unusual. And it's necessary because the data is not structured in a record format, it is highly variable in size so it tracks by sector location, sector offset, and # of sectors.

 

It is in fact a file copy of sorts; at the start of a new game it has to make pristine copies of the original mob files back over top the saved game files for use. Saving your game later has to output the entire file as it loads one whole file into active SAMS for easier access and also not forcing you to save your game every time you change maps, which would be awkward.

Share this post


Link to post
Share on other sites

Well, it's unusual, as that just means it's not used a lot. ;) I didn't judge whether it was useful or not!

 

Why wouldn't LOAD/SAVE of blocks of RAM have done that for you?

 

I'm just trying to understand the intent, it's not to justify it. Just so I can have a model in my head.

 

The work is nearly done (hours later... Now I need to figure out how to test it ;) ).

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, FarmerPotato said:

I’m not familiar with the name SBR_Fileout . But is that Level 2 or Direct file access? A lot of term programs use it to receive and send Xmodem etc. Would that work as a test? 

Nope, cause then I'd need to implement RS232 as well ;)

 

Share this post


Link to post
Share on other sites
3 minutes ago, Tursi said:

Well, it's unusual, as that just means it's not used a lot. ;) I didn't judge whether it was useful or not!

 

Why wouldn't LOAD/SAVE of blocks of RAM have done that for you?

 

I'm just trying to understand the intent, it's not to justify it. Just so I can have a model in my head.

 

The work is nearly done (hours later... Now I need to figure out how to test it ;) ).

 

LOAD and SAVE are constrained to the size of VDP, and only work on a single file in one swoop.

  • Like 1

Share this post


Link to post
Share on other sites
28 minutes ago, Tursi said:

Nope, cause then I'd need to implement RS232 as well ;)

 

I forgot to consider whether RS232 was simulated.. oops. 

Share this post


Link to post
Share on other sites

I've added support and tested against DM2K and ARC303G, as well as a beta of RoA - though I don't know how to tell if the RoA output is correct. 399.036 should work, though of course please back up your original disk images before letting Classic99 touch them ;)

 

I'd forgotten about archiver - that program is the only reason I implemented the sector file access in FIAD. ;)

 

Edited by Tursi
  • Like 1

Share this post


Link to post
Share on other sites

Tested and it works!

 

One other thing, Vorticon. You'll need to do disk configuration prior to starting a new game. The default SAV file is set to expect everything on DSK1.

Share this post


Link to post
Share on other sites

Hi to all friends, i have this problem.. (look Pics) the game halted in combat mode. This happen in randomize mode four time in many hours of game.. i think that my pc configuration give the  problem.. i used ubuntu linux and classic99 under wine. Another people used under linux classic99 for play at RoA? Thanks Ermanno

P.s. when freeze the game pics no show letter ..

Schermata da 2021-01-03 20-15-17.png

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Astharot said:

Hi to all friends, i have this problem.. (look Pics) the game halted in combat mode. This happen in randomize mode four time in many hours of game.. i think that my pc configuration give the  problem.. i used ubuntu linux and classic99 under wine. Another people used under linux classic99 for play at RoA? Thanks Ermanno

P.s. when freeze the game pics no show letter ..

Schermata da 2021-01-03 20-15-17.png

I use classic99 without issues on xubuntu 20  and latest wine.. are you running latest?

 

 

  • Like 1
  • Sad 1

Share this post


Link to post
Share on other sites

  

Well, Realms of Antiquity is a complex game, and there’s a lot I’ve learned over my past few months playing (and recently beating) the game. 

 

I felt like it could benefit from this sort of thing:

 

 

443748507_primaguide-small.thumb.jpg.8b06deacbd0bc542a31a3fb335525d0d.jpg

 

 

So I decided to put together a video with some tips and tricks for new adventurers in Talanua. 

 

No spoilers actually.  Just some tips which are likely to serve new adventurers well. 

 

 

 

  • Like 12

Share this post


Link to post
Share on other sites
On 1/3/2021 at 12:40 AM, adamantyr said:

Tested and it works!

 

One other thing, Vorticon. You'll need to do disk configuration prior to starting a new game. The default SAV file is set to expect everything on DSK1.

Yes it works perfectly now! I can finally see the introduction :) Thanks to Tursi and you for the quick response and fix. 

  • Like 2

Share this post


Link to post
Share on other sites
On 1/4/2021 at 12:12 AM, arcadeshopper said:

I use classic99 without issues on xubuntu 20  and latest wine.. are you running latest?

 

 

Hi Gregory, i used latest wine version, but i do another test.. i copied roa directory in another computer that use win10 , installed a ultimate version of classic99 but ever problem.. Now.. i for start game ever use roa.exe file.. if i use classic99 but no start using roa.exe file how use grom file ? i no remember  the correct configuration..

Share this post


Link to post
Share on other sites
14 minutes ago, Astharot said:

Hi Gregory, i used latest wine version, but i do another test.. i copied roa directory in another computer that use win10 , installed a ultimate version of classic99 but ever problem.. Now.. i for start game ever use roa.exe file.. if i use classic99 but no start using roa.exe file how use grom file ? i no remember  the correct configuration..

You can find details here on setting up Classic99 for a custom ROM:

http://quixotic.adamantyr.com/roa-running.htm

 

Also, you can load the game via other cartridges. You'll need to extract LOAD, ROA, and RPG from the ROA-GAME.dsk file under Disks using TI99Dir, as I didn't provide those in the Data directory, and place them in the same folder.

Share this post


Link to post
Share on other sites

Unfortunately, I can't offer any help under Wine as I've never run it - I don't know the gotchas.

 

Share this post


Link to post
Share on other sites
21 minutes ago, adamantyr said:

You can find details here on setting up Classic99 for a custom ROM:

http://quixotic.adamantyr.com/roa-running.htm

 

Also, you can load the game via other cartridges. You'll need to extract LOAD, ROA, and RPG from the ROA-GAME.dsk file under Disks using TI99Dir, as I didn't provide those in the Data directory, and place them in the same folder.

Thanks Adam,  looked and configurated.. start and now work well. Now start a new game in this mode roa bin file and  disk 1-2-3 and now looked if the bug go out or none..

  • Like 1

Share this post


Link to post
Share on other sites

If you are sitting on the fence about getting a copy of the collector's edition I suggest you act.. we have a limited amount and they are selling out.  

  • Like 1

Share this post


Link to post
Share on other sites

Another odd thing happened tonight. My party was fighting a group of six rats, and halfway through the battle I could no longer attack one of the rats. Instead, my characters would just walk right through it, and could stay on the same square as it. I managed to kill it with a zap though.

Share this post


Link to post
Share on other sites
5 minutes ago, fimbulvetr said:

Another odd thing happened tonight. My party was fighting a group of six rats, and halfway through the battle I could no longer attack one of the rats. Instead, my characters would just walk right through it, and could stay on the same square as it. I managed to kill it with a zap though.

Ah, I had a similar report elsewhere... did any of your characters get disabled and healed during battle?

 

I need to probably start trying to repro that one... *sigh* It seems to be an edge case, it doesn't happen that frequently.

Edited by adamantyr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...