Jump to content
Mr Robot

Fujinet TNFS Server Image

Recommended Posts

20 hours ago, Mr Robot said:

What USB WiFi dongle are you using? I tested with an Edimax one. 

 

I switched to a Sony UWA-BR100 dongle and it works great now.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
16 minutes ago, RonGLeblanc said:

Can someone remind me of the default password for this TNFS image. The Atari8bit.net is down for maintenance and for the life of me I can't remember.

 

Thanks.

'tnfs'

Share this post


Link to post
Share on other sites

Atari8bit.net will be back a bit later today, I'm making a few changes.

Share this post


Link to post
Share on other sites

I got my FujiNet 1.5 yesterday.  Found the link to your TNFS server for Pi and got it going today.

 

With basically zero Linux experience since the 90's when Red Hat was free, it was easy to setup and put a few files on it.

 

Fun stuff...

 

 

  • Like 5

Share this post


Link to post
Share on other sites

Hi Mr Robot, Please can you assist me on setting up the sd card image you've created for the raspberry pi. Ive followed your instructions and now ive finally found the wpa_supplicant.config file. Ive also change the network settings to my SSID and Password and saved before transferring the sd card to the raspberri pi3b.

 

On booting i see the network is online then i have to login so i entered tnfs and pi as password.  Now thats as far as i get? Im not sure if its on my network and in my list there is some unknown with an ip address but not sure what im looking for?

Also on the sd card mine has 2 partitions , 1 for the d:BOOT and the other is f:empty So do i put atari xl atr's in that part of the sd card ? and what ip address do i enter in the TNFS host list on the fujinet?

 

Does the rasp pi know that there is the 2nd partition with the atr's? and accessing them from the atari???? 

 

I did ONCE get this TNFS server up and running on my windows10 and it worked like a charm but i reset the router and lost what settings i put in there but although i have done this over and over again to the letter ive given up on windows10 . So now as it appears simpler to use a rasp pi i thought id have a go at that but its not so plug and play? please can you help what i am to do with the log in stage on the pi and what do i enter on the fujinet to access the atr's and where do i put the atr's for the fujinet to see them?

 

Thank you

 

just checked in my router and the raspberry pis ip address is there online... So i know thats ok but not sure where the atr's go on the sd card the F:drive has gone now?

Edited by Back2skooldaze

Share this post


Link to post
Share on other sites

you need a little more experience with raspberry pi's. the pi sd has two partitions, one is fat32 and accessible in windows, it contains the base boot configuration, the other is ext3 and only accessible to the pi, the fat32 partition appears on the pi as the /boot/ dir

 

you cannot copy atari files to the sd card, you have to access it via ftp/sftp/samba over your network once it's in the pi and the pi is booted. 

 

login with pi as username, tnfs as password, not the other way around

 

in windows open an explorer window and click on network in the sidebar, the tnfs server should appear there if it's running correctly, you can put files onto the server there.

 

Share this post


Link to post
Share on other sites

Hi Mr Robot, Cheers for your reply,  Ive finally achieved the setup. Once i found the wpa_supplicant.config file i used Visual studio code to edit the file and entered my SSID and Password. Once the sd card was in the pi booting i could see i was online and i found the pi's IP address. So now ive entered the pi's IP on the fujinet its working great. Only thing is i get an empty message which means there's no Atr's etc.. Thats where i got confused as to where the Atr's go?

So now you've told me to go to network on the Win10 I'll go try.

 

Thanks Mr Robot much appreciated :)

 

Share this post


Link to post
Share on other sites

Hi Mr Robot, I've got the pi connected to my windows and on the fujinet its working obviously with an empty as theres no Atr's in there yet . I've also check in my router in connected devices under wifi and the tnfs is there working but i can not find it in windows? Ive gone to network and i see the connected devices connected but theres no rasp pi/ip address? I'm stuck now as to where to put the Atr's on the pc?

 

Ive redone the sd card a few times and its not showing in the network on pc but yet its working on the fujinet?

Share this post


Link to post
Share on other sites

HUURRAAAY DONE IT!!! :) I had to go in to the Samba settings on windows10 and put a tick in the Samba 1.0 client and voila now the TNFS appears in network and ive put hero atr in there and its working on the fujinet ;) Wow using a raspberry pi is easier than setting up on daft windows10 .

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Mr Robot, Is it possible to use ethernet in the raspberry pi oppose to the wifi settings? Ive plugged in an ethernet cable and all is lit up and on booting its given me 2 ip address's the last one being the wifi ip?  

Can i change from wifi to etherent in the tnfs server?

Share this post


Link to post
Share on other sites

yep you should just be able to rename the wpa supplicant config so the wifi doesn't get initialized. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...