Jump to content
Ikrananka

2600 Jr. - Strange Joystick Behaviour - Help Needed

Recommended Posts

I have an NTSC 2600 Jr. that a few years ago I modded with Tim Worthington's RGB mod and it has been working great.  Over the past few days I have been testing games and adjusting my OSSC settings to get them to display on my monitor.  I started to test Track & Field (actual cart and also the rom via a Harmony cart) only to notice some very strange joystick behaviour that I cannot understand or explain.  After I press the joystick fire button to start the game, as normal I'm prompted to enter player 1's initials by moving the joystick left and right to select a letter and then press the joystick fire button to select that letter.  However, when I press the fire button to select a letter I hear a crunch sound to acknowledge the button press BUT the same letter continues to flash, it never moves on to the next letter in the sequence.

 

If I start a 2-player game I can enter the second players initials no problem, i.e. pressing fire on joystick 2 moves the flashing character to the next one as it should.  However, when I now press the player 1 fire button, it not only doesn't move the player 1 character to the next one, but it also resets the players 2 name which then starts to flash the first letter again.  I've tried a range of different joysticks for player 1 but get the same behaviour with them all.

 

So, I tried testing the joystick behaviour with a range of other games and it seems to work fine in all of those I tested.

 

I tested a range of joysticks in the left port using Paul Slocum's 2002 test cart (the rom via my Harmony Cart).  This gives a strange reading when I move the joystick down.  Not only is down registered for the left joystick but RESET registers at the same time.  When I press the fire button it correctly registers just that button being pressed and nothing else.  So, why does Track & Field not work with this for entering initials as the fire button seems to be registering fine?  Is there a problem with my left joystick port?

 

It's so weird as playing games like Defender and Asteroids the left joystick works exactly as I'd expect in all movement directions and when firing.

 

I'm so confused and would be most grateful for any help in diagnosing what the problem is.  Or am I just being dumb and missing something obvious?

Share this post


Link to post
Share on other sites

The problem is due to the "extra" button functionality of the RGB mod, intended to have an additional button on a modified joystick for remote "RESET" and "SELECT" switch.


The way this is implemented interferes with some controllers (e.g. trackballs) and also with games that use the controller ports as output, as is the case with "Track and Field" (the game in fact briefly pulses the I/O pins low on each frame).

 

The Testcart also uses the pins as output (to read the keyboard controllers), that's why you see the spurious "reset" switch presses there.

 

The solution is to disable that functionality of the RGB mod, as suggested in this post:

https://atariage.com/forums/topic/243453-atari-2600-trak-ball-games/?do=findComment&comment=4268807

Edited by alex_79
  • Thanks 1

Share this post


Link to post
Share on other sites

@alex_79 Oh wow - thank you.  I'm so relieved that this isn't due to something failing on my 2600.  I'll dig into the solution proposed in the thread you linked to and figure out my preferred method for fixing this.  I'll post back here when I've got it sorted.

Share this post


Link to post
Share on other sites

@alex_79 When I installed the RGB mod I decided to NOT install the extra switch in a joystick, but I do believe that I installed the 5 wire ribbon cable to the joystick connection and also likely the 2 wires for Reset and Select.  Seeing as I don't have or want the extra switch, could I not simply remove the entire 5 wire ribbon cable to solve my problem?  I'm also assuming that the other two EXTRA wires that go to the Reset and Select are likely also not needed (optional).  Do you think that's correct?

Share this post


Link to post
Share on other sites
18 hours ago, alex_79 said:

Yes, you can remove all the 7 "extra" wires if you don't use that function.

Perfect - just removed the wires and my joystick behaviour is back to normal and I can now enter my initials in Track & Field.  Also, testing player 1 joystick 'down' no longer triggers the reset indication.  Wahoo. 

 

I now feel somewhat foolish for installing these wires in the first place, I should have realised I only "needed" them if I was also installing the extra joystick switch.  Well you live and learn.  Thanks @alex_79 for providing me with the solution so quickly - very much appreciated.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...