Jump to content
retrorussell

SMS emulators that don't graphically glitch in a recorded video?

Recommended Posts

Hey all.

 

Got the (newest) emulator Kega Fusion and it plays SMS games just great.  However.. its recording process has the colors smeared all over the screen sometimes in some games.  As in, it plays fine but if you record it and play back the video it looks funky.

 

Examples:

large.1091270286_bandicam2021-03-0911-39-41-217.jpg.227b5817b519d9d5176b2577d90a82d6.jpglarge.253135998_bandicam2021-03-0911-37-58-184.jpg.c90cfc40a6beca2fc8910c8d018dacef.jpg

Maybe certain colors the emulator has trouble with; I'm not sure.  I'm kind of muddling through for now since there's only 3 more games I want to do videos of.  The emulator Gems I've tried too but that doesn't seem to do SMS games.  Anyone have any recommendations for other emulators or bug fixes?

 

Thanks!

Share this post


Link to post
Share on other sites

Not sure how you are recording of what you are using exactly. But I just use OSB for most of my recordings from my PC if I need to go that route. Like if I stream or record something I'm playing in DOSBox as an example. While I've not really tried to record anything from Kega Fusion, I can't imagine it would be any different than anything else I've recorded using OSB.

 

Share this post


Link to post
Share on other sites
2 hours ago, -^CrossBow^- said:

Not sure how you are recording of what you are using exactly. But I just use OSB for most of my recordings from my PC if I need to go that route. Like if I stream or record something I'm playing in DOSBox as an example. While I've not really tried to record anything from Kega Fusion, I can't imagine it would be any different than anything else I've recorded using OSB.

 

This is through the internal recorder from Kega Fusion (Video/Log AVI File).  Whether you play it back immediately as a rather large file or scrunch it down with a compression program (like Format Factory) it has that "smeared color" look sometimes.  Maybe it depends on the game's color scheme?  I could use Bandicam to record instead but that would capture all sorts of blurbs on the screen I don't want it to ("Power On", framerate, etc.).  Thanks for the advice; I will keep that in mind!

Share this post


Link to post
Share on other sites
On 3/11/2021 at 2:30 PM, retrorussell said:

This is through the internal recorder from Kega Fusion (Video/Log AVI File).  Whether you play it back immediately as a rather large file or scrunch it down with a compression program (like Format Factory) it has that "smeared color" look sometimes.  Maybe it depends on the game's color scheme?  I could use Bandicam to record instead but that would capture all sorts of blurbs on the screen I don't want it to ("Power On", framerate, etc.).  Thanks for the advice; I will keep that in mind!



Have you tried Screencast O Matic?

--

Capture, create and share.
Our screen capture tools help you easily create, edit and communicate with videos and images. Simple and intuitive tools to share your ideas.


https://screencast-o-matic.com/

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, roadrunner said:



Have you tried Screencast O Matic?

--

Capture, create and share.
Our screen capture tools help you easily create, edit and communicate with videos and images. Simple and intuitive tools to share your ideas.


https://screencast-o-matic.com/

I have not.  I shall keep that in mind though; thanks!

Share this post


Link to post
Share on other sites
6 minutes ago, DragonGrafx-16 said:

It might be good to turn off any filters. 

I'm not sure how I do that with Kega Fusion.

Share this post


Link to post
Share on other sites
23 hours ago, DragonGrafx-16 said:

It should be in video settings. 

I'll try to give that a look tonight; thanks!

Share this post


Link to post
Share on other sites
On 3/30/2021 at 3:29 PM, DragonGrafx-16 said:

It might be good to turn off any filters. 

Nuts.  Did that, and the problem came back.  I was able to play Bubble Bobble okay, but I tried one of the ones that gave me real trouble (Sonic The Hedgehog), and it happened again after awhile.  Oh well.

Share this post


Link to post
Share on other sites

Yeah, that's got to be the only solution.  But fortunately I'm almost done with my Sega Master System videos.  Thanks for all the suggestions!

Share this post


Link to post
Share on other sites

Super-likely unrelated, Man, but I recently had an issue on Dark Cavern(Atari 2600) on EMU when I recorded a vid with my old reliable, OBS, only half the spiders legs were showing up on the playback.

I didn't completely wrap my ears around it, but my Friends explained that there had to be programming tricks, the spiders legs flickered from left to right so fast that the naked eye can't(really)see it(it's noticable, after you know), but the camera can, it's actually "seeing" things a bit differently than we are.

 

I "get it", tho I don't really understand, but it was interesting to at least realize, I suppose.

  • Like 1

Share this post


Link to post
Share on other sites

OBS is the best for free software and should capture SMS no worries. To minimize any issues from frame flicker, record the video at 60 frames so it captures all the frames. This will eliminate issues with missing sprites like Roger was talking about.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...