Jump to content
Cicero

Blank white screen after RetroHQ logo screen v1.04 (RESOLVED)

Recommended Posts

Is that just with the SD cart? or all carts? I know our SD cart retains its memory if you don't power it off long enough and it can boot in an undefined state. 

Share this post


Link to post
Share on other sites

Only with the SD cart.  I have not had the issue with regular carts.  Brownout may not be the accurate term.  When the issue occurs the GameDrive boots and the logo screen displays.  However, when it should go to the menu it displays a white bar at the bottom of the screen and the screen gradually brightens to a blank screen.  I can blindly boot to a game which will load (as indicated by the game's sound/music), but the screen remains blank.  The issue began intermittently when I installed the new screen.  Eventually the problem became permanent.  It only began to resolve after I discovered C7 had come loose from the screen PCB and replaced it.  Now the problem is hard to replicate.

Share this post


Link to post
Share on other sites

Interesting. I think a recap will be the best first step to diagnosing this. Or else you could be chasing your tail. I'll be following!

  • Like 1

Share this post


Link to post
Share on other sites

Found time last night and this evening to replace Q12, D13, Q7, Q8, and all electrolytic caps.  After a couple of hours of testing, I haven't been able to replicate the issue.  Thank you everyone for your help and advice.

Share this post


Link to post
Share on other sites
Posted (edited)

Welp, it's doing it again intermittently.  It does it with batteries as well as with an external power supply.  No problems at all with standard cartridges.  Any suggestions would be welcome.

 

Edited by Cicero

Share this post


Link to post
Share on other sites

The only thing I can think is it's something odd to do with shutting down the LCD controller and starting it up again. However I've never heard of this issue before, so it's not a normal issue, it's something specific to your hardware (possibly in combination with the new LCD).

 

However, did you say the odd white screen issue also happens with the original screen? In which case it could be an issue with Mikey or surrounding support parts. Very odd.

Share this post


Link to post
Share on other sites

It never happened with the original screen or with original cartridges.  After more testing it seems that once I've been playing it for a while, the issue is harder to reproduce.  I'm going to go back in today and replace R74.  I didn't do that because the Console5 kit I bought said it was not always needed.  Also, even though it's listed as a replacement for R74, the diagram Console5 has for the kit has an arrow pointing to R75, so I'm a little confused.  It may very well just be a quirk in my 30 year old Lynx.  The problem seems way less common now than it was before I did a recap and replaced Q12, D13, Q7, and Q8.

  • Like 1

Share this post


Link to post
Share on other sites

replaced the 120 ohm resistor (R74) with a 30 ohm resistor.  The issue still presents if the Lynx has been powered off for a few hours or more.  It generally takes about 2 to 5 power on/off cycles before it starts working consistently.  I'm going to call this a fix(??) and be done with anymore troubleshooting unless anyone has any other suggestions.

Share this post


Link to post
Share on other sites
7 hours ago, Fab64 said:

I'm having the same problem.


If you read this thread, it generally seems to be a hardware related problem. If you need assistance in what to try, far more details about your system and what you’ve already tried will be required.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...