Jump to content
bikeguychicago

Harmony Encore & Circus Convoy

Recommended Posts

Posted (edited)

With David Crane mentioning that the Circus Convoy ROMs are currently not compatible with the Harmony Encore cart, are there plans to provide an update to the cart after the game is released in order to allow it to be used without issue? 

 

Thanks!

 

Source: 

 

 

Edited by bikeguychicago

Share this post


Link to post
Share on other sites

In the other thread Batari said it could be added in a firmware update.

 

Mitch

  • Like 1

Share this post


Link to post
Share on other sites

Yes, I can do that for sure, as there will be demand for that once the ROM gets out there. It will be Encore only.

 

Please note that the update will be a quick and dirty interim release based on the 1.06 firmware, and there will be no other changes. This is because the new Encore firmware, version 2.0, is undergoing ground-up reprogramming and it's not ready for even a beta at this time.

 

 

  • Like 4
  • Thanks 3

Share this post


Link to post
Share on other sites

Quick and dirty works for me. I have the Encore because of games like this. 

 

Thanks for the quick response, sir!

  • Like 3

Share this post


Link to post
Share on other sites

I worked on this last night so that people have a chance at enjoying the game on Harmony Encore when it arrives.

 

When I said quick and dirty, I really meant it. I just replaced the DF bankswitch code with SB bankswitch code. If you install this firmware, note that DF will no longer function on your cart unless you revert to the older firmware.

 

There are currently only two schemes that use 128k binaries: DF and DFSC. I believe Penult demos use DFSC. There are no current released DF games or any in development that I am aware of so this shouldn't break anything out there. Any 128k game not detected as DFSC will default to SB with this update.

 

To install this on your Encore, copy the two files to the root directory of your SD. Make sure there are no other files that begin with "hbios" on the card (either delete them or rename them so they no longer begin with "hbios.")

bios_updater_NTSC.cu

hbios_106_NTSC_Superbank.bin

 

Boot your Encore then select the "BIOS updater_NTSC.cu" file as if it were a game. In a few seconds the new firmware will be loaded to the cart.

 

Please note that I could only find one SB demo out there:

SB_128K.bin. Though the cart does appear to run it alright, there has been no testing beyond this binary. If anyone knows of other SB demos, please test with them and feel free to post these demos here so others can test.

 

 

  • Like 6
  • Thanks 4

Share this post


Link to post
Share on other sites
36 minutes ago, batari said:

I worked on this last night so that people have a chance at enjoying the game on Harmony Encore when it arrives.

Thank you so much @batari, the update worked perfectly!

(sorry, had to censor part of the video due to sensitive information)

 

- James

 

(SET VIDEO TO 1080P60 FOR FULL QUALITY)

 

  • Like 6

Share this post


Link to post
Share on other sites
16 minutes ago, ZeroPage Homebrew said:

sorry, had to censor part of the video due to sensitive information

At first glance it looked like you are playing Aardvark. :) 

  • Like 2

Share this post


Link to post
Share on other sites
27 minutes ago, Thomas Jentzsch said:

At first glance it looked like you are playing Aardvark. :) 

Good idea! I should play Aardvark more, amazing game!

 

- James

  • Like 2

Share this post


Link to post
Share on other sites

I wasn’t expecting anyone to test with the real game yet! I’m so relieved that it works. Let me know if there are any issues with it. 

  • Thanks 1

Share this post


Link to post
Share on other sites
6 hours ago, ZeroPage Homebrew said:

sorry, had to censor part of the video due to sensitive information

Damn that's where all the cool stuff is at 😭

  • Haha 1

Share this post


Link to post
Share on other sites
3 hours ago, batari said:

I wasn’t expecting anyone to test with the real game yet! I’m so relieved that it works. Let me know if there are any issues with it. 

No problem, thank you for the update! I'll let you know if I run into any issues.

 

- James

Share this post


Link to post
Share on other sites
Damn that's where all the cool stuff is at

Ya, James has a lot of secrets that he hints at during his streams. We eventually learn what they are. But he likes to taunt us on occasion.

 

 

Sent from my iPhone using Tapatalk

  • Like 1
  • Haha 3

Share this post


Link to post
Share on other sites

 

9 hours ago, mhodgeshvs said:

Would the game be playable on a concerto cart? For those of us who have that but not the encore?

From this very thread not very far above your post:

On 3/18/2021 at 7:53 PM, batari said:

Yes, I can do that for sure, as there will be demand for that once the ROM gets out there. It will be Encore only.

Share this post


Link to post
Share on other sites
1 hour ago, DrVenkman said:

 

From this very thread not very far above your post:

Sorry, do you mean we will be able to play it on concerto once you adapt it or only on harmony encore?

Thank you :) 

Share this post


Link to post
Share on other sites
On 3/19/2021 at 9:03 PM, batari said:

Please note that I could only find one SB demo out there:

SB_128K.bin. Though the cart does appear to run it alright, there has been no testing beyond this binary. If anyone knows of other SB demos, please test with them and feel free to post these demos here so others can test.

 

Prince Of Indiana is SB too, I used it for testing the PlusCart SB support.:

 

  • Thanks 1

Share this post


Link to post
Share on other sites
44 minutes ago, mhodgeshvs said:

Sorry, do you mean we will be able to play it on concerto once you adapt it or only on harmony encore?

Thank you :) 

Well, technically, the game can work on a Concerto now.

 

You need to flash the above Harmony Encore firmware using a USB cable (with the method outlined on the Concerto firmware thread). This will make your Concerto act like a Harmony Encore, and it won't support 7800 games unless you revert back to the Concerto firmware.

 

It will work on the normal Concerto menu eventually, though.

Share this post


Link to post
Share on other sites
25 minutes ago, Al_Nafuur said:

Prince Of Indiana is SB too, I used it for testing the PlusCart SB support.:

 

Thanks, seems to work fine!

Share this post


Link to post
Share on other sites
42 minutes ago, batari said:

Well, technically, the game can work on a Concerto now.

 

You need to flash the above Harmony Encore firmware using a USB cable (with the method outlined on the Concerto firmware thread). This will make your Concerto act like a Harmony Encore, and it won't support 7800 games unless you revert back to the Concerto firmware.

 

It will work on the normal Concerto menu eventually, though.

I see! Thank you for the info, I need to do that update :) 

Share this post


Link to post
Share on other sites

You shouldn't need a PAL version of the bios. The bios is the bios. You just need "PAL" roms if that is what you want to play. 

Share this post


Link to post
Share on other sites

I updated my Harmony Encore cartridge and it now says that I am on version 1.07. I tried to load my digital copy of Circus Convoy up and I see the E with the blue meter filling up, but then it crashed out instead of seeing the title screen. What do I need to do to get this game to work?

 

Share this post


Link to post
Share on other sites
45 minutes ago, killersquirel said:

I updated my Harmony Encore cartridge and it now says that I am on version 1.07. I tried to load my digital copy of Circus Convoy up and I see the E with the blue meter filling up, but then it crashed out instead of seeing the title screen. What do I need to do to get this game to work?

The file I posted is 1.06, so it sounds to me like you had a 1.07 file on your card (1.07 is an unofficial version) along with the special version of 1.06 I posted above. The updater chooses the first hbios*.bin file it finds, so it's important to only have one firmware file on your card.

  • Like 1

Share this post


Link to post
Share on other sites
39 minutes ago, batari said:

The file I posted is 1.06, so it sounds to me like you had a 1.07 file on your card (1.07 is an unofficial version) along with the special version of 1.06 I posted above. The updater chooses the first hbios*.bin file it finds, so it's important to only have one firmware file on your card.

I got it working. Thank you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...