Jump to content

Recommended Posts

Just a head's up, @InsaneMultitasker and I are working very hard to get MDOS V7.30 released today.  Continue following this thread for the release and this message will be updated with the files.

 

And here is the update.  Questions regarding the update should be posted in this topic.

 

 

MDOS730.zip

 

I have also attached the two 360K DSK images Michael created here if people feel more comfortable with the DSK images.

geneveos730b.dsk geneveos730a.dsk

  • Like 13
  • Thanks 2

Share this post


Link to post
Share on other sites

And just to set initial expectations, the release is intended to allow folks to try what we believe to be a stable release, look for troubles, etc. while we continue working on some additional changes, features, etc.   There is still work to be done but we're in a pretty good place right now.

  • Like 4
  • Thanks 3

Share this post


Link to post
Share on other sites

The first message in this topic has the updated MDOS730 for public release.

 

Please make sure you read the UPDATE730 DIS/VAR 80 file in its entirety before proceeding with any changes to your system.  There are things you need to do to prepare your system for this update.

 

Enjoy.

  • Like 2
  • Thanks 2

Share this post


Link to post
Share on other sites

I had some trouble making a .DSK (for my Lotharek), because I cannot rename the SYSTEM-SYS to SYSTEM/SYS

as the "/" key does not work on TI99DIR 8.2a. Is it me or is it by TIFILE/TIDIR-design ?

I also tried Copy´n´Paste to "steal" a "/" from another file :)  but on pasting it I got some strange character instead.

Finally I had to boot my usual MDOS650, insert this new disk as 2nd HFE-disk into my Lotharek Emudrive,

and then to rename the file there. And then this happened:

 

 

yeah Woohoo 🤠

 

IMG_5581.thumb.JPG.23249a34958070cff13c7852044ee30d.JPG

 

 

IMG_5579.thumb.JPG.4751576273044c093d8967b62e815d1f.JPG :thumbsup:

 

 

IMG_5587.thumb.JPG.fe854c88d0e5ebe4fcad65c379bdcbec.JPG

 

 

 

IMG_5588.thumb.JPG.f95b35bc6da995497f6089e2cb4db1c0.JPG

 

 

 

btw, I am always getting this errormessage at boot (It also happens to MDOS650)

(strange, but no problem at all)

 

IMG_5584.thumb.JPG.8fd18ad9aed2dbcdae7d88747e0646ce.JPG

 

 

my AUTOEXEC seems to be clean...

 

IMG_5597-AUTOEXEC.thumb.JPG.abfee0ae007a3c028a77ce5e3fb8703d.JPG

 

 

 

  • Like 4

Share this post


Link to post
Share on other sites

Yes I already deleted it, I erased it, I wiped it out, I eliminated it, tried it all :)

(Using QDE)

  • Haha 1

Share this post


Link to post
Share on other sites

Post the file here and we can look at it later.  Might be something simple.

 

Is your Horizon formatted with the old FORM or FORM3MEG?  I don't check for that old format, but maybe I should. 

image.png.c7fdf3b544f1b203b2a8dabdba3fb1e7.png

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Schmitzi said:

Yes I already deleted it, I erased it, I wiped it out, I eliminated it, tried it all :)

(Using QDE)

You forgot to terminate it! ;-)

 

  • Haha 2

Share this post


Link to post
Share on other sites

Thank you for this great job! Can't wait to test it.

 

It would have been helpful, though, to post one or more DSK images, not only the naked files. I suppose you also want to address emulation users, and this means MAME for the Geneve, as a matter of fact, and there is only DSK. Maybe you could add those images to the first post as well.

 

 

 

geneveos730a.dsk geneveos730b.dsk

  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, Schmitzi said:

I had some trouble making a .DSK (for my Lotharek), because I cannot rename the SYSTEM-SYS to SYSTEM/SYS

as the "/" key does not work on TI99DIR 8.2a. Is it me or is it by TIFILE/TIDIR-design ?

I also tried Copy´n´Paste to "steal" a "/" from another file :)  but on pasting it I got some strange character instead.

Finally I had to boot my usual MDOS650, insert this new disk as 2nd HFE-disk into my Lotharek Emudrive,

and then to rename the file there. And then this happened:

 

 

:thumbsup:

 

 

btw, I am always getting this errormessage at boot (It also happens to MDOS650)

(strange, but no problem at all)

 

 

TIDIR has that issue with a few characters.

 

As far as your AUTOEXEC file, load it in MyWord, and make sure you are PE (Program Edit) mode.  You have an empty line at the end of your AUTOEXEC file causing it. Then, while you are still in Program Edit mode, save the file.

 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

 

@9640News ah OK, thanks. I tried to cut that line (F3 in QDE), but maybe this does not work

 

Do you have the latest version of myword, and btw, I am looking for the CAPS (for CAPS ON in AUTOEXEC),

I asked for it somewhere around and searched all my data but cannot find it.

(I also just entered it in the AUTOEXEC - thought maybe it was a command - but it didn´t work)

 

Btw, as I boot from 720KB only at the moment, I maintain a MDOS DSK for me with some tools that I gathered together for my work,

so here it is. Due to my extremely knowledge about it, better see it as "untested" or "as is" :grin:  

 

MDOS-730_RMS-02-720KB-GPL-PFM-MDM6-READY1_hfe.dsk

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

In GPL mode, can I remove the MENU program again so that I get the usual Master Title screen? May I just put the old GP{M,N,...} files in place, or are they specifically adapted to GeneveOS 7.30?

 

(Actually, I patched my own GPL not to skip the MTS.)

 

Edit: Sorry, it's in the README. I should have read it before.

Edited by mizapf
  • Like 2

Share this post


Link to post
Share on other sites

 

yes I saw this too, and was not able to load "XB" or EA, it says "file not found"

 

only by pressing F7  I come to (the loaded or not?) Extended Basic

Pressing "X" does not work too

 

IMG_5595.JPG

Share this post


Link to post
Share on other sites
38 minutes ago, Schmitzi said:

 

yes I saw this too, and was not able to load "XB" or EA, it says "file not found"

 

only by pressing F7  I come to (the loaded or not?) Extended Basic

Pressing "X" does not work too

 

IMG_5595.JPG

You need to go up to the top of the screen and hit F5 to edit the file path to where your Extended Basic module is located.  You can edit all those menu items.

  • Like 2

Share this post


Link to post
Share on other sites
48 minutes ago, mizapf said:

In GPL mode, can I remove the MENU program again so that I get the usual Master Title screen? May I just put the old GP{M,N,...} files in place, or are they specifically adapted to GeneveOS 7.30?

 

(Actually, I patched my own GPL not to skip the MTS.)

 

Edit: Sorry, it's in the README. I should have read it before.

Yeah.  At least you found the docs first.  Check out both versions.  Not sure who edited the Grom screens for the bootup screens.

Share this post


Link to post
Share on other sites

FYI, Fred Kaal has updated the IDE DSR from V14 to V15 that fixes the 8th IDE drive partition issue in the DSR.  See his website if you are or will be an IDE user for the Geneve.

  • Like 3

Share this post


Link to post
Share on other sites
5 hours ago, InsaneMultitasker said:

Post the file here and we can look at it later.  Might be something simple.

 

Is your Horizon formatted with the old FORM or FORM3MEG?  I don't check for that old format, but maybe I should. 

image.png.c7fdf3b544f1b203b2a8dabdba3fb1e7.png

 

I think it was FORM3MEG, as mentioned here:

https://atariage.com/forums/topic/307339-i-need-a-new-users-guide-to-mdos-and-the-last-35-years/?do=findComment&comment=4748245

 

btw, what FORMAT-tool is best choice for MDOS730 ?

Like "FORM3MEG only if the card is greater than 800K, ortherwise FORM123" or so ?

 

 

Share this post


Link to post
Share on other sites

Here is a basic HD image for MAME, which may be used by people who wish a quick start-and-go. I updated the earlier version by the new operating system GeneveOS 7.30 and by adding a link to 9640news.com as a primary source for Geneve information - if you agree, Beery.

 

Also, I consider calling it "genhfdc.ide" instead of the previous "genhd.hd" to allow for other types of future hard disk images (like SCSI and IDE).

 

Maybe you have some more suggestions on what should be on this initial harddisk image before I upload it to WHTech. Currently you'll find the contents of the new release disks, QDE, TI Extended BASIC, Editor/Assembler, TI Invaders, an AUTOEXEC, and two scripts TI99 and TI99M for launching the GPL interpreter with classic Master Title Screen or with MENU80. This is just an initial setup and will certainly be filled as needed by the user.

 

Use it in MAME as usual by

mame geneve -peb:slot8 hfdc -peb:slot8:hfdc:h1 generic -hard1 genhfdc.hd


 

genhfdc.hd

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

MDOS works fine, when I check what cards I have in the PEB it finds TIPI and the TI-Disk controller but not the IDE card. DU2K also can't find the IDE card (loaded with EXEC /r).

I have not managed to load GPL to try to load the latest IDE DSR (also check if the battery on the IDE card is dead and that's the reason it won't find the card).

In a few days I have more time to try to fix it.

Also, I have to learn how TIPI works together with two physical disks, and the how to assign etc...

 

Many thanks, a tremendous work you guys have done! 😍

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, mizapf said:

 

Use it in MAME as usual by

 

mame geneve -peb:slot8 hfdc -peb:slot8:hfdc:h1 generic -hard1 genhfdc.hd

 

 

This command does not work:

(I only get a lot of strange sounds)

 

grafik.thumb.png.dbb59fda33ddb4591a0c76c665f701a2.png

Share this post


Link to post
Share on other sites
2 hours ago, Schmitzi said:

 

I think it was FORM3MEG, as mentioned here:

https://atariage.com/forums/topic/307339-i-need-a-new-users-guide-to-mdos-and-the-last-35-years/?do=findComment&comment=4748245

 

btw, what FORMAT-tool is best choice for MDOS730 ?

Like "FORM3MEG only if the card is greater than 800K, ortherwise FORM123" or so ?

 

 

Use GENCFG.  :)   Read the associated documentation and remember that you will lose anything on the ramdisk presently. :)

 

 

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, mizapf said:

It would have been helpful, though, to post one or more DSK images, not only the naked files. I suppose you also want to address emulation users, and this means MAME for the Geneve, as a matter of fact, and there is only DSK. Maybe you could add those images to the first post as well.

I won't speak for @9640News but we discussed creating disk images and believed that - rightly or wrongly - releasing the files in the ZIP would allow 'better' configuration to come together with help from the community.  This is technically the 'beta' release and wasn't put together with brand new users in mind.  Help from the community in that regard is much appreciated :)

 

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, mizapf said:

Here is a basic HD image for MAME, which may be used by people who wish a quick start-and-go. I updated the earlier version by the new operating system GeneveOS 7.30 and by adding a link to 9640news.com as a primary source for Geneve information - if you agree, Beery.

 

Also, I consider calling it "genhfdc.ide" instead of the previous "genhd.hd" to allow for other types of future hard disk images (like SCSI and IDE).

 

Maybe you have some more suggestions on what should be on this initial harddisk image before I upload it to WHTech. Currently you'll find the contents of the new release disks, QDE, TI Extended BASIC, Editor/Assembler, TI Invaders, an AUTOEXEC, and two scripts TI99 and TI99M for launching the GPL interpreter with classic Master Title Screen or with MENU80. This is just an initial setup and will certainly be filled as needed by the user.

 

Use it in MAME as usual by

 

mame geneve -peb:slot8 hfdc -peb:slot8:hfdc:h1 generic -hard1 genhfdc.hd

genhfdc.hd 780 kB · 4 downloads

No problem with you proceeding Michael.  Go for it.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...