Jump to content
santosp

Atari XE Remake Pre Order Thread

Recommended Posts

That's pretty... I hope mine turns out as nice. It's been a while since I've assembled a PCB.

  • Like 1

Share this post


Link to post
Share on other sites
On 6/16/2021 at 8:42 PM, venom4728a said:

Thanks for the link, I purchased the 4-pack from him.

 

I only need two, if anyone can use the other two, shoot me a PM.

Share this post


Link to post
Share on other sites
Posted (edited)

I purchased 10 @ OKI M41464-10 off of ebay and none of them work.   I have been using the factory ram pulled from my Atari 130xe up until today when these arrived from CHINA.  I tried swapping them one at a time, change a top chip then a bottom chip, trying to boot in between each swap and the board did not boot until I put the factory ram back in.

 

So, Did I buy the wrong RAM, did China send me junk, or do I need to make a change on the board to use the 41464?

1103892321_M41464-10OKI.thumb.jpg.25911c868a12d35a848f86b7f5528967.jpg

 

Edited by venom4728a

Share this post


Link to post
Share on other sites

Have you try to contact with him? I think the 50$ is there by mistake.

Share this post


Link to post
Share on other sites

Well that doesn’t bode well. I don’t have any stock ram to test either so if mine turn out to be fake also I won’t know if that’s the problem or if it’s another part of my build. 
 

is there any way to test these? 

Share this post


Link to post
Share on other sites
Posted (edited)

 

8 hours ago, orpheuswaking said:

Well that doesn’t bode well. I don’t have any stock ram to test either so if mine turn out to be fake also I won’t know if that’s the problem or if it’s another part of my build. 
 

is there any way to test these? 

Hopefully the next set I get will work. Trying Jameco this time.

 

41464-10

 

 

Edited by venom4728a

Share this post


Link to post
Share on other sites
18 hours ago, santosp said:

Have you try to contact with him? I think the 50$ is there by mistake.

No, just an observation. 

Share this post


Link to post
Share on other sites

I dug around in my boxes of parts and found 5 NEC D41464C-10 the machine booted up fine with that RAM too.   I tried the 10 OKI 41464-10 from CHINA again and no boot, they must be fakes.  I am disputing through EBAY right now with the seller. They asked for pictures of the machine not booting.  Not sure how the pictures will help them decide... Probably going to say " You are not wearing a grounding strap!  That is why those chips do failed to work!"  :)

 

  • Like 1

Share this post


Link to post
Share on other sites
On 6/20/2021 at 3:29 PM, santosp said:

:idea:Important Info:idea:

 

Completing today the assembly of a board from this last batch for a  buyer, I discovered something that I should inform you. This has to do with the "Basic rom" of the computer.

First of all I must to say that back then during the design, I was thinking about the difficulty that someone will face in the "seemingly" easy finding of the Basic rom, in case it does not have the original from a donnor Atari.

So I decided to make a change in the second and last version of the board, to give the option to someone to use a usual 27C64 or 128 or 256 or 512 eprom for this purpose. Now I realize that I made a small mistake regarding a signal, the pin Nr 2 of Basic rom. I have connect it to 5 volts.

So you need to follow the photo below to fix it.

So this board can not work using the custom Atari OTP rom, but with any 27C..... as desribed above.


Once again to apologize for my negligence .... 😑

 

 

IMG_20210620_221541-1600.jpg

Am I reading this correctly? If we are using an original Atari ROM then this is NOT needed? 

Share this post


Link to post
Share on other sites

So this board can not work using the custom Atari OTP rom

 

is what I read... so reprogrammable roms will work but not one time programmable rom like Atari used

Share this post


Link to post
Share on other sites

Hello Santoshp,

 

Can we get a post that's pinned to the front of this thread highlighting the known errata to different versions of the board?

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Atari_bbs_fan said:

Hello Santoshp,

 

Can we get a post that's pinned to the front of this thread highlighting the known errata to different versions of the board?

First version was shipped only to 9 persons. These have informed about the errata.

Second version have only this.

Share this post


Link to post
Share on other sites
31 minutes ago, Atari_bbs_fan said:

Ok.. how do I identify which board revision I have?  On the bottom of my board, I see "65XE(63X2) C103579-001 REVISED".

Second! 🙂

Share this post


Link to post
Share on other sites
Posted (edited)

On the bottom side 1st version mark as 1221 and 2nd mark as 1721.

Edited by santosp
  • Like 1

Share this post


Link to post
Share on other sites
On 7/7/2021 at 7:46 AM, orpheuswaking said:

Am I reading this correctly? If we are using an original Atari ROM then this is NOT needed? 

So this seems to be in confusion.  Several people have asked the same question.   🙂  Do you have to do the mod to use the original Atari OTP 24 pin chip?

 

 

Share this post


Link to post
Share on other sites

I have writing in previous post that..

"So this board can not work using the custom Atari OTP rom, but with any 27C..... as desribed above."

Share this post


Link to post
Share on other sites
7 hours ago, santosp said:

I have writing in previous post that..

"So this board can not work using the custom Atari OTP rom, but with any 27C..... as desribed above."

Please forgive us.  Sometimes we loose something in the translation between languages.  Sometimes the translation between the dialect of New England and the South of the US even though we supposedly speak the same English is worse. 🙃  I was trying to get my mind to a yes or no translation of the instructions. 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I was confused as well.  I can verify that you cannot use the original Atari factory basic rom, the mod has nothing to do with it.  If you want to use the factory rom, you would have to create an adapter to switch the pinout.  In order to use a 27Cx, you need to do the mod, it won't work otherwise.

 

One other note, I didn't want the battery backup, so I didn't order/install parts for it.  You need to jump pins 5-6 on the U12 footprint, otherwise no worky..

Edited by wildstar87
  • Like 2

Share this post


Link to post
Share on other sites

Having an issue with programming my GAL22V10D with Horus's v1.3 jed.  I am getting a vector test fail indication on five of the 10 chips so far.  I tried re-downloading the jed individual file and the zipped file directly from his website.  My programmer claims it can program these chips and everything goes well until it attempts to verify the programming.  Is it possible I got bad/fake GALs?

Share this post


Link to post
Share on other sites
2 hours ago, Dropcheck said:

Having an issue with programming my GAL22V10D with Horus's v1.3 jed.  I am getting a vector test fail indication on five of the 10 chips so far.  I tried re-downloading the jed individual file and the zipped file directly from his website.  My programmer claims it can program these chips and everything goes well until it attempts to verify the programming.  Is it possible I got bad/fake GALs?

I had to disable the encryption.  I purchased 5 and only one of the 5 took the program successfully.

 

  The five I purchased were used.   I have since purchased 2 new chips but have not tried to program them yet.

 

I have been looking at getting a newer programmer to see if that us my issue.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...