Jump to content
gilsaluki

64K 600XL w/n Load Battlezone, but XEGS Will

Recommended Posts

I put my 64K upgraded 600XL front and center today (giving my other machine a rest).  I tried a lot of my carts and all work and load with the exception of Battlezone.  I take the cart over to my nearby XEGS, it loads perfectly.  I upgraded the 600XL years ago with the instructions (very simple upgrade, RAM chips and a couple of wires) found on this site.  Anyone have a clue why it works on one machine, and not the other?  Other XEGS carts work fine on the 600XL. 

Share this post


Link to post
Share on other sites
13 minutes ago, Sugarland said:

Have you tried the same Battlezone from SIO instead of cart?

No, but I will.

Share this post


Link to post
Share on other sites
Posted (edited)

An original bank-switched Battle zone cart should run on any 64k machine, just like the others ( including Mario Bros. ) . It’s the cracked versions that need to decompress into 128k. The 600xl mod is not 100% software compatible. There are some modified versions out there that take advantage of , for example - the uno cart - I have a Commando XE .rom file that runs off it and on a 64k machine. There are exceptions.

Edited by Paul Westphal

Share this post


Link to post
Share on other sites
22 minutes ago, Paul Westphal said:

The 600xl mod is not 100% software compatible.

Oh wow that's good to know.  How can we find out more about this? What sort of incompatibility is it?

Share this post


Link to post
Share on other sites
Posted (edited)

Why would the 600XL 64k memory mod make it any less compatible than say an 800XL?

 

I just downloaded the XE 64k ROM of Battlezone, stuck it on my SD card and plugged it into my SIDE3 in my 64k modded 600XL - It runs fine.

 

EDIT: I do also have an U1MB...

Edited by Mazzspeed

Share this post


Link to post
Share on other sites

600XL 64K should be fine.  There are different revisions of the XL OS which might make a difference (though pretty unlikely).

The first 600XL I owned had the OS that simply restarts when you change a cartridge.

My 800XL has the later revision that simply halts and you have to press Reset to coldstart again, and my current 600XL is the same.

 

If a 64K internal mod is done correctly then no reason why it shouldn't be 100% "same" as an 800XL in a hardware sense from software perspective.

Not sure about the Battlezone factory Rom - possibly it only needs 40K or even 32K of Ram.

Or maybe it does need 48 or 64K.

 

It might be worth trying to clean the cartridge slot and ensure all the contacts are sitting properly.  One method can be to put the contact cleaner on the edge connector then insert/remove the cartridge a few times.  Then let it all dry for a few minutes.

  • Like 4

Share this post


Link to post
Share on other sites

All my Cart (XE Type or otherwise) are store bought carts, not copies.  It's funny.  The Load Runner works.  The Eagle's Nest works.  Midnight Magic works.  Airball works.  Moon Patrol-No go.  Battlezone-No go.  It is hit or miss which ones do work and which ones do not.  Very weird.  I don't think it is the cart connector, as some carts load fine, others refuse.  I guess I never noticed (or tried certain carts) when I did the upgrade.  More investigation.  Everything else works great.  Loads disks fine, etc. 

Share this post


Link to post
Share on other sites
14 minutes ago, gilsaluki said:

All my Cart (XE Type or otherwise) are store bought carts, not copies

if you have the original BZ, it won't run on a u1mb computer.

Share this post


Link to post
Share on other sites
1 hour ago, xxl said:

if you have the original BZ, it won't run on a u1mb computer.

My 600xl is only upgraded to the 64K configuration.  I wouldn't know a u1mb from a frankfurter.. Some XEGS carts work on it, some just show black screen.  I cleaned the ROM cart connector on the computer.  Same reaction.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, gilsaluki said:

It is hit or miss which ones do work and which ones do not.

Can you describe what exactly are the symptom/s ?

 

Having said that (and without any other details), seems like a signaling / memory-management problem (cart's bank-switching maybe failing on host computer). PIA & MMU to be closely examined, for sure.

 

I tried Battlezone rom-image on my 800/Incognito and 800XL/U1MB and seems to work (at least boots, shows auto-demo, etc.) Did not hit "start" or play with actual controllers, though.

Edited by Faicuai
  • Like 1

Share this post


Link to post
Share on other sites

I will try downloaded versions of the particular games. Maybe it does have to do with bank switching. I am learning all the time.  Symptom is:  When the non-performing (not loading) cart is inserted and powered up, the screen remains black, no sound, nothing.  Reset, Start, Option, Select keys have no affect.  However, some of the XEGS-styled era carts do work just fine as noted before.  Moon Patrol does not work and it is a fairly simple program.  Airball works, and it is visually more complex.  Into the Eagle's Nest cart works fine.  Food Fight works fine.  Battlezone does not work.  Karateka does not work.  

Share this post


Link to post
Share on other sites
3 hours ago, xxl said:

if you have the original BZ, it won't run on a u1mb computer.

I have an original cartridge, it runs on my U1MB equipped 800XL. Maybe there are different versions around?

Share this post


Link to post
Share on other sites
16 hours ago, MrFish said:

Yeah, it requires 128 KB for the file version. Weird thing is, Fandal did the conversion (no surprise), but I don't see it on his own site.

 

 

Atari lawyers once contacted Fandal and wanted him a) to change the URL of his webpage from atari.fandal.cz into something else not using atari (his webpage was unavailable then for a while and then he used and still uses a8.fandal.cz) and b) to remove some titles where Atari is the copyright holder. So that is why you will not find several Atari titles on his webpage.

 

Edit: replaced "most/all titles" with "some titles"

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
5 minutes ago, CharlieChaplin said:

Atari lawyers once contacted Fandal and wanted him a) to change the URL of his webpage from atari.fandal.cz into something else not using atari (his webpage was unavailable then for a while and then he used and still uses a8.fandal.cz) and b) to remove most/all titles where Atari is the copyright holder. So that is why you will not find several Atari titles on his webpage.

 

IDK... I see many other Atari games there. Might you name a few others that aren't?

 

Edited by MrFish

Share this post


Link to post
Share on other sites

Hmmm,

 

maybe check the OS of your 600XL computer, some of them do have XL-OS Rev. 1 and there are indeed some A8 programs that do not run at all with this OS version. (A friend of mine had a 600XL with 1064 and several programs from Poland did not work with it due to XL-OS Rev. 1.)

 

 

  • Like 1

Share this post


Link to post
Share on other sites
12 minutes ago, MrFish said:

 

IDK... I see many other Atari games there. Might you name a few that aren't?

 

 

Offtopic: Fandal told me, that the Atari lawyers explicitly listed which titles he should remove from his webpage. But I do not remember the list anymore. Just like you, I found Basketball, Asteroids, Star Raiders, Star Raiders II, Centipede, Millipede and other Atari titles on his page, so I have to ask him again which titles he was asked/forced to remove.

 

(Besides, if I remember correctly, Atari sold the rights for Battlezone to Rebellion Entertainment ?!? And Activision also made Battlezone versions available for e.g. the PC)

 

Share this post


Link to post
Share on other sites
Posted (edited)
26 minutes ago, CharlieChaplin said:

Atari lawyers once contacted Fandal and wanted him a) to change the URL of his webpage from atari.fandal.cz into something else not using atari (his webpage was unavailable then for a while and then he used and still uses a8.fandal.cz)

Yeah, I remember when that all went down. His site was offline until he got his current URL.

 

Edited by MrFish

Share this post


Link to post
Share on other sites
5 hours ago, xxl said:

if you have the original BZ, it won't run on a u1mb computer.

 

If you had coded it, then it surely (and surely+) would not run on U1MB computers.

 

Both XE carts however (Hong Kong type and Taiwan type cart.) did run fine on my U1MB equipped 800XL computers before I sold them to Nir Dary.

 

If you mean the original/unreleased A8 Battlezone version or Homesofts 5200 conversion, this might be true (I never tested this with U1MB).

 

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, gilsaluki said:

the screen remains black, no sound, nothing.  Reset, Start, Option, Select keys have no affect.

Mhmm.. NO RESET key? The CPU is crashing... and monumentally, it seems.

 

However:

 

  1. When you power down the machine, insert cart, and power up, do you IMMEDIATELY get a black-screen or can you detect a slight delay before crash?
  2. Same Q. as above, but when pressing RESET.

 

ONLY way to boot a cart is by having OS (own) boot-manager first reading and then vectoring CPU to $BFFA-$BFFF (8K L-cart) or $9FFA-$9FFF (8K R-cart) areas. If you are getting other carts to work, that means OS boot-manager *is* working on those instances.

 

We need to find out if machine is crashing BEFORE or AFTER OS boot-manager dispatch.

 

As for actual physical interfacing, assuming NO problems with R/W and PHI2 signals, then S4/RD4, S5/RD5 and CCTL *must* be available and working perfectly on their corresponding cart-port pins.

Edited by Faicuai

Share this post


Link to post
Share on other sites
2 hours ago, CharlieChaplin said:

If you had coded it, then it surely (and surely+) would not run on U1MB computers.

He sees U1MB even where it does not exist.

  • Like 1
  • Haha 3

Share this post


Link to post
Share on other sites

Hello guys

 

I probably haven't opened one of the cartridge boxes in years.  Just opened the BattleZone box (blue, copyright 1987, XE cartridge, RX8077), stuck the cart into my 64kB 600XL, plugged in the TAC-2 and played the game for a short time.  Everything seems to work just fine.

 

BTW I used the description on my special stuff site to upgrade the 600XL to 64kB (years ago).  The 600XL was made in Hongkong, is a PAL machine and has a sticker at the bottom with French text on it.

 

Sincerely

 

Mathy

 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, flashjazzcat said:

He sees U1MB even where it does not exist.

Good - it's in his head, getting rent for free.  Every time I install one, a kitten gets a bowl cut.

  • Like 1
  • Haha 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...