Jump to content
eems

5V MEMORY UPGRADE Troubleshooting

Recommended Posts

Posted (edited)

I did this upgrade on an H2 motherboard and everything seemed to go well with desoldering and installing the sockets, connect +5V to L3,  and pins 8 & 9 were at ~5V and pin 1 at 0V. Popped the chips in and garbled video.

Troubleshooting:

1.       Continuity across the 8 chips: All pins besides 2*(see #2) & 14 have continuity. From underside all the traces had continuity. 

2.       *Strangely pin 2 on U15 and U17 have continuity. After making this connection, Pin 1 jumps to ~2 volts (with power disconnected) and if I put pin 1 to ground the voltage slowly drops back to 0V.

3.       The address and controls across all 8 are fine to the VDP but going back to U15 and U17(see#2), I found that there is also continuity from those PIN 2s to AD5 (pin 5) and this causes the same 2 volt charge to pin 1.

4.       Since AD5 is connected to all pin 6 there is also continuity between U 15 & U17 pin 2 with all Pin 6s.

 

Any thoughts on where there might be a short or other troubleshooting to be tried based on these observations

IMG_2595.JPG

IMG_2599.JPG

IMG_2598.JPG

Edited by eems

Share this post


Link to post
Share on other sites

Added some pictures of how the image is displaying for additional information. Boot screen (Original Bios), Donkey Kong game select screen, and then started Donkey Kong game (sort of looks like abstract Zelda). Sound is fine. Could be a job for Jimmy.

184A9578-2C81-4F65-A9EA-11FC9839C899.jpeg

C1A67DD6-0491-494D-9B5C-5DA8A1B0F0C7.jpeg

256E3F04-6450-4D17-B510-72B2926B6E78.jpeg

Share this post


Link to post
Share on other sites

Update: I traced the continuity issue with U17-2 and U15-2 through the VDP (AD4/AD5) which individually trace to all P12 and P6 on each chip. With some help from a gracious community member the best course of action was to see what was going on under the holders so I popped them all off and found the likely short where it looks like U11-12 had some issues and is bridged to the run from U16-6.  I'll report back in if that is the fix. If it is the lesson is inspect, inspect, inspect (or have your kids do it if your eyes are aging) and take a picture at each stage of the process.

IMG_4854(Edited).jpg

  • Like 1

Share this post


Link to post
Share on other sites

Final update: All chipped up and back in business.

Ready for the next mods!

EE7FCBF0-3DA7-4975-B892-5FC0B237FD44.jpeg

507AA396-E7F0-45A0-BDD8-836DBDAB615E.jpeg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...