Jump to content
Sign in to follow this  
Simon Carter

1050/SD Drive Max Question

Recommended Posts

Hi folks,

          super happy that I've managed to get hold of a working 1050 at a fairly decent price in the UK, but have one question - can you daisy chain an SD Drive Max via the second IO port? Main reason I'm asking is the printed SIO plug on my SDM is a tight fit on my 65XE and straight up about 1mm too big to fit in the IO on the back of my 1050. I didn't know if this was a design choice or some poor quality 3D printing (that I could fix with a little plug shaping). As an aside, will plugging it in to the 1050 provide it with enough power to work, or will it need an external supply?

 

And I'm guessing if it will work, I can copy from the SDM (using D2-4) to disks on the 1050 (D1)

 

And by god, how expensive are new 5.25 inch floppies these days... best I found on eBay (yes I know...) was 10 for £30.

 

OK, might have been more than one question.

 

When I was 13 years old, I thought I had a decent understanding of these computers, what you can do with them these days absolutely bakes my noodle!

 

TIA

 

Si

Share this post


Link to post
Share on other sites

 

32 minutes ago, Simon Carter said:

can you daisy chain an SD Drive Max via the second IO port?

I think it depends if the SDrive has it's signals buffered, I've heard of some that don't like SIO devices on the bus, I built my own

and included a 7407 chip to buffer all the signals.

 

Best thing is try it and see if it works.

 

If it does, then just use it as a normal drive.

Share this post


Link to post
Share on other sites
1 hour ago, Simon Carter said:

an you daisy chain an SD Drive Max via the second IO port?

You need to ask your vendor if they included the SIO mod to allow for the use of real drives along with the SDrive-MAX, if they didn't then you cant.  It would be a daughter board that may look a little like this:

https://www.vintagecomputercenter.com/product/sdrive-max-sio-mod-pcb-ver-1-0

Share this post


Link to post
Share on other sites
2 hours ago, videofx said:

The only way I got mine to Work was with Sdrive max as drive 1 and 1050 as drive 2

If you don't load an image to the D1 slot of The SDrive Max then you can set your 1050 to D1.
This works reliably (at least with my SDrive Max).

 

When testing PoP this weekend I even booted Happy 7.1 software from my SDrive (with the 1050 switched off) because I did not have the Happy floppy at hand. When the menu showed up, I "ejected" the image from the SDrive, switched on my 1050 and pushed Reset. The Happy software recognized the drive immediately.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...