Jump to content
Gitbizy

Atari Stacy 4/40

Recommended Posts

Hello all-

I finally got around to opening up my Stacy 4/40 (bought it a LONG time ago through the Atari Developer program).  The Connor CP-3040 drive is oozing and I am going to attempt data recovery via a windows/SCSI system.  
I modded my STACY in the early 90's and put in an accelerator board which worked fine at the time, although I don't have the software right now to enable the accelerator (one wire goes to a pin on the Yamaha chip).

 

@DarkLord I want to make a few initial mods.  I have ordered an Ultrasatan (internal + cables) as per one of your posts.

I would like to completely eliminate the DC/DC board and go to an EL sheet replacement.  Can you steer me to directions on that?
 

Secondly, I'd like to go to the PICO 120w PSU internal one that is on this photo. Do you have directions on that?

Thanks!
 

 

post-5822-0-46273900-1440974368.jpg

 

 

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

FYI, the Accelerator I have goes to pin 27 on the Yamaha YM2149F chip.  I believe it's the Fast Technologies T25.  Any idea where to get the software to monitor/toggle the accelerator on/off?

 

Edited by Gitbizy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...