Jump to content
catmando

Atari Jaguar Sync issues with OSSC

Recommended Posts

Anybody have issues with their jag locking sync with OSSC when the system is started or rebooted?

 

Sometimes mine will get sync straight away, other times the OSSC seems have trouble locking the sync down (usually need to switch the Jag on and off several times before I can get it sync again) 

Share this post


Link to post
Share on other sites

So, updating the firmware from 0.83a to 0.88a on the OSSC appears to have solved 90% of the problem

Share this post


Link to post
Share on other sites
Posted (edited)

I haven't had any problems with the OSSC and Jaguar, but I know compatibility can depend heavily on the upscale mode you select as well as your TV.

 

I have not had a sync issue with any system with the OSSC (including Famicom, SFC, MD, PCE, Saturn, PSX [yes even 240p/480i switching] N64, DC, PSP, and Jaguar) since tweaking my settings just right several months ago, but you might try changing the following:

 

Compatibility > Full TX setup

Set to ON (default is OFF)


If that doesn't work, you might try setting the upscale mode to 2x for 240p, just to see if it helps.  It might be an issue with your particular console or TV, so it's worth dropping down to the minimum settings just to test.

Edited by newtmonkey

Share this post


Link to post
Share on other sites

My ossc is still on .85 I believe and I've never had an issue with my Jag not syncing via RGB to my OSSC? 

 

Share this post


Link to post
Share on other sites

Is your Jaguar PAL or NTSC? Mine is PAL and I have a lot of trouble syncing to the OSSC... In general I need to power cycle the OSSC a couple of times before it syncs. I ended up giving up on it and have bought a Genesis HD Retrovision cable + Jag2Gen adapter.

Share this post


Link to post
Share on other sites
1 hour ago, xDfmva said:

Is your Jaguar PAL or NTSC? Mine is PAL and I have a lot of trouble syncing to the OSSC... In general I need to power cycle the OSSC a couple of times before it syncs. I ended up giving up on it and have bought a Genesis HD Retrovision cable + Jag2Gen adapter.

PAL model, that was the what I was having to do with mine.

 

I'm going to do an NTSC mod and see if that eliminates the issue

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, catmando said:

PAL model, that was the what I was having to do with mine.

 

I'm going to do an NTSC mod and see if that eliminates the issue

I am OK with the games running the way they run in 50Hz so I haven't tried to do the 60Hz mod but perhaps it helps. What I have read is that OSSC has a hardware bug which cannot be fixed via FW update. So, if you use a PAL Jaguar then you should try another scaler such as GBS-C or Retrotinker. In my case, I felt that using the HD Retrovision Cables + the Jag2Gen produced quite a nice image and my TV is able to proper scaling the 240p signal with minimal input lag.

Edited by xDfmva
English error

Share this post


Link to post
Share on other sites
3 hours ago, xDfmva said:

Is your Jaguar PAL or NTSC? Mine is PAL and I have a lot of trouble syncing to the OSSC... In general I need to power cycle the OSSC a couple of times before it syncs. I ended up giving up on it and have bought a Genesis HD Retrovision cable + Jag2Gen adapter.

I also get that issue when running PAL. If I switch the console to NTSC then the sync is fine. But yeah, PAL is hit n miss.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...