Jump to content
Sign in to follow this  
GreyHobbit

XC12 no audio channel

Recommended Posts

I picked up an XC12 from eBay and it loads programs ok, but with, for example, the Conversational French cassettes, there is no audio in the spoken sections.  I tried playing a normal audio cassette with POKE 54018,52 but there's no sound with that either.  The cassettes play ok in a standard cassette player.

 

(Oddly, I tried it on my 800, in case the U1MB in my 800XL was causing an issue, and there is no audio there either, but when I enter the POKE 54018,52 and press Play, the 800 does a soft reset.  The tape motor starts up when entering the POKE command with the play button already pressed.)

 

I can see a digital signal on the Data In pin when playing a cassette, but no signal at all on pin 11 when there should be an audio channel, so I'm guessing the left channel is being read ok but the right channel signal is getting lost somewhere between the head and SIO pin 11.

 

Has anyone found a service manual for the XC12?  I can only find the 1010 service manual and I'm not sure how much of that will apply equally to the XC12.  This schematic is the best info I can find on the workings of the XC12.

 

Thanks

Geoff

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, GreyHobbit said:

but when I enter the POKE 54018,52 and press Play, the 800 does a soft reset

The 800 %V on the SIO port does not have enough power to drive the cassette, the 410 which came

with to 800 has it's own power supply, that's probably why it resets.

 

Here's a link to the owners manual https://archive.org/details/atari-xc12-manual

 

I have this circuit diagram

 

 

xc12.gif

Edited by TGB1718

Share this post


Link to post
Share on other sites

Thanks for your reply, I thought the 800 issue might have been voltage-related but wasn't sure.

 

I was investigating it again and noticed that when I touched the Q3 transistor the audio track started to come through, but with a lot of crackle.  Even when I stopped the tape the crackle continued and got louder until I pressed Reset on the 800XL which reversed the POKE 54018,52.

 

There may be a dry solder joint on Q3, or possibly the transistor is bad.  I'd like to confirm that before I try to source a replacement.

 

That schematic is very similar to the one I have, thanks for the link to the user manual.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...