Jump to content
Sign in to follow this  
ThatGuyUKnow

Lynx 2 BennVenn screen single pixel issue

Recommended Posts

I have 2 Lynx 2 consoles. Both have been recapped and the power systems refreshed. I installed BennVenn screens in both. I get a single blinking pixel ONLY in the Blue Lightning intro. It doesn’t appear in gameplay and doesn’t appear playing Shadow of the Beast at all. The pixel shows up in exactly the same place on both consoles. I’ve already asked Ben in his discord and he believes it’s a ram/Suzy issue. I would expect that if it was a ram or Suzy issue the pixel would be a consistent issue, but it’s not, it only blinks during the intro of Blue Lightning and goes away when the game starts. It’s a Rev 6B screen. I wanted to ask here to get second opinions.

52E595D9-4ECA-483B-94C4-17A83C9485D7.jpeg

Share this post


Link to post
Share on other sites

The main odd thing here is that you have the exact same flickering pixel for just Blue Lightning happening on two different Lynx 2 systems correct? While I could see the Suzy to blame for one of them it seems odd you would have two that are failing in the exact same manner.

 

That said, if it just the one pixel and only on this game, I wouldn't worry about it too much unless it started to get worse over time of course.

 

Share this post


Link to post
Share on other sites

I had a very similar thing going on when games would boot up on my own Lynx 2 units with the BV screen.

Ben believes it to be a ram / Suzy issue.... and he was quite nice enough about it as well, to even offer a replacement screen though he was 99% sure the issue wasn't with the screen.

I'm half tempted to fire up that game on my BV modded lynx 2 and see if I have the same results.

I have a half baked theory that these pixels are "normal", just not highly visibly on the original units due to the poor screen quality, lower resolution, and contrast issues.... maybe I'm completely wrong though and you do happen to have two different units with the same graphical artificating issues.

It's quite possible it is, as Ben says, a ram / suzy problem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...