Jump to content
jedimatt42

GEMINI protocol browser: VIRGIL99

Recommended Posts

Also, in reading through his pages, going from the m102.gmi back and then to the as2000.gmi, the m102.gmi was longer...and somewhere I'm not resetting something and so I'm drawing lines from an old page at the end of the shorter page... 

 

edit... nope, it's more a paged ram issue... 

Share this post


Link to post
Share on other sites

This executable shouldn't need any updates to ForceCommand. 

 

Fix illogical history... 

Fix relative urls

Add url normalization

* /foobar/../ becomes /

* /./ becomes /     

Navigation through the site @dgrissom noted should be fixed now.

Better formatting for long headings, and long bullet lines. 

Added CTRL-A to bring up address bar... updated about: page to agree. 

Now show last line in page even if it didn't have a line terminator.

 

 Virgil99 1.3: VIRGIL99

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, jedimatt42 said:

This executable shouldn't need any updates to ForceCommand. 

 

Fix illogical history... 

Fix relative urls

Add url normalization

* /foobar/../ becomes /

* /./ becomes /     

Navigation through the site @dgrissom noted should be fixed now.

Better formatting for long headings, and long bullet lines. 

Added CTRL-A to bring up address bar... updated about: page to agree. 

Now show last line in page even if it didn't have a line terminator.

 

 Virgil99 1.3: VIRGIL99

Wow! Much improved!

I like that is a single file replacement/upgrade!  Boy is it an upgrade!

 

On the earlier version 1.2, I noticed the improve response that after the screen downloads.   Scrolling is fast and smooth.  Seems more robust!

 

Will dig up other sites to test it over the next couple of days!

 

DG

  • Thanks 1

Share this post


Link to post
Share on other sites

I'd be curious if anyone else has problems with this link:

 

gemini://geminispace.info/known-feeds

 

For me it corrupts the display, filling it with vertical bars... 0xB3 in my font... or overrunning the character definition table... not sure which... 

(edit: Saying something out loud is the number one way to find your bugs :) it's an interesting edge case if the line is exactly 80 characters, then I clear to the end of the line -1 (a.k.a. 65536) characters. LOL

  • Like 3

Share this post


Link to post
Share on other sites
8 hours ago, jedimatt42 said:

I'd be curious if anyone else has problems with this link:

 

gemini://geminispace.info/known-feeds

 

For me it corrupts the display, filling it with vertical bars... 0xB3 in my font... or overrunning the character definition table... not sure which... 

(edit: Saying something out loud is the number one way to find your bugs :) it's an interesting edge case if the line is exactly 80 characters, then I clear to the end of the line -1 (a.k.a. 65536) characters. LOL

Yes, it looks like blows up on a long line of text:

Below are the public feeds of which geminispace.info is aware. This list is auto-generated from the index, so if your feed is not showing up here, please use the link at the bottom of this page to submit a crawl request for your feed URL.

 

The display becomes very artistic!

  • Like 1

Share this post


Link to post
Share on other sites

I'm experiencing an error in all versions of Virgil99.  In all versions, the program loads and displays the About page, and this can be scrolled.  But likewise in all versions, attempting to open a Gemini link results in an error (or I expect this is what the text in the footer signifies). 

 

In Virgil99 1.2 this is "Loading 42" (with the program freezing).  And in Virgil99 1.3 this is "Loading 45" (with the program likewise freezing).  The TIPI certainly has an Internet connection, as I'm able to pull up myti99.com in Stuart's Browser. 

 

The setup is the expected F18A/SAMS/TIPI.  Tried both the 1.2 and 1.3 versions of Virgil99 under both Force Command 1.28 and 1.29. 

 

Interestingly, clicking the "Gopher URLS are Yellow" text (which I presume to be a Gopher link) results in a "Loading 42" message, but does not freeze the application.  Only the Gemini links (or submitting a Gemini address via the ADDRESS box) freezes the application.

 

Any ideas on troubleshooting this?

Share this post


Link to post
Share on other sites

Loading nn - the nn indicates lines loaded so far... But those 42 45 values are just the about: pages line lengths for the respective versions.

 

I don't support gopher, so it should just ignore the click.

 

So, the only real blocking happens when opening a connection. I would guess you don't have the last TIPI update that supports TLS connections... 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the quick reply Matt!  Yes, that makes a great deal of sense, and was surely it.  Updating got things going, there. 

  • Like 2

Share this post


Link to post
Share on other sites

VIRGIL99 v1.4

 

It requires changes I made to the ForceCommand cartridge, so you'll have to fetch the whole bundle again: https://github.com/jedimatt42/fcmd/releases/download/v1.30/forcecmd_1.30.zip, or over in the ForceCommand thread. The changes are all about VIRGIL99

 

Rewrote a bunch of the good stuff... Now it's faster, and does not crash on the gemini://geminispace.info/known-feeds page. 

 

That page also exceeds my 1meg SAMS... so a quick out of memory check stops it from overrunning... so, with that I've successfully loaded over 10000 lines from one page. You'll get bored before that happens... it is substantially faster now, but not 10000 lines fast.. 

 

Improvements:

* faster loading

* out of memory check

* snoring pointer when loading ( even though it is getting some ZZZs in, it is still active and you can click and interrupt loading and scroll / etc... )

 

Known regressions:

* word wrap (it's just character wrap at the moment)

* history - back button reloads the current page (sometimes), you can hit STOP, then BACK again to get to the expected prior page.

 

Known continued issues:

* ANSI color in pre-formatted blocks is not interpreted.

* long urls and link lines render to the screen poorly and become invalid urls.. 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, jedimatt42 said:

That page also exceeds my 1meg SAMS... so a quick out of memory check stops it from overrunning... so, with that I've successfully loaded over 10000 lines from one page. You'll get bored before that happens... it is substantially faster now, but not 10000 lines fast.. 

 

I think it's about time we get bigger SAMS cards.😆

I've been approaching the 1MB sams limit myself (while testing with big files in Stevie) 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, retroclouds said:

 

I think it's about time we get bigger SAMS cards.😆

I've been approaching the 1MB sams limit myself (while testing with big files in Stevie) 

 

We actually need smaller cards, so the limit tests can run quicker.

 

  • Haha 1

Share this post


Link to post
Share on other sites
3 hours ago, jedimatt42 said:

VIRGIL99 v1.4

 

It requires changes I made to the ForceCommand cartridge, so you'll have to fetch the whole bundle again: https://github.com/jedimatt42/fcmd/releases/download/v1.30/forcecmd_1.30.zip, or over in the ForceCommand thread. The changes are all about VIRGIL99.. 

Great.  Not able to test it much this week.  Looking forward to trying it!😀

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

today I tried the browser VIRGIL99 v1.4. The mouse pointer reacts very smoothly, just like on a modern PC. 

 

I found an interesting article about an alternative operating system from 1989 called Plan 9.

 

Main page ADDRESS:
gemini: //sunshinegardens.org/~xj9/wiki/plan9/

 

IMG_4374.thumb.JPG.fcb3f82ba4790b935c760380d4b23dca.JPG

 

=> plan 9 from bell labs

 

Article ADDRESS:
gemini: //sunshinegardens.org/~xj9/wiki/plan9/from-bell-labs.gmi

 

This page loads 1336 lines and uses 156K of memory

 

IMG_4373.thumb.JPG.a3fb87778d7f93b6a97c809669ea8b65.JPG

  • Like 3

Share this post


Link to post
Share on other sites

Was indeed named after the famous blockbuster movie "Plan 9 from Outer Space".

 

(Kam vor einiger Zeit auch in Schlefaz, falls du das schaust)

Share this post


Link to post
Share on other sites

Loading of pages is magnitudes faster!

It seems that a lot of the Gemini pages listed on the official Gemini site either give a connection error or an unknown mime type error. Probably nothing to do with Virgil99 but rather the highly experimental state of the Gemini project to date.

Incidentally, the tilde does not display in the address line (FCTN-W).

One feature request would be a favorites list to store the interesting sites.

  • Like 2

Share this post


Link to post
Share on other sites

I haven't loaded Virgil99 up yet, but seeing some of the pages/content, how about a function to print to PI.PIO ?  Perhaps with a selected page range?

 

 

  • Like 2

Share this post


Link to post
Share on other sites

You can go to the address 'about:' and read up on the hotkeys... This page is shown if no start page is given on the command line.

 

I chose CTRL-A for the address dialog.

 

Next I have to implement paging C code in SAMS. I have 2k left in upper expansion address space, but this will be easier to do before it gets more complex.

 

It is also probably time to start curating and developing some content.

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, wolhess said:

Hi,

 

today I tried the browser VIRGIL99 v1.4. The mouse pointer reacts very smoothly, just like on a modern PC. 

 

I found an interesting article about an alternative operating system from 1989 called Plan 9.

 

Main page ADDRESS:
gemini: //sunshinegardens.org/~xj9/wiki/plan9/

 

 

 

=> plan 9 from bell labs

 

Article ADDRESS:
gemini: //sunshinegardens.org/~xj9/wiki/plan9/from-bell-labs.gmi

 

This page loads 1336 lines and uses 156K of memory

 

 

Nice article.  Formatted well for VIRGIL99.  Stuff, I like to read!

  • Like 1

Share this post


Link to post
Share on other sites
36 minutes ago, jedimatt42 said:

You can go to the address 'about:' and read up on the hotkeys... This page is shown if no start page is given on the command line.

 

I chose CTRL-A for the address dialog.

 

Next I have to implement paging C code in SAMS. I have 2k left in upper expansion address space, but this will be easier to do before it gets more complex.

 

It is also probably time to start curating and developing some content.

CTRL-A is not working on my install.

CTRL-X, CTRL-E works.   Mouse to the ADDRESS at the top works.

A few crashes so far.  I will try to get repeatability.

Otherwise, very usable.  Lookin' good!

 

 

DG

 

Share this post


Link to post
Share on other sites
25 minutes ago, dgrissom said:

CTRL-A is not working on my install.

CTRL-X, CTRL-E works.   Mouse to the ADDRESS at the top works.

A few crashes so far.  I will try to get repeatability.

Otherwise, very usable.  Lookin' good!

With Virgil99 v1.4 on my side CTRL-A, CTRL-X and CTRL-E are working. Also the mouse to ADDRESS!

  • Like 1

Share this post


Link to post
Share on other sites
16 minutes ago, wolhess said:

With Virgil99 v1.4 on my side CTRL-A, CTRL-X and CTRL-E are working. Also the mouse to ADDRESS!

Found my problem.  Had a 1.2 version in TIPI.FC.BIN  and 1.4 version in TIPI.FCMD.  Depending on how I accessed VIRGIL99 I would get different versions.

Rebuild my TIPI folders/installation this week.  This slipped through the "cracks"

 

CTRL-A does work!.  Probably explains why some pages crashed and then didn't crash.  🙂

 

Thanks

 

DG

Share this post


Link to post
Share on other sites
27 minutes ago, wolhess said:

With Virgil99 v1.4 on my side CTRL-A, CTRL-X and CTRL-E are working. Also the mouse to ADDRESS!

What about the tilde (CTRL W)? Does it display in the address space?

  • Like 1

Share this post


Link to post
Share on other sites
23 minutes ago, Vorticon said:

What about the tilde (CTRL W)? Does it display in the address space?

It doesn't work on my 1.4 install.

 

It along with these: {, }, |  

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Vorticon said:

What about the tilde (CTRL W)? Does it display in the address space?

@Vorticon I think I misread your post as suggesting you should hit CTRL-W to open the address bar... but I bet you are talking about being able to type a ~ in the address such as for a /~user/index.gmi  type link...

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, jedimatt42 said:

@Vorticon I think I misread your post as suggesting you should hit CTRL-W to open the address bar... but I bet you are talking about being able to type a ~ in the address such as for a /~user/index.gmi  type link...

fixed, but it's a cartridge update - there is a little mouse tuning in the VIRGIL99 executable too. 

 

https://atariage.com/forums/topic/290966-force-command-ver-131-kinda-like-commandcom-from-1985-no-tipi-required/

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...