Jump to content
rcamp48

Forem XE Pro Version 6.0 Is Now Out

Recommended Posts

Well, its been 36 hours plus working on Forem XE Pro Version 6.0 for the Atari 8 Bit computer, making an install disk, and coding the PD code, I have added a few changes to the program, mainly adding ports listening, auto answer and baud lock for the ESP Wifi modem that is in the Fujinet. There are a few instructions as how to put everything together, watch the video and run the install program(s) that I have created, after I modify the main start program to allow for port listening and the like I will release it here.

 

The music I put together from MIDI files that are freely downloadable on the internet (with Mixcraft 9 Pro), and I made the video to show off the new software. Note that you need a 130 XE with at least 128 KB and a Basic XE cart to even run this software, but it can be dome and the Fujinet is just barely fast enough. Here is hoping that you will like my video: Forem XE Pro Version 6.0 Video Demo

 

Forem_XE_Pro_5.4_Master_Disk_Updated_With_Docs.atr - Put in slot # 1

foremxe_updated_disk_one.atr                                       - Put in Slot # 2

foremxe_updated_disk_two.atr                                       - Put in Slot # 3

 foremxe_updated_disk_three.atr                                    - Put in Slot # 4

                             - Put in Slot # 6

 

It is important that these files go into the right slots , cause the script is coded for these locations, and not easy to change, a blank disk , 720 K was created for disk # 6.

 

Enjoy: PS: Forem XE Program has been edited to run with what is running from the start. Russ

 

Edited by rcamp48
Edited files for download
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, rcamp48 said:

Forem_XE_Pro_5.4_Master_Disk_Updated_With_Docs.atr - Put in slot # 1

foremxe_updated_disk_one.atr                                       - Put in Slot # 2

foremxe_updated_disk_two.atr                                       - Put in Slot # 3

 foremxe_updated_disk_three.atr                                    - Put in Slot # 4

                             - Put in Slot # 6

 

It is important that these files go into the right slots , cause the script is coded for these locations, and not easy to change, a blank disk , 720 K was created for disk # 6.

Am I the only one not seeing the download for the blank disk?

Share this post


Link to post
Share on other sites
1 hour ago, firebottle said:

Am I the only one not seeing the download for the blank disk?

Probably but I have a newer one anyways , everything has been updated....I will upload it and all of the files needed.... Russ

Forem XE Pro Version 6, created by my program script

 

Forem_XE_Pro_5.4_Master_Disk_Updated_With_Docs.atr  - Goes in Slot One  --  Updated, Drive 1

foremxe_updated_disk_one.atr  - Goes in slot Two -- updated, Drive 2

foremxe_updated_disk_two.atr  - Goes in slot Three -- Updated, Drive 3
foremxe_updated_disk_three.atr  - Goes in slot Four -- Updated, Drive 4

Forem_xe_pro_Version_6_updated.atr -- Goes in Slot 6 -- Updated, Drive 6

 

If you have the drives in the correct order, booting up should bring you to a Spartados XINIT command automatically, always choose drive 6 as the drive to format, (7) 80 tracks, (2) Double Sided Double Density, if for some reason the drive pauses, press the break key once, Fujinet does not like Spartados as much as other programs, if having problems booting Spartados, set your drive speed to (9) in the Fujinet config. 

 

Later I will make a video showing how to actually set it up for all drives , etc. Russ.

Share this post


Link to post
Share on other sites

Are you doing this in an emulator (Altirra?) or on a real 8-bit machine?

 

Using the word 'slot' leads me to believe an emulator...

Share this post


Link to post
Share on other sites
1 minute ago, bf2k+ said:

Are you doing this in an emulator (Altirra?) or on a real 8-bit machine?

 

Using the word 'slot' leads me to believe an emulator...

I am uising a real machine a 130 XE and Basic XE cart, but I cvall them slots because Fujinet has slots too like an emulator, working oin the program right now.

 

 

 

Just the way I programmed it Doc, slot 5 was not working so I used slot 6, anyways here are 3 more files with bug fixes, etc stuff that was missing from the last release

 

Forem_XE_Pro_5.4_Master_Disk_Updated_With_Docs.atr

Forem_xe_pro_Version_6_updated.atr

foremxe_updated_disk_one.atr

 

All 3 are updated , it should now make a working BBS.....

 

Russ

 

  • Like 3

Share this post


Link to post
Share on other sites
40 minutes ago, _The Doctor__ said:

what happened to slot 5?

Slot 5 will be usedfor Data disk 1 to create subdirectories on it

 

Share this post


Link to post
Share on other sites
1 minute ago, Sugarland said:

Would like to have this working on a Hayes 1200b 😃 For the light show!  Thank you @rcamp48 very much for your generosity and work.

Using a real disk drive? I can put it on disks but I need good disks...

Russ

 

Share this post


Link to post
Share on other sites
1 minute ago, rcamp48 said:

Using a real disk drive? I can put it on disks but I need good disks...

Russ

 

I'd rather use a SIDE2 for a BBS. Will this work on one? 

Share this post


Link to post
Share on other sites
Just now, Sugarland said:

I'd rather use a SIDE2 for a BBS. Will this work on one? 

Yes no problem, I am using a Fujinet

Russ

 

Share this post


Link to post
Share on other sites
1 minute ago, rcamp48 said:

Yes no problem, I am using a Fujinet

Russ

 

 

I guess since BXE uses the cart slot, then an AVG Cart would be required since it can emulate both BXE and SIDE2 at the same time.

 

dollars GIF

  • Like 1
  • Haha 2

Share this post


Link to post
Share on other sites

I feel late to the party.  Where can I find the background context on this?

I don't understand what is going on here, though I know what Forem XE is, I don't get what this does, nor what MIDI files have to do with it.  So confused.  Can someone please point me in the right direction?

 

Share this post


Link to post
Share on other sites

Mainly bug fixes , and soon it will be ready for telnet, not too much,, I just wanted to differentiate between the old version and the one I was working on... there were several mistakes in the coding , and I added script coding to make it easier to install. 

Share this post


Link to post
Share on other sites
4 hours ago, Phlod said:

I feel late to the party.  Where can I find the background context on this?

I don't understand what is going on here, though I know what Forem XE is, I don't get what this does, nor what MIDI files have to do with it.  So confused.  Can someone please point me in the right direction?

 

The MIDI files were just put in as background music, copyright free , and the coding that was being shown was the creation of an install disk with all of the correct directories and sub directories, files , etc...

 

Share this post


Link to post
Share on other sites

This is one of the coolest SOFTWARE things Atari wise I have seen in a long time. Thank you for your tireless work on this. I still need to get Fujinet and get my XEGS modified - but this makes it easier for me and everyone else to run a bbs! 

 

 

Share this post


Link to post
Share on other sites

Its not yet done Doctor, I still need to work on the project a little longer. Also there has been considerable work done on Atari 8 Bit MIDI, I have a link to the video on YouTube, it took 8 hours to perfect with Mix-craft 9 Pro acting as a virtual synthesizer , I will enclose the ATR of the program used to record and play it back with the Atari MIDI file intact so that other users can reproduce the MIDI playback themselves.

 

Finally Atari MIDI on the 130 XE is here, and I have proof in an ATR file.

 

MIDTOOL1.ATR   Use this file on an emulator possibly or on real hardware, it will boot to TurboDos, and you run the RECMIDI.COM file, load the file ATARI.REC and playit, you will have a surprise.

Edited by rcamp48
Correct the typos
  • Like 2
  • Confused 1

Share this post


Link to post
Share on other sites

FoReM XE Pro 6.0 BBS doesn't work, but as a consolation prize, we get a Midi music player! 😆

Edited by JohnPolka
  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...