Jump to content
Peter Rabitt

520stm inside the cover

Recommended Posts

Hi all, I am new to the St computer but have been working on the A8 side.

I have 2ea 520stm I guess the "m" is for RF modulator??? So it is a bare 520 ..I opened the cover today because I have run out of 800xl and 8 bit stuff to play with. I found a extra board and some extra wire in the box..I don't have enough knowledge with ST's so I am asking for help...

Here are the pictureWIN_20211116_15_31_35_Pro.thumb.jpg.9625fd2c78cef5c6f3f6f9194554a17f.jpgWIN_20211116_15_35_58_Pro.thumb.jpg.7053cbf5a5f315f9f732647d443fc07f.jpgWIN_20211116_15_46_04_Pro.thumb.jpg.2df630ef4ebbebf4f1ee511c13bf290b.jpgWIN_20211116_15_34_32_Pro.thumb.jpg.bd0e8e7921546444cdc434c7aa518c6d.jpgs...WIN_20211116_15_31_02_Pro.thumb.jpg.c708581445f291b62f095a2a7c1391b8.jpgWIN_20211116_15_45_20_Pro.thumb.jpg.1820e9cfb3cd7c9fffa567aaa0865527.jpg

Well I hope you can make some sense out of all this mess...

Not sure how to get the pictures in the right order and all.

 

Peter

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

O yes no I have not powered it up yet as the power supplies are not check out and with all the people saying the power need to be recap'ed I need to check them out...I also have 2 monitors one black and white and one colored.. Need to check them out also..Found some 3.5 in disk drives wired to to a pcb and with a st data cable ,so maybe they are going to work with this system...Picture coming...

 

Peter

Edited by Peter Rabitt

Share this post


Link to post
Share on other sites

I'm not really all that familiar with the non-STF 520s, so I'm not sure, but I'd bet it's probably some sort of RAM upgrade. That's really just a guess though. Once you power it up, you should run SysInfo and see what version of TOS it has and how much memory it has. That would tell you quite a bit.

 

Share this post


Link to post
Share on other sites

It is certainly a RAM upgrade. It is connected to the shifter chip. How much I dunno...check with sysinfo as recommended above.

Share this post


Link to post
Share on other sites

Indeed looks like RAM expansion.

Tip: you can look for chips - by what is printed on them, with WEB search. Or someone here could do it - when will see more detailed pic of expansion.

No mess, you need to apologize to persona made it 🙂

Share this post


Link to post
Share on other sites

OK great, thanks for the info...I did find a box in the boxes that I am un-earthing and it said "Z-RAM/2.5 meg upgrade for the 520st...ETC". I guess that maybe the upgrade I have in this ST..It has a couple of "pins" that have to "jab" into one of the square IC on the M.B. ??? Not a real good way but no solder...

I also have the roms (?) that have pin 1 tied together and run to the back of the box to a "new" hole. the wires go to +5v and gnd but the switch is missing... Maybe a duel TOS ??

 

Also found a set (2) 3.5 disks with a pcb and a ST cable, but have not looked into it yet... Still slowly bringing the st with power supply up...

Pictures in a day or two..

The more boxes I open the more strange stuff I find...I don't even remember most of this stuff back in the 80's but i did get into it ...

 

 

Peter

Edited by Peter Rabitt

Share this post


Link to post
Share on other sites

The pins "jabbing" into the square IC is the unit connecting to the PLCC socket of the MMU. It is a common way to upgrade the ram on these. I guess the onboard RAM (original RAM) has been disabled and this 2.5MB upgrade is taking over. I would just leave it. Nice to have a RAM upgrade in there right off the bat anyway. I recently upgraded mine to 4MB using a more modern version of what you already have in here with the same type of method.

 

2.5MB should be more than enough to use a HDD emulator device like masteries ASCI2STM hard drive emulator with this....which I would HIGHLY recommend. Its cheap (under $50 shipped to the USA) and then you can really use this computer to its full extent.

Share this post


Link to post
Share on other sites
9 hours ago, Peter Rabitt said:

Also found a set (2) 3.5 disks with a pcb and a ST cable,

Well I have looked at the 2 disk and have found that the 3.5 drives are NEC FD1035...They are in a "home made" setup and appear ready to go. The power supply with the disks is a CO700919-  ps32 Date code could be 4-83  OLD??  Also has a PCB that appears to have come from a Atari floppy drive .. The data ribbon cable that attaches the 2 disks also appears to go to some other place, maybe a 5.25 drive??

No I have not turn it on or hooked it up yet...Still working on the ST..

 

WIN_20211118_17_32_24_Pro.jpg

WIN_20211118_17_32_47_Pro.jpg

WIN_20211118_17_33_52_Pro.jpg

WIN_20211118_17_36_03_Pro.jpg

WIN_20211118_17_39_20_Pro.jpg

Edited by Peter Rabitt

Share this post


Link to post
Share on other sites

I did something similar with floppy drives on my 520STM, an external twin floppy drive

although mine had the ribbon cable from my external single floppy, also I had an external

5 1/4 floppy in the chain too, with some switches I could select any drive to be A: or B:

 

Have an external HDD in a similar metal case

Share this post


Link to post
Share on other sites

Good day all..

Well today I found a box full ribbon cables and a few Atari sio cables and other stuff I did not recolonizes. I did find a couple of IC 68a10 and 6810 probably the same chip with a different manufacture..Anyway the where piggy back and had two jumpers from the low side pins to the high side of the pins...  Any IDEAS????

Boy digging back in time sure is fun and stressing the old brain...

 

Peter

TGB1718 Yes the drives are ds/dd but did not fire them up as other things came along...Now i am thinking the ST is modded alot more than it first look like...

Also need to find the old 3.5 disk in the boxes...

Share this post


Link to post
Share on other sites

Nothing to add on what some of those items are, but you mentioned SIO cables, which were never used with anything other than the 8-bit Atari line. So, it sounds like you have a mixture of things, and since those SIO cables are in there and they have nothing to do with the 16-bit line, some of those other items may be unrelated as well. Just something to keep in mind.

 

Share this post


Link to post
Share on other sites

Yea I know what you mean..And yes I am also an A8 bit guy.. I have both...I understand the A8 much better than the ST but learning.. I also have 2 ea 800xl, 1   600xl,  a 400,  ATR8000 w/64k memory and some hdd and 5.25 and 3.25 drive...Lots of stuff......On the st side I have a color and mono monitors...So I have a lot of work ahead..

Just hoping for help to remember what I did 35 plus years ago..

 

Peter

Share this post


Link to post
Share on other sites
On 11/19/2021 at 5:49 PM, Peter Rabitt said:

did find a couple of IC 68a10 and 6810 probably the same chip with a different manufacture..Anyway the where piggy back and had two jumpers from the low side pins to the high side of the pins...  Any IDEAS????

Well I found the participial answer... It is a memory upgrade for a 1050 disk drive...I found it in a thread about 1050 and updates to Happy or so drives... No information on on when to change the chip to a two chip but it increases the memory for DD I think... May have to be used only with the 1050 upgrades???

 

Peter

Share this post


Link to post
Share on other sites

New update for anyone watching this thread...

I got the ST with the 2.5 meg running and found two thing ,well three things...

1. The TOS (GEM) comes up but I don't know how to tell what Rev. it is..Any programs or ?? available..

2. The rom's ?? that are in this computer have a wire from each of them (pin 28 ?) to a point where it would appear to have a switch. A hole in the case has been drilled. Right now the pin is at GND..

3. the two drives sorta work... The drive ?A? runs and looks at the disk but does not to format the disk..Disk 2 works great and will read the dir. and format. Have not tried loading a program yet looking for the OLD 3.6 disk for the ST. Have not found them yet.

Question if the disk is formatted on the ST (DS/DD) can you take it to the PC. and add a program and then back to the ST and run it???

Well be cleaning the disk drives and a little oil this week...

 

HAPPY TURKEY DAY TO ALL!!!!😃

 

Peter

Share this post


Link to post
Share on other sites
8 minutes ago, Peter Rabitt said:

1. The TOS (GEM) comes up but I don't know how to tell what Rev. it is..Any programs or ?? available..

Either this: https://sites.google.com/site/stessential/system-tools/sysinfo

 

or check Desktop Info under the menu Desk in desktop of GEM. You will see some date on there. Then look for the date on http://avtandil.narod.ru/tose.html under 'GEM Reports' date.

Share this post


Link to post
Share on other sites

WOW thanks for the INFO.. I downloaded the program, but the avtandil does not come up??

O well the date is 89 the last year it shows..That's all...

Share this post


Link to post
Share on other sites

It says '1985,86,87,88,89'?

 

In that case you got TOS v1.04 (also called Rainbow TOS due to the fuji logo being in rainbow color)

Edited by snarkdluG

Share this post


Link to post
Share on other sites

OK that's what it is.. The Atari Logo does turn colors... Great I don't have to buy TOS v1.04 roms....

Thanks for the Info...It seems back in the 80's I must have been more active with the ST520m than i was aware of.

Mow to get to work every time I boot up...Sometimes it comes up fine and other times it gives me 20 bombs...

I think its the 2.5mb memory upgrade not staying in place...

 

Peter

 

Edited by Peter Rabitt
spelling

Share this post


Link to post
Share on other sites

Hi, @ Chri O.Thanks for the help... Now I have a question: If the ST won't boot up, it goes to 20 bombs,  how do I run the memory tester program...If I can't get the ST to read the floppy disk or how do I get the program to the floppy disk??? I guess I have run this problem before with the 800xl I was working on.. How to move files from the PC type system to the ST system??

 

Thanks for the help...

 

 

Peter

 

 

Share this post


Link to post
Share on other sites

Update...Opened my second st 520m and found it had also been updated to, I think to 2.5 meg also, but a different update kit.same design.

The reason I opened it was the power switch was bad?? Well it was because i could not turn on the ST. Jumped the switch and it powered up but did not boot to desk top. Just some colors and sometimes blank sometimes write just all over the place...

So the question is has anyone seen the power switch for sale before I try to do something I don't want to do...

 

Peter

 

 

Share this post


Link to post
Share on other sites

Up UP date!!!

Pictures of the second 520.. This one has updated memory also..

 

@bfollowell, Yes the switch you showed was a good switch for a power supply but not for the ST.. Ordered one from Digi-key...Little ex$$$ but ok with it..

 

The Roms in this unit are Co26160-001, RP23256 to CO26165-001  RP 23256. Does that ring a bell and what TOS they are??

 

 

WIN_20211128_16_33_59_Pro.thumb.jpg.3ae4e239e443ad382213901686bfeb3e.jpg

WIN_20211128_16_36_16_Pro.thumb.jpg.65a10d9576c5aa99c5c8f297d1b27fca.jpgWIN_20211128_16_36_35_Pro.thumb.jpg.0d54b4ee19bd833e1b6e2d2f6ecaa756.jpgWIN_20211128_16_38_04_Pro.thumb.jpg.6e80e6bf1beecbb34ffd5e975547144f.jpg

Share this post


Link to post
Share on other sites
16 hours ago, Peter Rabitt said:

...

The Roms in this unit are Co26160-001, RP23256 to CO26165-001  RP 23256. Does that ring a bell and what TOS they are??

...

 

 

 

I don't think that anyone keeps those numbers in head 🙂 Just search with google for. And that stays for other cases too - may get answer faster than waiting for reply in forum.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...