Jump to content
Sign in to follow this  
Chandler

Falcon TOS 4.04 rom image needed

Recommended Posts

Can anyone point me in the right direction of a working Falcon TOS 4.04 rom image please so i can burn my own TOS rom

 

Thanks

Share this post


Link to post
Share on other sites

Thanks

 

So do i need to do anything to this image or can i simply burn that file onto a rom?

Share this post


Link to post
Share on other sites

Besides learning how to burn a ROM?  I mean, just that I'm not sure what you're asking... Most of the ROM files like that are dumps from burners/readers.

 

Usually, the only thing that needs "done" is breaking it out into the specific number of chips since some of the "lower machines" would have two to six chip variants within the same "model" which wasn't the case with the Falcon.

 

 

Share this post


Link to post
Share on other sites
On 1/10/2022 at 4:05 AM, Chandler said:

Thanks

 

So do i need to do anything to this image or can i simply burn that file onto a rom?

You can check it for correct size. Can test it in Hatari. And instead asking more trivial things - it is called EPROM where it will go, pardon burn it's way by flame 🙂

Share this post


Link to post
Share on other sites
1 hour ago, Chandler said:

Can i use HN27C4096CC-10

 

or does the rom need to be a -12 or -15 ?

 

Thanks

Yes.

 

-10 should be 100ns. -12 and -15 are slower. 120ns and 150ns.

Share this post


Link to post
Share on other sites

Sometimes the file will need to be byte swapped before burning.

When you load it into programming environment, TOS 4.04 first word should be 602e.

If it reads 2e60 or else, you need to do a swap.

I have CGYWIN on a PC, and use dd.

 

I can send a 55ns Amtel with 4.04 when I send the COMBEL.

Edited by rustynutt
Forgot something

Share this post


Link to post
Share on other sites

Well i've been trying to make this TOS 4.04 Eprom with no success, i'm using Hitachi erasable HN27C4096CC-12 EPROMs

 

Using a Willem PCB50 programmer

 

I load the file (512K) (Downloaded from this thread) into the Willen PCB50

 

I can see the first word starts 602e

 

The EPROM is blank, the programmer copies and verifies the image

 

I insert the EPROM into the Falcon and all i get on a low res colour monitor is a black screen with red lines, no boot

 

Re install the original rom and all is well so there's nothing up with the Falcon

 

Can anyone help?

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...