Jump to content
Jasoco

Digital Press has been hacked

Recommended Posts

When's the forum update? :ponder:

 

While I've put it off many times in the past, I've now put it at the front of my plate. All these vulnerabilities in phpBB are just icing on the cake. The sad thing is I purchased a license for IPB back in July of last year.. :ponder:

 

..Al

Share this post


Link to post
Share on other sites
Did they release a patch Al, or just a warning?  It's only a matter of time before they get back around to us I guess.

 

They released a patch fairly quickly, but it didn't take long for someone to create an exploit for the critical issue that was patched. I didn't even know a new version on phpBB had been released by the time the board was hacked, which occured the day after the patch was released.

 

..Al

Share this post


Link to post
Share on other sites
Hey for kicks you should just go back to the Nexus style forums and see what people say :D

 

Hmm, are you talking about the original Nexus boards? I think those were on some freebee public message board. Man that was along time ago...

Anyone else still around from those days? :D

 

Mitch

 

I was just a lurker back in the Nexus days. In part because the forum software made it such a pain to read the threads.

 

For those of you who weren't there, you had to click on each response and wait for it to load. The Stella List archives look similar to it. I had a really slow computer back then, so I only clicked on the threads I really thought were interesting. Good thing there wasn't much activity on the boards back then.

Share this post


Link to post
Share on other sites
They released a patch fairly quickly, but it didn't take long for someone to create an exploit for the critical issue that was patched.  I didn't even know a new version on phpBB had been released by the time the board was hacked, which occured the day after the patch was released.

 

Which is pretty much how most Windows hacks work... reverse engineer a patch to find out the exploit, then write something to take advantage of it...

Share this post


Link to post
Share on other sites

It's been safe since the hack was fixed. Like many many days ago. You could have been browsing DP happily for days. Go! Go and enjoy!

Share this post


Link to post
Share on other sites

Besides, the "Hack" couldn't even hurt you unless you actually installed the "Plugin". If you don't install it, even visiting the page it's located on won't hurt you. (Just beware, the page automatically downloaded it if you sit there for a minute. So one day you're wandering through your Downloads folder and see a stray EXE named "plugin" and figure, "Hmm.. it must be important.. what the hell?" and double-click your computer into obscurity.)

 

Go! Visit! It's been safe since the night the trojan was found! Go!!!

Share this post


Link to post
Share on other sites

Bringing this back up so i don't have to start a new thread. Is there something wrong over at Digaital Press? I can't seem to get to the site at all. I get a blank page with this on it:

 

 

:19638/webhost/rollout">-->

 

anyone know?

Share this post


Link to post
Share on other sites
Seems the server was compromised and there was "an outbound DDOS

> attack" coming from the box. As a result it's been WIPED CLEAN. It's

> going to take quite some time to get everything installed and the

> backups uploaded.

Share this post


Link to post
Share on other sites
Whatever you do, DO NOT RUN this program. It is most likely spyware or a virus. Either way, being on a Mac, I'm immune, but annoyed I can't even get to the forums.

You are LIKELY immune. You are not GUARANTEED immune.

There is a POSSIBILITY that it's a Mac trojan instead of a Windows trojan. Less likely, but still possible, is a platform-neutral exploit in the browser.

 

 

Macs are not invincible. There viruses, spyware, etc that hit Macs. They're jsut less common.

Share this post


Link to post
Share on other sites

It looks like they at least altered the meta tag to block a refresh. I get this - 19638/webhost/rollout">-->

Share this post


Link to post
Share on other sites

The site and forums are back online.

 

I can't find the post where one of the members here commented on the forum's "too busy" look, but if that's really an issue all you have to do is change the skin template from your user profile. The skin "myApple" eliminates all signatures and has a very clean look; "MSSimplicity" has no signatures OR avatars - and is the one that office-browsing folks use the most.

 

Once again, sorry for the inconvenience. Even after 14 years, we're learning!

Share this post


Link to post
Share on other sites
If it's back online, how come I get a 404 error every time I try to view?

924313[/snapback]

 

Just go to Digitpress.com and then choose the forum from the sidebar on the right. If you try to go to the forums directly, you'll get a 404 error. I'm sure it's just temporary as they're still fixing things up.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...