Jump to content
Sign in to follow this  
gobo

Turbo Basic XL Question

Recommended Posts

Hi,

 

I was recently looking over some of my old Atari Basic games I wrote way back when and wanted to tweak one using Turbo Basic XL instead of Atari Basic. The problem is that when I run it under Turbo Basic XL it starts out fine but then gives an Error 12 (line not found). When I list the lines they are gone as if Turbo Basic deleted them. They are right at the end of the code listing using line numbers like 20000 and 30000 etc. In the game I used a Machine Language Routine in Page 6 (page 6 I'm guesing from distant memory) that moves some Player Missile Graphics around. Could Turbo basic have a problem with that? Any Ideas? I didn't use many REM statements because the program used just about every free byte in Atari Basic. I was hoping to get more free space and speed using TB XL. Strange.

 

 

Thanks

Gobo

Share this post


Link to post
Share on other sites

Hmmm, have you checked out your basic listings to make sure they are OK? TB uses less resourses than standard Atari Basic even with the further features/commands. It is fully compatible with Atari Basic and of course you can use the compiler for a significant increase in speed. TB leaves page 6 free as you would expect. I seem to recall a limit in the format of the listings sometimes ... it's in the back of my mind.. it's been many years ! ... can anyone remember this ?

Share this post


Link to post
Share on other sites

If I remember correctly, the resident part of TBASIC is in low memory-area.

This means free RAM is different. So when you have put players/missiles in the area normally safe for your standard basic-listing, it could be unsafe using TBASIC. I think your players/misslie overlap your listing, erasing parts of it.

 

Try moving up your players/missiles 8K.

 

cheers,

sijmen.

Share this post


Link to post
Share on other sites

Thanks , I'll give that a try. It's weird to be playing with this language again. Can't beleive I remember using it so well. Seems like a lifetime ago. I spent many an hour in Atari Basic on my Atari 400. (Dreaming of the 1200XL:).

Share this post


Link to post
Share on other sites
I think your players/misslie overlap your listing, erasing parts of it
that's what I was trying to remember! yes you are right. I recall coming across the same thing when using TB at the time. moving your location should solve the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...