Jump to content
Sign in to follow this  
orpheuswaking

130XE jacked up picture/sound

Recommended Posts

Hey Guys,

 

I just dug out my old 130XE and hooked it up for the first time in years, it worked great for a day and then when I played it today after about 20 minutes the picture went out and a loud buzzing came through the speakers... Originally I hooked it up with the RF so I switched it over to the monitor cable (out to rca jacks) and still no picture... What I was getting is a rolling screen at best and fuzz at worse (One time it was all red)... The sound was a continous buzzing...

 

So.... I figure that as both RF and Monitor out had the issue it's something internal... what however I have no clue... Hopefully something realtively simple to fix and not too expensive

 

any ideas???

 

Simon

Share this post


Link to post
Share on other sites

Could be simple:

defective PSU

 

Or not:

Looks like a dead CPU or GTIA-chip.

But could also be failure in a standard IC .

1st release 130XE has CPU in a socket = easy replacement :-)

 

Cheers,

Sijmen.

Share this post


Link to post
Share on other sites
Could be simple:

defective PSU

 

Or not:

Looks like a dead CPU or GTIA-chip.

But could also be failure in a standard IC .

1st release 130XE has CPU in a socket = easy replacement :-)

 

Cheers,

Sijmen.

843470[/snapback]

 

Checked PSU (Have several) not that...

 

So how do I go about checking the other things? I had it apart yeserday but realized that my knowledge of the internal workings of the Atari is lacking somewhat...

Share this post


Link to post
Share on other sites

If CPU replacement does not work (if it's socketed) you are

not able to fix it. You need the electrical drawings + scoop

for trouble shooting. The drawings.... I have, but I can't

tell you were to start. sorry.

 

cheers.

Sijmen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...