Jump to content
itatton

Problems with an Atari 1200XL

Recommended Posts

I just recently found an Atari 400 and an Atari 1200XL for 60 bucks (for the pair and a handful of games and an ATARI 1030 MODEM!! WOOHOO!). I was pretty excited since I've been looking for one for a while, but I'm having a problem with the 1200XL. It appears that there are approx 15 keys on the keyboard that do not work. When you press the key in there is no keyboard input from the BASIC cart. I've used the same cart in the 400 so I know it works. There are a couple keys that when held down will intermittently not work. Is this something that might be fairly easy to fix or should I go take it back.

 

Thanks in advance for the assistance.

Share this post


Link to post
Share on other sites

This is pretty common on 1200XL's. I've been able to fix several of them by taking the keyboards completely apart, cleaning everything, and reassembling them.

 

-Bry

Share this post


Link to post
Share on other sites

If checking connections and cleaning all the contacts doesn't work you could just order a replacement keyboard from BEST or someplace (if you want to spend a little more money). :( They are at least very easy to replace.

Share this post


Link to post
Share on other sites

I had this same problem with my 1200XL back in 95ish sometime.... finally after years of it sitting around I sold it on eBay in 2000 as-is.... and never looked back...

Share this post


Link to post
Share on other sites

http://retrobits.net/keyboard.html

 

I've never met a 1200XL keyboard that was in physically complete condition and hadnt been previously 'fixed' that couldnt be restored with a little TLC.

 

If you open it and find someone has previously failed at fixing it, it might be time to find a new keyboard, bad repairs usually make things worse.

 

Steve

Share this post


Link to post
Share on other sites
http://retrobits.net/keyboard.html

 

I've never met a 1200XL keyboard that was in physically complete condition and hadnt been previously 'fixed' that couldnt be restored with a little TLC. 

 

If you open it and find someone has previously failed at fixing it, it might be time to find a new keyboard, bad repairs usually make things worse.

 

Steve

862521[/snapback]

 

I have the same problem with my 1200XL. They need TLC :-)

When you don't use it for a few month, keys are starting to fail.

But when I press them repeatedly, they start working again.

 

Doesn't a 800XL keyboard fits into a 1200XL?

 

Cheers,

Sijmen.

Share this post


Link to post
Share on other sites
Doesn't a 800XL keyboard fits into a 1200XL?

862594[/snapback]

 

The function key layout is totally different.

 

-Bry

Share this post


Link to post
Share on other sites
This is pretty common on 1200XL's. I've been able to fix several of them by taking the keyboards completely apart, cleaning everything, and reassembling them.

 

    -Bry

862475[/snapback]

 

 

If you do take it apart, be prepared to deal with a lot of screws. A LOT of screws.

Share this post


Link to post
Share on other sites
This is pretty common on 1200XL's. I've been able to fix several of them by taking the keyboards completely apart, cleaning everything, and reassembling them.

 

    -Bry

862475[/snapback]

 

 

If you do take it apart, be prepared to deal with a lot of screws. A LOT of screws.

863194[/snapback]

That's the way it is with almost ALL keyboards, lots of screws to deal with...I've taken apart XL,XE,ST, MAC,C64,C128 and Amiga keyboards and they have all had about 30 screws to remove.

 

But I've yet to have a problem with my 1200XL keyboard and it did sit in my closet and then in a box when I moved, for nearly a year with no use, and I just hooked it up again a month or so ago and it's keyboard is still working perfectly fine...were there more than one revision of the 1200XL that could be the culprit, and my revision doesn't have the problems you guys are refering too?

Edited by Gunstar

Share this post


Link to post
Share on other sites
But I've yet to have a problem with my 1200XL keyboard and it did sit in my closet and then in a box when I moved, for nearly a year with no use, and I just hooked it up again a month or so ago and it's keyboard is still working perfectly fine...were there more than one revision of the 1200XL that could be the culprit, and my revision doesn't have the problems you guys are refering too?

863534[/snapback]

 

If there was a new revision it must not be very wide spread because all but one of the 1200XLs I've had all needed to be refurbed. Thats one out of probably 40 or 50 1200XLs I've outfitted.

 

Steve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...