Jump to content
Sign in to follow this  
pcuser4

XF551 cant read !

Recommended Posts

I tested the Single Density formatted disk on 1050. 1050 can read it. I

insert the same disk in XF551. XF551 still cant read it. XF551 is damaged. I

do not know what part is damaged. I think some chips are malfuctional or

5.25 mechanism. Which one is damaged?

 

Thanks!

Jack

Share this post


Link to post
Share on other sites

First of all, welcome to AtariAge!

 

I would guess that the fault is with the mechanism (does it sound like it's physically having trouble reading the disk?) My recommendation would be to swap it out with another working 360K 5.25-inch drive mech and test it. Just make sure that the DRIVE0 jumper on the drive mech is set correctly first; you'll know that it is if you plug it in and switch on the XF551 and see the drive activity LED flash on for a fraction of a second.

 

If the other mech doesn't work either, you might want to take it out completely and look over the drive's mainboard and see if there's any obvious physical damage. You can also retouch the soldering on the SIO connectors, which is a frequent point of failure with the XF551.

Share this post


Link to post
Share on other sites

Do you have any XF551 diagnositc program to test the XF circuit if it is ok?

 

Which mechanism works with XF551? I tried to use teac, it does not work.

Share this post


Link to post
Share on other sites
Do you have any XF551 diagnositc program to test the XF circuit if it is ok?

 

Which mechanism works with XF551? I tried to use teac, it does not work.

1025544[/snapback]

Unless I'm mistaken, any 360K 5.25-inch drive mech will work with the XF551 as long as the DRIVE0 jumper is set correctly. You'll want to check the documentation for your drive to see how to do this. I'm afraid I haven't seen any diagnostic programs for the XF551, but perhaps someone else on these boards knows of one.

Share this post


Link to post
Share on other sites
How do I check the drive 0? Show me how to check it.

1026124[/snapback]

 

Should be a group of jumpers on the board near the floppy connector. Even a newer model 1.2MB 5.25" I have from the PC days has them-- they're labeled S0-S3 on my drive, and the jumper is on S0.

Share this post


Link to post
Share on other sites

I found the jumper near the most 1.2MB 5.25 drive from the PC. The jumper of drives set D0 or S0. The different drives connect to XF551 board. All the drives can not read and format. The XF551 drive sets D1 that connects to PC, the drive can not read and format! I dont know which part is damaged. Do you think 360K PC drive works with the XF551 board? what else?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...