Jump to content

Photo

CoolCV emulator for Mac OS X, Linux, Windows and Raspberry

Colecovision Emulator Mac Windows

564 replies to this topic

#551 alortegac OFFLINE  

alortegac

    Chopper Commander

  • 194 posts

Posted Wed Jan 23, 2019 5:49 PM

Thanks for your response. May you tell me please the correct display settings for Coolcv to work? Thanks again so much! Al

#552 knievel1 OFFLINE  

knievel1

    Space Invader

  • 41 posts

Posted Wed Jan 23, 2019 5:49 PM

I've got CoolCV 0.6.6 on Mojave - 

 

At the risk of sounding dense, I click on the app to open. Didn't work. 

Then, I tried dragging a game onto the app icon. 

Nope. "CoolCV cannot be opened due to a problem"

 

Downloaded CoolCV all zip from thread here -- am I missing something?

A install step?

 

Tried dragging Buck Rogers SGM to icon as well as the SGM test ROM. 

No luck. 

 

thanks all for the help....



#553 nanochess OFFLINE  

nanochess

    Processorus Polyglotus

  • Topic Starter
  • 5,797 posts
  • Coding something good
  • Location:Mexico City

Posted Wed Jan 23, 2019 5:56 PM


 

thanks all for the help....

 

You need to download and install libSDL https://www.libsdl.o.../SDL2-2.0.9.dmg



#554 knievel1 OFFLINE  

knievel1

    Space Invader

  • 41 posts

Posted Thu Jan 24, 2019 6:44 PM

So for all us iMac users - install libSDL, run the CoolCV application - that's it?



#555 mumbai ONLINE  

mumbai

    Dragonstomper

  • 751 posts

Posted Thu Jan 24, 2019 7:33 PM

So for all us iMac users - install libSDL, run the CoolCV application - that's it?

 

 

Should be, for macOS users. This is a known issue mentioned upthread a while back (posts #338 to #340) where the libSDL packaged in the application bundle isn't (always? sometimes?) recognized as intended.

 

EDIT: "OS X" -> "macOS"


Edited by mumbai, Thu Jan 24, 2019 7:41 PM.


#556 alortegac OFFLINE  

alortegac

    Chopper Commander

  • 194 posts

Posted Sat Jan 26, 2019 12:13 PM

 
Sorry! I don't know what happens. I don't know Launchbox nor I've tested it.
 
If CoolCV already worked in your setup, and doesn't work after installing LaunchBox, and also makes another emulator to fail, then it's pretty probable LaunchBox messed up your display settings.



The problem was the monitor. In case someone ever has a similar issue. I swapped to other monitor...and is now working fine. Weirdest issue.

#557 nanochess OFFLINE  

nanochess

    Processorus Polyglotus

  • Topic Starter
  • 5,797 posts
  • Coding something good
  • Location:Mexico City

Posted Sat Jan 26, 2019 1:25 PM



The problem was the monitor. In case someone ever has a similar issue. I swapped to other monitor...and is now working fine. Weirdest issue.

 

Just searched for problem reports in libSDL and apparently there is a unsolved problem with different DPI settings in separate monitors https://stackoverflo...-second-monitor



#558 bhall408 ONLINE  

bhall408

    Space Invader

  • 45 posts
  • Location:California

Posted Tue Jan 29, 2019 9:56 PM

So for all us iMac users - install libSDL, run the CoolCV application - that's it?

 

Yes, that will get the app to launch (without libSDL it will fail silently).

 

However I do find that the audio can be choppy compared to (for example) OpenEMU.



#559 ColecoJoe OFFLINE  

ColecoJoe

    Dragonstomper

  • 514 posts
  • Location:Whittier, CA

Posted Wed Jan 30, 2019 9:23 AM

 

Yes, that will get the app to launch (without libSDL it will fail silently).

 

However I do find that the audio can be choppy compared to (for example) OpenEMU.

That's weird, I have the opposite problem. By the way, OpenEmu is not a emulator, it's a collection of emulators. I believe it uses CrabEMU for Colecovision roms.



#560 alortegac OFFLINE  

alortegac

    Chopper Commander

  • 194 posts

Posted Wed Jan 30, 2019 9:29 AM

Has anyone tried to set up WiiPro controller via mayflash?. Coolcv does not recognize them at all. Do I need call them differently (other than joy) in the config mappings? I am setting up mayflash in dinput mode, the controller is recognized successfully and it is working properly in all other applications. OS id won 7 64. Thanks!

Edited by alortegac, Wed Jan 30, 2019 9:29 AM.


#561 EVEGames OFFLINE  

EVEGames

    Combat Commando

  • 3 posts

Posted Sun Feb 17, 2019 2:09 PM

@Nanochess,
Glad to see this thread is still chuggin'.
I recently installed CoolCV on a Raspberry Pi Zero W for the first time, and while I got it fully up and running, controller mapped properly, still it runs a bit laggy.
It starts with sound slightly stuttering and it seems to get progressively worse with time while playing a game.
Just wondering if there are any tips or tricks to squeeze additional performance out of CoolCV.

I have not yet gone as far as to overclock my Pi, I want to save that as a last resort.
Any tips from the creator?
Thanks again for all you do with CoolCV!
-Dave



#562 fdr4prez OFFLINE  

fdr4prez

    Stargunner

  • 1,882 posts

Posted Mon Feb 18, 2019 4:08 PM

@Nanochess,
Glad to see this thread is still chuggin'.
I recently installed CoolCV on a Raspberry Pi Zero W for the first time, and while I got it fully up and running, controller mapped properly, still it runs a bit laggy.
It starts with sound slightly stuttering and it seems to get progressively worse with time while playing a game.
Just wondering if there are any tips or tricks to squeeze additional performance out of CoolCV.

I have not yet gone as far as to overclock my Pi, I want to save that as a last resort.
Any tips from the creator?
Thanks again for all you do with CoolCV!
-Dave

 

 

The Pi Zero isn't really overclockable

 

https://www.raspberr...ic.php?t=177743

https://www.raspberr...ic.php?t=127934

and many more topics floating around out there

 

You can try the new RPi3 A+ is you want a smallish formfactor

 

I've used coolcv on my RPi3B builds, but not in my Pi0 builds (for no particular reason).



#563 nanochess OFFLINE  

nanochess

    Processorus Polyglotus

  • Topic Starter
  • 5,797 posts
  • Coding something good
  • Location:Mexico City

Posted Mon Feb 18, 2019 5:18 PM

@Nanochess,
Glad to see this thread is still chuggin'.
I recently installed CoolCV on a Raspberry Pi Zero W for the first time, and while I got it fully up and running, controller mapped properly, still it runs a bit laggy.
It starts with sound slightly stuttering and it seems to get progressively worse with time while playing a game.
Just wondering if there are any tips or tricks to squeeze additional performance out of CoolCV.

I have not yet gone as far as to overclock my Pi, I want to save that as a last resort.
Any tips from the creator?
Thanks again for all you do with CoolCV!
-Dave

 

I don't have tested with Pi Zero, but it has performance equal less perfomance in comparison to Pi 2. I remember overclocking the Pi 2 to get the required speed but once I updated the base system it got slow again.

 

As I've been using Pi 3 I don't have yet returned to it to check if I can improve perfomance. Sorry.



#564 fdr4prez OFFLINE  

fdr4prez

    Stargunner

  • 1,882 posts

Posted Mon Feb 18, 2019 6:32 PM

 

I don't have tested with Pi Zero, but it has performance equal to Pi 2. I remember overclocking the Pi 2 to get the required speed but once I updated the base system it got slow again.

 

As I've been using Pi 3 I don't have yet returned to it to check if I can improve performance. Sorry.

 

The performance of the Pi0 and the Pi2 are not quite the same.

 

The Pi0 has 1-core CPU @1000MHz (1GHz) and 512MB of ram, but the Pi2 had 4-core CPU @900MHz and 1GB of ram

 

There is a fairly complete comparison chart:

http://socialcompare...dels-comparison



#565 nanochess OFFLINE  

nanochess

    Processorus Polyglotus

  • Topic Starter
  • 5,797 posts
  • Coding something good
  • Location:Mexico City

Posted Mon Feb 18, 2019 6:58 PM

I stand corrected





Also tagged with one or more of these keywords: Colecovision, Emulator, Mac, Windows

2 user(s) are browsing this forum

1 members, 1 guests, 0 anonymous users