Jump to content

Photo

Mouse button issues on my Geneve

Geneve

4 replies to this topic

#1 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,554 posts
  • Location:Germany

Posted Tue Jan 30, 2018 5:10 AM

Well, I suppose my Geneve is getting old. I hoped to finish everything in MAME before its time has come, but the first symptom showed up yesterday.

 

The right mouse button is reported to be pressed rapidly when it is not. In my Fractals program, the right mouse button is used to show the menu line with the pull-down menus, and now this line is flickering. Also, I tried a test program for the mouse, and the "right button" text flickers on the screen.

 

Too bad this still happens when I unplug the mouse.

 

When I press the button, the flickering stops, and the button is correctly detected. So it seems as if the unpressed state has become unstable.

 

The right mouse button is checked by the v9938 (unlike the left button which is checked via CRU). My theory is that the pull-up resistor on the Geneve board has gone bad. At least this would be the preferred explanation, since I could fix this with a soldering iron. Other ideas?



#2 mizapf OFFLINE  

mizapf

    River Patroller

  • Topic Starter
  • 3,554 posts
  • Location:Germany

Posted Wed Feb 28, 2018 6:47 AM

Phew, as it seems, I was able to fix it. Using a multimeter, I found that the resistor network RN30 is broken right in the middle; pins 6-10 are dead. Most of them are pullups for unused output, but not pin 10 which pulls up the mouse button input line to the v9938. On the mouse port, pin 6 is the affected mouse button, pin 8 is +5V.

 

I'm not going to earn a prize for soldering art, but it does its job.

Attached Files


Edited by mizapf, Wed Feb 28, 2018 6:48 AM.


#3 Opry99er OFFLINE  

Opry99er

    Quadrunner

  • 10,670 posts
  • Location:Hustisford, WI

Posted Wed Feb 28, 2018 9:49 AM

Good news indeed

#4 Swim OFFLINE  

Swim

    Chopper Commander

  • 158 posts
  • Location:Staten Island

Posted Wed Feb 28, 2018 12:57 PM

This used to be an uncommon problem but as our Geneves continue to age and thermal cycles add up it's becoming more common. 



#5 mizapf OFFLINE  

mizapf

    River Patroller

  • Topic Starter
  • 3,554 posts
  • Location:Germany

Posted Wed Feb 28, 2018 5:22 PM

The only critical point with RN30 (see the schematics) is that one of its resistors is used to pull up the outgoing MEMEN* line behind the LS244 (U29, lower left part of the schematics). Hence, this does not work anymore on my Geneve, but on the other hand, there is no visible malfunction.







Also tagged with one or more of these keywords: Geneve

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users