Jump to content

Photo

SGM stopped working


2 replies to this topic

#1 Hastor OFFLINE  

Hastor

    Chopper Commander

  • 111 posts

Posted Sat Jun 2, 2018 10:14 PM

So my Colecovision has been on my shelf, my Super Game Module in its box, since the last time I used them several months ago. Mine is from the 3rd run. I've been dealing with some family health issues that had my mind on other things. Though at the same time many SGM-requiring games I'd ordered showed up, so I've got quite the large collection of SGM games now.

 

However, I sat down to play for the first time since my life calmed down, and all SGM games just give a message saying that it is required. It is connected, the power light comes on. The Atari adapter works on my expansion slot as well. I didn't have any issues before, it just worked fine. Now the same games that worked previously just give this message. Looking for any advice, since I can't order a new one right now, but have hundreds of dollars worth of games I'd like to play.

 

All other games work fine, including the AtariMax SD cart.


Edited by Hastor, Sat Jun 2, 2018 10:15 PM.


#2 rodge2001 OFFLINE  

rodge2001

    Chopper Commander

  • 100 posts

Posted Mon Jun 4, 2018 4:43 PM

My expansion port was not working at all until after I gave the contacts inside a really good cleaning.  Otherwise it might be the SGM itself.  I know Opcode is busy but it wouldn't hurt to reach out and see if they can look at it for you.  I have a 3rd run SGM that I acquired form eBay that had issues and Opcode was kind enough to evaluate it for me.  Now my 3rd run SGM works almost perfectly except for two issues: #1, it won't work with King's Valley ROM from my AtariMax SD cart which gives me same message that you are receiving.  #2, it won't work with a bootleg Mario Bros cart I acquired prior to an finding an authentic Mario Bros CIB.  Otherwise it's working fine but I think I may purchase a second one in the future as a back-up.  I meant to just the other day but they sold out so quickly from AtariAge store.  I know there is a SGM diagnostic test you can perform by holding the # button prior to loading a SGM game and the result may be useful in diagnosing any issues your SGM may be having. 



#3 Hastor OFFLINE  

Hastor

    Chopper Commander

  • Topic Starter
  • 111 posts

Posted Mon Jun 4, 2018 5:02 PM

Thanks for the info, I did reach out to Opcode and might send it to them for diagnostics. A friend is letting me borrow his by mail, though he hasn't used it in a long time either. If it works, I know it is the SGM. If it doesn't, I might still send mine in for diagnostics cause I'm not 100% sure his is fine, while I look for a new console (after of course taking mine apart and checking for visible damage to the port). The SGM and console both worked great, and the pins on my console look pristine. I did clean them a little to be sure, but it didn't change anything. Even if I was lucky when it worked a few months ago, I'd think the 25 or so tries I've given of plugging/removing it would have resulted in one success if there wasn't damage to either the SGM or the console. I don't know who might have dropped what and not told me after all lol.

 

I tried holding down # while powering the system on with the SGM installed but it resulted in the same message. I tried on each controller, but no change in behavior. Does this apply to all SGM games? I was trying with Penguin Adventure. All games and everything worked great a few months ago. I do also use the Module 1 adapter for Atari games and it works great.

 

If it does end up being my system, I'm going to look for either someone to do mods, or some help, as the one I currently have has really clear RCA output, an internal power supply, and some other mods. Nothing that would affect the SGM though. Also, despite having several ways to play Atari VCS cartridges, using module 1 on this gives me a clearer picture than any of my other methods including an RCA mod on an actual VCS. Would break my heart, I love this awesome system, and would do my best to re-create it. The person I commissioned it from doesn't seem to be active online anymore.

 

I figure it can't be anything worse than a bad trace between the expansion port, which looks like it goes right to the cartridge port mostly. I'm no hardware expert, but can solder, test traces with a multimeter, and have done quite a few mods myself. I just prefer to pay an expert that's done it a million times to do it right when I can.


Edited by Hastor, Mon Jun 4, 2018 5:12 PM.





0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users