Jump to content


"Prefetching or prechaching is not allowed" message

3 replies to this topic

#1 kevtris OFFLINE  



  • 735 posts
  • FPGA Whisperer
  • Location:Flyover, USA

Posted Fri Jun 8, 2018 8:00 PM

After I upgraded to the latest version of Firefox awhile back, I keep getting the following message sometimes:


"Prefetching or precaching is not allowed. If you have Google Accelerator enabled, please disable"


I am using Firefox, so I am not using Google Accelerator.   This happens if I visit the last page of a thread and hit the "previous page" link, then hit back on my browser (to go to the last page of the thread so I can read it in order).  i.e. if a thread has 150 pages, I click the "last page" link in the forum thread list, then hit "previous page" to go to page 149, then "previous page" again to go to page 148, which would be where I left off reading it.


After reading page 148, I hit back on the browser which should take me to page 149, but instead I get the above message. I have to refresh the page and then the page is viewable.  Likewise, hitting back again should get me now to page 150 which is the end of the thread, so hitting back once more returns me to the forum thread list.   The weird thing is the previous pages should be precached by my browser anyways as I visited them in reverse order.  I guess I tend to view the ends of forum threads in RPN format.


Not all the time will it give this error, but it's been happening for over a month now since I upgraded Firefox.  I have been reading forums in this fashion for quite awhile now and haven't had any problems up to that point.  It does not happen on any other forum.


#2 Albert OFFLINE  



  • 35,099 posts

Posted Fri Jun 8, 2018 8:21 PM

This looks to be an issue with Firefox and Invision Power Board (the forum we're running).  After doing a bit of reading, it seems Firefox can be aggressive in prefetching links, even though technically it should not do so unless there is a "prefetch" tag associated with the link.  Looks like Firefox does not always honor that setting.  A search for the above error string reveals where this has been discussed on several Invision forums. 


You can disable prefetching in Firefox here: 




The forum does have a setting to prevent prefetching (which is a potential drain on server resources), and the default is "YES".  I did just toggle the setting to allow prefetching, which will prevent the error (I took a look at the forum source), but if I see a spike in server load as a result, I will turn it back off. 



#3 kevtris OFFLINE  



  • Topic Starter
  • 735 posts
  • FPGA Whisperer
  • Location:Flyover, USA

Posted Sat Jun 9, 2018 1:05 AM

thanks!  I just turned prefetching off in FF now as well. 

#4 Kosmic Stardust OFFLINE  

Kosmic Stardust

    Princess Rescuer

  • 18,290 posts
  • Location:Milky Way Galaxy

Posted Sat Jun 9, 2018 1:13 AM

I have gotten this error as well. I just hit refresh and move on with it. If it is really causing a drain on the server, I have no qualms about Albert disabling it. If nothing else so that 5% of rougue users (including bots) consume 95% of bandwidth. :ponder:

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users