Jump to content

Photo

Atari 2600 composite mod not working

Composite broken black screen help troubleshooting

5 replies to this topic

#1 kalgran OFFLINE  

kalgran

    Combat Commando

  • 2 posts

Posted Sun Jan 13, 2019 10:59 PM

Hey guys. I've seen a lot of good help on this forum that I've used to help me diagnose my Atari 2600 4-switch that has not worked ever since I tried to install a widely used composite mod. (Kit Link Here) I installed it using an instructable (Instructable Link Here) I followed all instructions including removing q202, r209, r222, and c205, aaaaand... nothing it didn't work.

 

(note: when I say nothing, I mean the TV says no signal.)

I suspected bad connections but that wasn't it. I tried re-soldering the old components and that did something for a while but then it stopped. Next I thought that it wasn't getting enough power so I checked the power supply and 5v reg. Both were just fine except the 5v Reg had 2 of it's pins crossed. After uncrossing them I got some video for about two seconds and then it quit. (see attached video) I thought it was the chips now so I replaced all 3 (TIA, RIOT, and CPU) and this put me back to the same old no signal screen. I tried the old chips on a working system (w/o composite mod) and they gave a black screen. 

 

Not sure what to do at this point. Nothing is abnormally hot. Maybe my somewhat noob soldering skills maybe be a problem

 

Cheers, kalgran

Attached Thumbnails

  • Pins Crossed.JPG
  • Current Overview.jpeg

Attached Files



#2 ChildOfCv OFFLINE  

ChildOfCv

    Star Raider

  • 81 posts

Posted Mon Jan 14, 2019 3:53 AM

That looks like a nasty solder bridge where the green wire connects to the main board.  At the least, you should probably remove a few pounds of solder from that area.


Edited by ChildOfCv, Mon Jan 14, 2019 3:54 AM.


#3 Nickp716 OFFLINE  

Nickp716

    Combat Commando

  • 7 posts

Posted Mon Jan 14, 2019 3:12 PM

 I had this same kit as you from Ebay, I installed it in a fully functioning 4 switch woody that had a total re-cap, and it did not work either. (Im no noob when it comes to soldering, and have been doing it for years.) i had no picture whatsoever, nor sound. I read somewhere that the resistors included are just not strong enough to drive a modern tv. I also heard its more likely a success with a 6 switch over a 4, I cannot validate this as I have not tried.I ended up returning it. sorry to see your having the same problem. 



#4 ChildOfCv OFFLINE  

ChildOfCv

    Star Raider

  • 81 posts

Posted Tue Jan 15, 2019 12:05 PM

So, do the borrowed chips still work in the original 2600?  That's the first step in troubleshooting.  But you also said that the chips from this modded 2600 didn't work in the other working unit?

 

Anyway, as I figured, the composite mod is way too complicated in what it says to do.  This guy managed to do it by only removing 3 parts, and by the schematic I don't see why L201 needed to be removed.  He's primarily doing a PAL mod, but does show what needs to happen for a 4-switch NTSC model.

 

https://www.thefutur...m/2600_comp_mod

 

The first thing you should do is look for Youtube videos on proper solder technique.  Then practice on some electronics that you don't care about.

 

Second thing, try to restore the mod system to original to see if you can get it to work again.  Finally, try the mod above.


Edited by ChildOfCv, Tue Jan 15, 2019 12:06 PM.


#5 kalgran OFFLINE  

kalgran

    Combat Commando

  • Topic Starter
  • 2 posts

Posted Tue Jan 15, 2019 11:12 PM

Thanks for the feedback! I realize that I haven't actually worked on this project for a couple months. I've been working on my soldering so I've since cleaned up the board and fixed those really nasty bridges and such. Looking at proper soldering videos really helped. Thx ChildOfCV.  :thumbsup:

@Nickp716 thanks for the info about the composite kit that I have. It seems that it is kind of a cruddy kit so is there one that anybody has used that they would suggest?

 

None of the chips seem to be working now. The 6'er that I have that WAS working is only giving a black screen now (with either chip set). Is there any way I can use a multi-meter to test the any of the chips?



#6 ChildOfCv OFFLINE  

ChildOfCv

    Star Raider

  • 81 posts

Posted Yesterday, 4:53 AM

Not good.  Well, first I'd suggest you get a logic probe.  Something like this:  https://www.amazon.c...rds=logic probe

 

You can use it to look for signals on various pins, which should tell you which chip(s) are now dead.  A straight multimeter won't be good for much unless it has a frequency function.  It can tell you that voltages are present, but that's about it.







Also tagged with one or more of these keywords: Composite, broken, black screen, help, troubleshooting

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users